Choose style:

Author Topic: RDP to Peppermint 10 fails with blank screen  (Read 159 times)

0 Members and 1 Guest are viewing this topic.

Offline JonMikelV

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
RDP to Peppermint 10 fails with blank screen
« on: March 06, 2020, 01:49:13 am »
Likely not related, but in the interest of full disclosure I'm trying out Peppermint 10 in a QEMU VM.

Since PP10 uses HWE I've installed xorgxrdp and can connect (get a login prompt) but after logging in get a blank screen for about three minutes followed by a rather generic sesman error message.

I'm coming from a Windows machine that only has Remote Desktop (RDP protocol) installed so using something like VNC or Teamviewer isn't an option - it has to be RDP.

Since I'm still testing and using a VM I'm happy to try different things and wipe / reinstall the VM as much as necessary - which is good because some of the proposed XRDP fixes out there can break keyboard & mouse input if one isn't careful  :-)

Has anybody managed to get the RDP protocol server working with PP10?

Thanks!

Offline JonMikelV

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: RDP to Peppermint 10 fails with blank screen
« Reply #1 on: March 06, 2020, 05:11:57 pm »
For those following along, I did a fresh Peppermint 10 install on a VM then ran the following:
Code: [Select]
sudo apt-get update
sudo apt-get install xrdp xorgxrdp-hwe-18.04
sudo systemctl enable xrdp
sudo systemctl start xrdp

Now I can connect via RDP but get a BLACK screen (instead of an error message).  Ctrl-Alt-T brings up the terminal allowing me to poke around at which point I found "No window manager registered on screen 0" in my ~/.cache/lxsession/LXDE/run.log.

Still trying to figure out how to handle that.  :-)

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2087
  • Karma: 373
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: RDP to Peppermint 10 fails with blank screen
« Reply #2 on: March 06, 2020, 06:23:07 pm »
Can you add the switch --disable-wm-check to the start command? What happens then?

Offline JonMikelV

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: RDP to Peppermint 10 fails with blank screen
« Reply #3 on: March 09, 2020, 01:34:21 pm »
Thanks for the suggestion!  Unfortunately, I think I missed something - what 'start' command should I be adding --disabled-wm-check to?

Is it something that should be in a ".xxx" file (like .xsession) or is this just a test I should be doing from terminal (like 'startx --disabled-wm-check' - which just tells me I need to install xinit)?

I'm fairly skilled with computers in general, but not so much yet  with window managers (which I assume is where I'm having trouble).
« Last Edit: March 09, 2020, 01:49:22 pm by JonMikelV »

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2087
  • Karma: 373
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: RDP to Peppermint 10 fails with blank screen
« Reply #4 on: March 09, 2020, 02:42:46 pm »
I don't use virtual machines or RDP, I just looked up your error message. Is there any other way to start it other than as a service?