Choose style:

Author Topic: Nvidia Graphics Lag (SOLVED)  (Read 252 times)

0 Members and 1 Guest are viewing this topic.

Offline al3xsh

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Nvidia Graphics Lag (SOLVED)
« on: December 09, 2019, 04:38:19 am »
Hi all,

I've recently switched to Peppermint 10 on both desktop and laptop - but am having a strange issue on my desktop installation! With the 5.0.x kernel and the nvidia drivers (435), I get huge (as in unusable) mouse pointer lag. I have switched back to using the 4.18.x kernel, which sort of solves the problem - apart from at the lock screen!

The problem didn't seem to occur using the 390 drivers (even with the 5.0.x kernel) - but I need the 435 series (or later) for the CUDA 10.1 support!

Any ideas or suggestions??

Regards,

Alex

p.s. apart from this issue - Peppermint is awesome :)
« Last Edit: December 14, 2019, 07:01:32 am by PCNetSpec, Reason: marked as (SOLVED) »

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3230
  • Karma: 616
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Nvidia Graphics Lag
« Reply #1 on: December 09, 2019, 04:56:27 am »
you could try adding the nvidia ppa and seeing if the 440 drivers are any better.

regards Zeb...

sent from mobile...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline al3xsh

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Nvidia Graphics Lag
« Reply #2 on: December 09, 2019, 10:44:10 am »
Hi,

Thanks for your reply - I have installed nvidia-driver-440 package, but it doesn't make any difference.

I have now replaced

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1"

with

GRUB_CMDLINE_LINUX_DEFAULT=""

which stops the lag - but makes the lock screen really low resolution! 

I know it's a really minor thing, but I'd like to fix it if you have any other ideas?

Regards,

Alex

Offline al3xsh

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Nvidia Graphics Lag
« Reply #3 on: December 11, 2019, 09:22:46 am »
I *think* I have found a solution to this issue ...

This thread: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1757202 suggests that the login screen resolution (and lag) issue might be a problem with the x server looking in the wrong place for the module path.

I have used the work around listed in that thread:

1. Create an xorg.conf file for your nVidia device. All you have to do for this is to launch the command:

sudo nvidia-xconfig

This will create a file /etc/X11/xorg.conf.

2. Edit the created file /etc/X11/xorg.conf and add at the end the lines:

Section "Files"
 ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
 ModulePath "/usr/lib/xorg/modules"
EndSection

3. Save and restart the X server.

And this *seems* to have fixed it for both the 5.0.x kernel issue and the log in screen issue.

Regards,

Alex

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nvidia Graphics Lag
« Reply #4 on: December 14, 2019, 06:59:38 am »
Fantastic news al3xsh, thanks for taking the time to post your working solution .. it all helps build the knowledge base :)

[EDIT]

Hope you don't mind but I've marked the topic (SOLVED) to hopefully guide others to a workable solution.
« Last Edit: December 14, 2019, 07:02:48 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec