Choose style:

Author Topic: Trouble with Geany Plugins on my laptop...  (Read 292 times)

0 Members and 1 Guest are viewing this topic.

Offline Mynaardt

  • Member
  • ***
  • Posts: 160
  • Karma: 18
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Trouble with Geany Plugins on my laptop...
« on: December 14, 2019, 02:53:19 am »
Hi, All!

I've been happily using Geany for a while now, on Peppermint 9.

Funny thing is, though, I had no problem getting and using Geany plugins for my desktop computer.

But for some odd reason, I can't seem to get them to work for Geany on my laptop.

I look in Synaptic, and it seems to tell me I've installed the plugins, but I get a lot of exclamation marks on Geany plugins on a search, which seems to indicate something's amiss.

Anyway, except for Geany plugins, which don't seem to work at all on my laptop, everything else in Geany seems to be working fine.

Anyone knows why this might be?  And if so, how can I fix it?

Thanks in advance!
~*~  Mynaardt  ~*~
(Victoria, BC, Canada)
Peppermint OS is your computer's friend,
Always Trust Peppermint OS!

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1870
  • Karma: 488
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Trouble with Geany Plugins on my laptop...
« Reply #1 on: December 14, 2019, 04:48:13 am »
I look in Synaptic, and it seems to tell me I've installed the plugins, but I get a lot of exclamation marks on Geany plugins on a search, which seems to indicate something's amiss.

Hi Mynaardt,

Could you explain that a bit more clearly? Where are you performing the search? In synaptic:-\

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline Mynaardt

  • Member
  • ***
  • Posts: 160
  • Karma: 18
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Trouble with Geany Plugins on my laptop...
« Reply #2 on: December 14, 2019, 12:27:15 pm »
Hi Slim.Fatz:

Sorry about that, I probably should've posted that earlier in the day...   ::)

But anyway...

First of all, I tried to install Geany plugins some time back.  Unfortunately I can't remember if I did that via the terminal, the software manager or synaptic.

But when I open Geany, and go to the edit menu, the plugin preferences option is greyed out so that I cannot select it.

So, I tried looking up 'geany-plugin' in Synaptic, and instead of the usual yellow plus for uninstalled or white check on green for installed, all I get is a blue box with an exclamation mark.

When I try marking those for updating, I just get an error message about broken dependencies or some such.

Just seems a bit odd, because I'm only having this problem with my ThinkPad laptop, and not my desktop machine.

Everything else seems to work just fine in Geany on my laptop otherwise.  I just can't seem to access plugins at all for some reason.

Should I reinstall Geany from scratch, perhaps?  And if so, should I use the terminal/ppa thing, snap, synaptic, or the software manager?

Hardly a life and death thing, but it would be nice to be able to use plug ins.

Thanks!

I look in Synaptic, and it seems to tell me I've installed the plugins, but I get a lot of exclamation marks on Geany plugins on a search, which seems to indicate something's amiss.

Hi Mynaardt,

Could you explain that a bit more clearly? Where are you performing the search? In synaptic:-\

Regards,

-- Slim
~*~  Mynaardt  ~*~
(Victoria, BC, Canada)
Peppermint OS is your computer's friend,
Always Trust Peppermint OS!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26468
  • Karma: 2870
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Trouble with Geany Plugins on my laptop...
« Reply #3 on: December 14, 2019, 01:40:10 pm »
What's the output from
Code: [Select]
dpkg -l | grep geany
and
Code: [Select]
snap list
and
Code: [Select]
flatpak list
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Mynaardt

  • Member
  • ***
  • Posts: 160
  • Karma: 18
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Trouble with Geany Plugins on my laptop...
« Reply #4 on: December 14, 2019, 04:51:56 pm »
Hi, PCNetSpec (it's been a while):

Here's what I got:


1. From dpkg -l | grep geany

Code: [Select]
ii  geany                                 1.36-1~16.04                                    amd64        fast and lightweight IDE
ii  geany-common                          1.36-1~16.04                                    all          fast and lightweight IDE -- common files
ii  geany-plugin-addons                   1.36+dfsg-1~16.04                               amd64        miscellaneous plugins for Geany
ii  geany-plugin-autoclose                1.36+dfsg-1~16.04                               amd64        auto-closing plugin for Geany
ii  geany-plugin-automark                 1.36+dfsg-1~16.04                               amd64        auto-mark plugin for Geany
ii  geany-plugin-codenav                  1.36+dfsg-1~16.04                               amd64        code navigation plugin for Geany
ii  geany-plugin-commander                1.36+dfsg-1~16.04                               amd64        command panel plugin for Geany
ii  geany-plugin-ctags                    1.36+dfsg-1~16.04                               amd64        ctags plugin for Geany
ii  geany-plugin-defineformat             1.36+dfsg-1~16.04                               amd64        on-the-fly #define prettyprinter plugin for Geany
ii  geany-plugin-doc                      1.36+dfsg-1~16.04                               amd64        documentation plugin for Geany
ii  geany-plugin-extrasel                 1.36+dfsg-1~16.04                               amd64        extra selection plugin for Geany
ii  geany-plugin-gendoc                   1.36+dfsg-1~16.04                               amd64        documentation generation plugin for Geany
ii  geany-plugin-geniuspaste              1.36+dfsg-1~16.04                               amd64        GeniusPaste plugin for Geany
ii  geany-plugin-gproject                 1.36+dfsg-1~16.04                               all          transitional dummy package for geany-plugin-projectorganizer
ii  geany-plugin-insertnum                1.36+dfsg-1~16.04                               amd64        number inserting plugin for Geany
ii  geany-plugin-keyrecord                1.36+dfsg-1~16.04                               amd64        git change bar plugin for Geany
ii  geany-plugin-latex                    1.36+dfsg-1~16.04                               amd64        improved LaTeX support plugin for Geany
ii  geany-plugin-lineoperations           1.36+dfsg-1~16.04                               amd64        Line Operations plugin for Geany
ii  geany-plugin-lipsum                   1.36+dfsg-1~16.04                               amd64        Lorem Ipsum generator plugin for Geany
ii  geany-plugin-lua                      1.36+dfsg-1~16.04                               amd64        Lua scripting plugin for Geany
ii  geany-plugin-macro                    1.36+dfsg-1~16.04                               amd64        macro plugin for Geany
ii  geany-plugin-miniscript               1.36+dfsg-1~16.04                               amd64        Geany Mini-Script filter plugin
ii  geany-plugin-numberedbookmarks        1.36+dfsg-1~16.04                               amd64        numbered bookmarks plugin for Geany
ii  geany-plugin-overview                 1.36+dfsg-1~16.04                               amd64        overview plugin for Geany
ii  geany-plugin-pairtaghighlighter       1.36+dfsg-1~16.04                               amd64        tag pair highlighter plugin for Geany
ii  geany-plugin-pg                       1.36+dfsg-1~16.04                               amd64        pg plugin for Geany
ii  geany-plugin-pohelper                 1.36+dfsg-1~16.04                               amd64        Geany plugin for improved support for GetText translation files
ii  geany-plugin-prettyprinter            1.36+dfsg-1~16.04                               amd64        XML pretty printer for Geany
ii  geany-plugin-prj                      1.36+dfsg-1~16.04                               amd64        alternative project manager for Geany
ii  geany-plugin-projectorganizer         1.36+dfsg-1~16.04                               amd64        projectorganizer plugin for Geany
ii  geany-plugin-sendmail                 1.36+dfsg-1~16.04                               amd64        mailer plugin for Geany
ii  geany-plugin-shiftcolumn              1.36+dfsg-1~16.04                               amd64        text column shifting plugin for Geany
ii  geany-plugin-spellcheck               1.36+dfsg-1~16.04                               amd64        spellcheck plugin for Geany
ii  geany-plugin-tableconvert             1.36+dfsg-1~16.04                               amd64        table convert plugin for Geany
ii  geany-plugin-treebrowser              1.36+dfsg-1~16.04                               amd64        tree browser plugin for Geany
ii  geany-plugin-updatechecker            1.36+dfsg-1~16.04                               amd64        update checker plugin for Geany
ii  geany-plugin-vc                       1.36+dfsg-1~16.04                               amd64        VCS plugin for Geany
ii  geany-plugin-xmlsnippets              1.36+dfsg-1~16.04                               amd64        XMLSnippets plugin for Geany
ii  geany-plugins-common                  1.36+dfsg-1~16.04                               amd64        set of plugins for Geany (translations)

2. from snap list ...
Code: [Select]
Name    Version           Rev   Tracking  Publisher   Notes
core    16-2.42.5         8268  stable    canonical✓  core
midori  v8.0-31-gf6b3b1e  550   stable    kalikiana   -

3. from flatpak list
     nothing


What's the output from
Code: [Select]
dpkg -l | grep geany
and
Code: [Select]
snap list
and
Code: [Select]
flatpak list
~*~  Mynaardt  ~*~
(Victoria, BC, Canada)
Peppermint OS is your computer's friend,
Always Trust Peppermint OS!

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1870
  • Karma: 488
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Trouble with Geany Plugins on my laptop...
« Reply #5 on: December 15, 2019, 05:52:55 am »
Hi Mynaardt,

Thanks for the clarification! Try this (if you have not tried it already): open synaptic and click on the Reload button (in upper left corner). After the reload finishes, click on the menu item named Edit (at the top of the synaptic window), then click on the item in the drop-down list named Fix Broken Packages and see if this solves your problem. If it does not, then I would try removing them and then re-installing them from within synaptic.

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline Mynaardt

  • Member
  • ***
  • Posts: 160
  • Karma: 18
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Trouble with Geany Plugins on my laptop...
« Reply #6 on: December 17, 2019, 01:42:13 am »
Hi, Slim.Fatz:

No such luck!

Tried to fix packages and nothing happened.

Did a complete removal of Geany via Synaptics, then a reinstall.  Twice...

Still can't access any plugins after installing some.

Just seems odd that it worked on my desktop but plugins just won't appear on my laptop.   ???

Nothing there I really need to have, though, so I'm not too worried about it...

Hi Mynaardt,

Thanks for the clarification! Try this (if you have not tried it already): open synaptic and click on the Reload button (in upper left corner). After the reload finishes, click on the menu item named Edit (at the top of the synaptic window), then click on the item in the drop-down list named Fix Broken Packages and see if this solves your problem. If it does not, then I would try removing them and then re-installing them from within synaptic.

Regards,

-- Slim
~*~  Mynaardt  ~*~
(Victoria, BC, Canada)
Peppermint OS is your computer's friend,
Always Trust Peppermint OS!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26468
  • Karma: 2870
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Trouble with Geany Plugins on my laptop...
« Reply #7 on: December 17, 2019, 03:57:26 am »
When uninstalling then reinstalling did you check to see if there were any Geany directories left over in say

~/.config

or

~/.local/share

?



Personally when uninstalling something I:-

a) uninstall it

b) run:
Code: [Select]
sudo updatedb
c) run (in this case):
Code: [Select]
locate -i geany
to see if anything was left behind.

d) manually delete anything that was left behind.
« Last Edit: December 17, 2019, 04:00:14 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec