Author Topic: Pulse Audio Equalizer stopped working. (SOLVED)  (Read 644 times)

Offline GEMS

  • Member
  • ***
  • Posts: 99
  • Karma: 6
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Pulse Audio Equalizer stopped working. (SOLVED)
« on: December 11, 2019, 07:37:55 pm »
Spoiler (click here to view / hide)
[close]

Pulse Audio Equalizer just stopped working. I used it last night and saved a profile. When calling it up using VLC to fine tune a video I was watching today; nothing happened when I executed the panel icon. Thereafter, I tried to execute it from the Menu. No good. Uninstalled thru the Software Manager. Rebooted. Ran Terminal...update...upgrade...autoremove...autoclean. Rebooted. Reinstalled thru the Software Manager. Re installed a icon on the panel. Still when I left click the icon, or try to execute thru the menu; NOTA.

What did I do wrong? Thanks in advance for your support.

GEMS.

« Last Edit: December 14, 2019, 12:06:01 pm by GEMS »

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2343
  • Karma: 616
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Pulse Audio Equalizer stopped working.
« Reply #1 on: December 12, 2019, 01:20:00 am »
Hi GEMS,

Open a terminal and run this command to try to start the equalizer:

Code: [Select]
qpaeq
and post the output that you get back here in your next post. Note that the command uses the letter 'Q' twice (just in case it is difficult to read in the posted command). When I did this to run the equalizer (which I have never used) I got this output:

Code: [Select]
sf@Asperger ~ $ qpaeq
There was an error connecting to pulseaudio, please make sure you have the pulseaudio dbus module loaded, exiting...
Since I do not use the equalizer, this does not matter to me. But if you get this error message, then someone here can probably assist you better than I can.

Regards,

-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Pulse Audio Equalizer stopped working.
« Reply #2 on: December 12, 2019, 02:13:17 am »
Can you post the contents of
Code: [Select]
xed /etc/pulse/default.pabecause my guess is you accepted the default pulseaudio config file during the installation of the recent  pulseaudio update (as opposed to electing to keeping your current config file).

My guess (as Slim.Fatz suggests) is your 'new' default.pa file won't contain (usually at the very bottom) the lines:-
Code: [Select]
### Added to make pulseaudio-equalizer work
load-module  module-dbus-protocol
# load-module module-equalizer-sink
If those lines don't exist, add them, save the file, log off and on again, then test the equalizer.
« Last Edit: December 12, 2019, 02:19:08 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2170
  • Karma: 450
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Pulse Audio Equalizer stopped working.
« Reply #3 on: December 12, 2019, 05:05:34 am »
I didn't have this problem, I don't think. But on PM7 the Pulseaudio update somehow brought back snapd and apparmor which I had removed. I let mintupdate install those and then purged them again in the terminal.

Offline Oberon

  • Newly Subscribed
  • *
  • Posts: 4
  • Karma: 1
  • New Forum User
    • View Profile
Re: Pulse Audio Equalizer stopped working.
« Reply #4 on: December 12, 2019, 06:16:39 am »
hey guys... had this same problem this morning after upgrading last nite... yep PCNetSpec that worked great for me..only as a noob it took a minute to realize I had to do this as root... :)  too many years of Windows...! ;D

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5844
  • Karma: 1132
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Pulse Audio Equalizer stopped working.
« Reply #5 on: December 12, 2019, 06:45:33 am »
This happened to me in November; and, It was a *itch to fix: https://is.gd/V0OqJd

The 'fix' held up, even through the recent PulseAudio upgrade, but...

When one is performing the new PulseAudio upgrade, make sure to allow the config change, when it asks.

I checked the diffs, and to my way of thinking, disallowing the change will likely bork PulseAudio  ::)

Just saying...

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5844
  • Karma: 1132
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Pulse Audio Equalizer stopped working.
« Reply #6 on: December 12, 2019, 06:49:59 am »
I didn't have this problem, I don't think. But on PM7 the Pulseaudio update somehow brought back snapd and apparmor which I had removed. I let mintupdate install those and then purged them again in the terminal.

I'm still running PM7 on my 'Road Warrior', and luckily noticed those unsavory additions before clicking 'Install'.

Don't know why they're sneaking those bastards in the back door, but I'm not having any of it...  :P

Offline GEMS

  • Member
  • ***
  • Posts: 99
  • Karma: 6
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Pulse Audio Equalizer stopped working.
« Reply #7 on: December 12, 2019, 01:50:15 pm »
PCNetSpec,
Spoiler (click here to view / hide)
[close]

Spoiler (click here to view / hide)
[close]

The first one was when all of a sudden the screen went white with all this info.
The second one was what resulted from the Terminal screen.

GEMS.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Pulse Audio Equalizer stopped working.
« Reply #8 on: December 12, 2019, 02:40:49 pm »
@GEMS

Ignore those Gtk warnings when starting xed (the text editor) from the terminal, they're unimportant and have no detrimental effects.

Make the changes I suggested .. ie:-

Run
Code: [Select]
gksudo xed /etc/pulse/default.pawhen it opens, make it read:-
Code: [Select]
#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
.ifexists module-switch-on-connect.so
load-module module-switch-on-connect
.endif

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Block audio recording for snap confined packages unless they have
### the "pulseaudio" or "audio-record" interfaces plugged.
.ifexists module-snap-policy.so
load-module module-snap-policy
.endif

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input

### Added to make pulseaudio-equalizer work
load-module  module-dbus-protocol
# load-module module-equalizer-sink
SAVE the file and exit the text editor.

Now log off/on (or reboot)

and finally test the PulseAudio Equalizer.



@VinDSL

Quote from: VinDSL
When one is performing the new PulseAudio upgrade, make sure to allow the config change, when it asks.

This is wrong Mr Dizzle .. the trick is to KEEP your current config, NOT accept the new (default) one which doesn't contain our edit.

Ie. Select 'N' to keep your current copy of default.pa

[EDIT]

In any case this will be irrelevant in the Respin (which would have been unaffected whichever you chose) :)

[EDIT 2]

Personally if any update asks if I want to keep MY copy of a config file or accept the default, I pretty much always elect to keep my current version ;)
« Last Edit: December 12, 2019, 02:53:11 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GEMS

  • Member
  • ***
  • Posts: 99
  • Karma: 6
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Pulse Audio Equalizer stopped working. (SOLVED)
« Reply #9 on: December 12, 2019, 04:53:35 pm »
PCNetSpec,

It worked. Initially I screwed it up. I ran the terminal command and pasted above what was already there. After a reboot; it did not work and I could hear something turning on and off from the speakers. Then I realized how hopelessly stupid I was and went in again and deleted everything and then pasted in your set of commands.

As usual you saved my bacon. Thank You.

HAIL ! PCNetSpec  :D

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2170
  • Karma: 450
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Pulse Audio Equalizer stopped working.
« Reply #10 on: December 12, 2019, 04:56:09 pm »
I checked PM10 again and sure enough, no equaliser. So I added the lines into the pulse config and logged off and on. Still not there.

Code: [Select]
$ qpaeq

Command 'qpaeq' not found, but can be installed with:

sudo apt install pulseaudio-equalizer

tom@office-pc ~ $ sudo apt install pulseaudio-equalizer
[sudo] password for tom:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 pulseaudio-equalizer : Depends: libpulse0 (= 1:11.1-1ubuntu7.4) but 1:11.1-1ubuntu7.5 is to be installed
                        Depends: pulseaudio (= 1:11.1-1ubuntu7.4)
E: Unable to correct problems, you have held broken packages.


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Pulse Audio Equalizer stopped working.
« Reply #11 on: December 12, 2019, 07:10:30 pm »
Try
Code: [Select]
sudo apt-get updatethen
Code: [Select]
sudo apt-get install --reinstall libpulse-dev=1:11.1-1ubuntu7.5 libpulse-mainloop-glib0=1:11.1-1ubuntu7.5 libpulse0=1:11.1-1ubuntu7.5 libpulsedsp=1:11.1-1ubuntu7.5 pulseaudiov=1:11.1-1ubuntu7.5 pulseaudio-module-bluetooth=1:11.1-1ubuntu7.5 pulseaudio-utils=1:11.1-1ubuntu7.5
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GEMS

  • Member
  • ***
  • Posts: 99
  • Karma: 6
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Pulse Audio Equalizer stopped working.
« Reply #12 on: December 12, 2019, 09:03:20 pm »
PCNetSpec,

It seems to be working with what what I did previously. Should I do this now? No offense.

GEMS.

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2170
  • Karma: 450
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Pulse Audio Equalizer stopped working.
« Reply #13 on: December 12, 2019, 09:06:26 pm »
No, you don't need to do it GEMS. If it's working it's fine.

It didn't quite work anyway and I ended up doing
Code: [Select]
sudo apt-get install --reinstall libpulse-dev/bionic libpulse-mainloop-glib0/bionic libpulse0/bionic libpulsedsp/bionic pulseaudio/bionic pulseaudio-utils/bionic
and I got back the stock (crap) equaliser. I then replaced that with the WebUpd8 version from their PPA.

Offline The Omen

  • Member
  • ***
  • Posts: 131
  • Karma: 31
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 respin
Re: Pulse Audio Equalizer stopped working.
« Reply #14 on: December 13, 2019, 07:04:02 am »
Hi Murraymint,

Is that the same LADSPA equalizer that I am using?

https://ubuntu.pkgs.org/16.04/webupd8-amd64/pulseaudio-equalizer_2.7.0.2-5~webupd8~xenial0_all.deb.html

It works great and is much better than the one that comes with bionic.

I notice that it is for zenial but works so good with Peppermint 9 respin 2.

Regards,

The Omen