Choose style:

Author Topic: Intel UHD 620 and NVidia MX250 , PM X [paused]  (Read 361 times)

0 Members and 1 Guest are viewing this topic.

Offline LordKaan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6 and 10
Re: Intel UHD 620 and NVidia MX250 , PM X [solved]
« Reply #15 on: December 11, 2019, 06:39:42 pm »
No; the only partions i kept, was the UEFI/Boot, the "black" unknow" (Windows need it), and the recovery

But as i wrote above; after first attempt; where everything was easily to install inkl. pm6;
i had to reinstall all new (Win8, and 10, Lubuntu, LM, and Peppermint x, and partitions for Datas)

All my computers are made in this row: First 8, afterwards 10, than LM, afterwards Lubuntu and finaly PM
(In case there is space on the HD, i still create one Partition for "testing" other Linux Distris;
but most i take care, to have a running system)

By the 2nd attempt: LM broke up installing - can't write grub
I let it, as it happend and install PM 10 - and he wrote in the startmenu LM too

Reason why PM is the last one: Cause the Starter; At PM & the red letters;
and by PM 10 the gry background

At 2nd attempt; i figured out, that the installer of Win 8 sometimes regognise the LAN; sometimes not
In this case, he found it (Later on i couldn install, cause u are not getting the win8 Driver for LAN/WiFI)

After 25 years, allways installing Double systems (mostly different Win Versions) i knew:
Never use the same Partition-Table as before, when attempt 1 failed;
cause anywhere in the system the HD will remember something

So in this case, after the Partitions for win (twice 31250 ) i put a 2000 Swap-Partiton, instead 200MB "Uefi-Spezial" Partion; cause "Swap" is alway the Last i put in the row

Offline LordKaan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6 and 10
Re: Intel UHD 620 and NVidia MX250 , PM X
« Reply #16 on: December 12, 2019, 03:40:02 am »
Just out of interest, can you run Memtest86 (from the GRUB menu .. or from the boot menu of a LiveUSB) to test the memory.



No;
at Grub i have 4 alternativ "Bootings"; sems 2 elder versions, and 2 safe mode ones

No memtest at all
----------------------------------------------

Today i will take time, to reinstall all Linux OS in a other row;
in the hope, it will be worked afterwards;
there i will see, if on the LIVe-USB/Installersticks are memtests

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26468
  • Karma: 2871
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Intel UHD 620 and NVidia MX250 , PM X [solved]
« Reply #17 on: December 12, 2019, 05:44:29 am »
Yep you're correct (my mistake)

If you boot a Peppermint LiveUSB/LiveDVD Memtest86+ should be one of the options (at the same screen where you're offered Try Peppermint/Install Peppermint)

This actually makes more sense as it rules out the HDD/SSD/Kernel/Operating System as the root cause, concentrating solely on memory testing from a hopefully known good source, and able to test ALL memory (not just unallocated memory).

[EDIT]

Be aware Memtest86+ will continue to run until you physically stop it (IIRC with the Esc key) .. allow it to run at least 2 full cycles, if no errors show up by then you can be fairly confident your memory is good.

[EDIT 2]

You do know the Peppermint 10 Respin is highly likely to be released within the next few days (almost certainly before Christmas) ?

The reason I mention this:- If you're considering a fresh Peppermint reinstall, you may want to wait for the Peppermint 10 Respin ISO which should automatically install nvidia 435 (as long as you have an active internet connection during the install) and set up optimus profile switching for you.
« Last Edit: December 12, 2019, 06:10:30 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline LordKaan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6 and 10
Re: Intel UHD 620 and NVidia MX250 , PM X [solved]
« Reply #18 on: December 12, 2019, 07:21:43 am »
Hi PCNetSpec...

I will await respin - the next laptops are waiting ;)
And as long, as i can configurate as PM 6 (mostly simple style) - i will be happy too :hurray:

And yes, i will try with memtest


Btt.: !!!!!!
Today mornig, i get extremly angry, cause at least so many graphic-bugs happend again;
He forgot the "sudo kill all", at the other Linux Distris so many other graphic-Errors
that i delete all the table, and start to install clean;
with a new entry-table on the HD (Just 1 click more (Size) change, and -i guess so- he would find fraquments of formal/other installations

What should i say, from the first Linux Distri, till PM X everything work FINE, no troubles at all;
at lm he could write again the grub, at PM x i changed after installing the driver, put chrome on it - no errors whil display

So i guess, while last installation, he found "gremlins" of previouse installations, or what ever, and that was the reason, why all failed

I made on all systems the flicker-fixer (see earlier thread): Worked
Display-Errors: No

Kind of wired colour-changing: Nope

----------------
So, THANK YOU AGAIN AND THX. that u spend SO MUCH TIME for my problem !!!!!!!!!!!
By this thread i learned again something for the future;
even while waiting 4 answers, i found other answers/ideas (clip-downloader ;) etc.

Thx. aagain !!!! that u take care so much !!!!!!

-----------------------
So, and now i went, and change all the styles, to my beloved pm 6 theme ;)


Edit: Too early :(

Okay, after clean install, changing Graphic-Card Driver all was okay (read above)

Than i made the modification:

Removing Whiskey-Menu (replace with the 1-Row menu)
+ add the new shortcuts (all in the Hardwarethread, elder thread of me)
Changing "styling" (installing the old pm6-theme)

Fixing Flickering

Restart... and still having the display-errors (Chrome-browser)
When i try to switch card -which wasn't a problem before- he crashed again into black Screen with the "_" (Underline)-Prompt


:((((

So, i duno why, and where ... but it seems, the error will be there anywhere

I will cross-test it; means, again new install incl. changing card driver;
Using System without changing style/FlickerFixer
and will see, what happend -stay tuned
« Last Edit: December 12, 2019, 07:46:02 am by LordKaan »

Offline LordKaan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6 and 10
Re: Intel UHD 620 and NVidia MX250 , PM X [paused]
« Reply #19 on: December 12, 2019, 08:21:10 am »
Things i do till "crash":

Re-Install/New Install of PM x: done; After finishing he ignore the button "shut down"/frezze; so i push "switch on"-button

Conected to wifi ; done
Install Nvidia 435: done

remove Country-Flag (right corner down, beside clock/Panel): done

Install chrome: Done ; Set it as default browser
Install XNView: Done

Install extensions at chrome (Some blocker): Done

restart system: Done; Some wired flickering while "start" and Desktop" (on the black screen); I do have after installing Nvidia; and only on this laptop

Both browsers opend (Firefox/Chrome): done
Install Anti-Flicker: done
(https://forum.peppermintos.com/index.php/topic,8852.0.html post Nr. 3 from Omen; worked fine on all intel products)


restart ->
GOTCHA

After Flickerfixing by terminal and restart the graphic bug happend;
Settings was on NVidia

I will now/the next hours reinstall; and test it, if it happend while Intel-Driver is selected

PC: This is bad, cause living with flickering, esps. inside forums... is not helpfull

------------------------------
Cross-Test: Done

It doesn matter, if i choose "Full or minimal install" (is there really a difference???)
If Chrome hast extensions or not

Just clean install, inkl. Standart Intel-Driver;
After Flicker-Fixing and restart, there is the graphic bug :(

This effect is only under PM X (not by the other distris)

I also made -as u recommand- switch off of effects, and the sudo kill; but after restart he forget, what i killed ;)

But while running killing, the effect is away

----------
The worse thing is on it too, the when i click the right mousebutton inside the brwoser p.e for copy&Paste,
i also have this effect; Menu only would just disdurb a little, but with the right mouse-button... itś worse
« Last Edit: December 12, 2019, 08:56:21 am by LordKaan »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26468
  • Karma: 2871
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Intel UHD 620 and NVidia MX250 , PM X [paused]
« Reply #20 on: December 14, 2019, 06:55:46 am »
I'm kinda confused about what you're trying to say here :-\

Can you boot to a LiveUSB, then post the output from:
Code: [Select]
inxi -Fz
run within the Live session.

I want to know if it defaults to the 'intel' or 'modesetting' graphics driver.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec