Choose style:

Author Topic: Change monitor resolution on Asus ET2400E  (Read 8690 times)

0 Members and 1 Guest are viewing this topic.

Offline dorianhyde

  • nOOb
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: Change monitor resolution on Asus ET2400E
« Reply #15 on: September 04, 2014, 02:03:15 pm »
Hi Karma,
yes, I added nomodeset in the "Grub" in order to fix the black screen on the first reboot after installation.
This is the only add I had done to the file Grub.
This is the configurations:
GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Offline dorianhyde

  • nOOb
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: Change monitor resolution on Asus ET2400E
« Reply #16 on: September 04, 2014, 09:03:19 pm »
Hi Karma,

on the Grup I have added only NOMODESET.

This is the actual configuration:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Change monitor resolution on Asus ET2400E
« Reply #17 on: September 05, 2014, 07:15:01 am »
OK, what I want t try is removing the "nomodeset" kernel boot parameter, and update GRUB followed by adding:-
setpci -s 00:02.0 F4.B=30
to
/etc/rc.local

The idea is that you don't need "nomodeset" (and nomodeset is what's stopping the correct graphics drivers from being loaded), as your black screen isn't caused by kernel mode setting, but rather by a backlight issue where the screen backlight isn't on or is set too low.

The problem is, to test this (as I said) we're going to have to remove the automatic application of the "nomodeset" kernel boot parameter at boot .. so if I'm wrong, you'll need to know how to MANUALLY apply "nomodeset" at the GRUB screen, so you can get back in to undo.

Can you read this:
http://linuxforums.org.uk/index.php?topic=11309.msg90149#msg90149
and confirm you'd be OK manually adding the nomodeset (as described) if necessary .. then we'll continue.

Even better would be confirmation you have another machine where you can access this forum if you get stuck and need assistance ?
« Last Edit: September 05, 2014, 07:18:18 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dorianhyde

  • nOOb
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: Change monitor resolution on Asus ET2400E
« Reply #18 on: September 05, 2014, 01:50:49 pm »
Hi Karma,

Ok for all.
I read the link and I  can manage grub on boot and I have an other notebook to see the forum.

Thanks,

Juri

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Change monitor resolution on Asus ET2400E
« Reply #19 on: September 05, 2014, 05:51:00 pm »
OK, a couple of things We can try, but lets start with this .. run:
Code: [Select]
sudo gedit /etc/rc.local
and add

setpci -s 00:02.0 F4.B=30

just above the

exit 0

line .. so it now reads:-
Code: [Select]
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

setpci -s 00:02.0 F4.B=30
exit 0
SAVE the file and exit gedit.

back in the terminal run:
Code: [Select]
sudo gedit /etc/default/grub
find the line that reads:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

and remove the "nomodeset" parameter .. so it now reads:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

SAVE the file and exit gedit.

Back in the terminal run:
Code: [Select]
sudo update-grub
When that finishes, reboot to test.

Be aware, the screen backlight might not come on until the PC reaches the login screen .. but just give it a while and see if it comes on.

If not .. power off .. then boot adding the nomodeset parameter manually at the GRUB screen, then undo those changes (remembering to run "sudo update-grub" after you've added nomodeset back in and saved the file.

and let me know how you get on.

If it doesn't work, there are other kernel boot options we can try.

It might be helpful, whilst booting WITHOUT nomodeset if you shine a flashlight on the sccreen and try to see if the pickure IS there, but it's just that the backlight isn't coming on .. if you get my meaning.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dorianhyde

  • nOOb
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: Change monitor resolution on Asus ET2400E
« Reply #20 on: September 07, 2014, 04:05:49 pm »
Hi Karma,
you are right. I done as you say and no black screen without nomodeset. So I tried your first solution to add modeset 1920 1080 to xrandre but it failed again.
Thanks,

Juri

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Change monitor resolution on Asus ET2400E
« Reply #21 on: September 07, 2014, 05:41:30 pm »
So what's the output from:
Code: [Select]
sudo lshw -C display
and
Code: [Select]
xrandr
without nomodeset
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dorianhyde

  • nOOb
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: Change monitor resolution on Asus ET2400E
« Reply #22 on: September 08, 2014, 02:51:24 pm »
Hi Karma,

this is the configuration required:
  *-display:0 UNCLAIMED   
       description: VGA compatible controller
       product: 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:fe400000-fe7fffff memory:e0000000-efffffff ioport:dc00(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:fe900000-fe9fffff

and:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 1024, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      77.0*

Thanks,

Juri

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Change monitor resolution on Asus ET2400E
« Reply #23 on: September 08, 2014, 03:58:49 pm »
Display(s) are still UNCLAIMED, so the i915 driver still isn't loading properly .. which is odd.

I'll see what I can dig up

[EDIT]

Are you game for trying the intel driver installer .. it will take a minor edit to LSB but that can be undone afterwards.

I guess what I'm asking is .. are you game/prepared for a complete reinstall if things go horribly wrong ?
« Last Edit: September 08, 2014, 04:01:12 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dorianhyde

  • nOOb
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: Change monitor resolution on Asus ET2400E
« Reply #24 on: September 09, 2014, 05:19:30 pm »
Hi karma,
no problem for complete reinstall, this is a sort of "testing" desktop so no personal data are yet saved on.
Instead, the black screen problem is come back again and again the monitor go on only with nomodeset.
I also had reinstalled the system and applied your command line:
setpci -s 00:02.0 F4.B=30
but this time it does'nt resolve black screen problem.
The monitor come back just after this line:
Scanning for BTRFS fyle system
that appear with a bigger font respect when I set nomodeset.
If you think it will be useful I can newly reinstall the system.

Thanks,

Juri

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Change monitor resolution on Asus ET2400E
« Reply #25 on: September 09, 2014, 07:43:38 pm »
It might actually be worth a reinstall, just to see if the graphics drivers load properly this time.

Which version did you install, 32bit or 64bit ?

Might be worth trying the other architecture.....
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dorianhyde

  • nOOb
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: Change monitor resolution on Asus ET2400E
« Reply #26 on: September 10, 2014, 05:17:10 pm »
Hi Karma,

I had tried a 64 bit Linux Mint distro but had same problem.

I also tried to load the intel grafich driver for windows by Wine but it fail and I don't find a properly driver for Linux.

Juri

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Change monitor resolution on Asus ET2400E
« Reply #27 on: September 10, 2014, 05:42:34 pm »
So what's installed now ? .. Mint or Peppermint ?

And what's the output from:
Code: [Select]
uname -a
and
Code: [Select]
sudo lshw -C display
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dorianhyde

  • nOOb
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: Change monitor resolution on Asus ET2400E
« Reply #28 on: September 12, 2014, 02:31:18 am »
Hi Karma,
now I have Peppermint, Mint was my firt linux installations.
This is the output required;

Linux dorian-ET2400E 3.13.0-35-generic #62-Ubuntu SMP Fri Aug 15 01:58:01 UTC 2014 i686 i686 i686 GNU/Linux

and:

*-display:0 UNCLAIMED   
       description: VGA compatible controller
       product: 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:fe400000-fe7fffff memory:e0000000-efffffff ioport:dc00(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:fe900000-fe9fffff


Thanks,

Juri


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Change monitor resolution on Asus ET2400E
« Reply #29 on: September 12, 2014, 07:23:07 am »
Can you run:
Code: [Select]
tar czvf ~/Desktop/logs.tar.gz /var/log/dmesg /var/log/boot.log /var/log/kern.log /var/log/syslog /var/log/Xorg.0.log
you should then have a file on your desktop called "logs.tar.gz" .. can you host that file online somewhere and provide me with a link to it .. so I can check out your log files and try to figure out why the i915 driver seems to be loading, yet the graphics cards are unclaimed.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec