Choose style:

Author Topic: wifi wont connect at all  (Read 359 times)

0 Members and 1 Guest are viewing this topic.

Offline bananatech

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
wifi wont connect at all
« on: November 23, 2019, 06:12:35 pm »
i have a dell laptop with broad com wifi chip , ive tried so far to restart network manager ,flush dns cache retyping password, but sometimes it it works sometimes it doesn't , im at a loss as to solve this issue, any ideas?  im using peppermint os 10 on a fresh install

Offline bananatech

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: wifi wont connect at all
« Reply #1 on: November 23, 2019, 08:40:34 pm »
i just looked up the information on the wifi card with the lshw  -c network command it is a broadcom BCM4312

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 527
  • Karma: 95
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: wifi wont connect at all
« Reply #2 on: November 24, 2019, 04:46:25 am »
In Synaptic package manager there is broadcom wifi drivers, but I know a lot of people complain that they cannot get them to work properly. I don't use wireless just rather be fully plugged into my router.
Try this in a Terminal
Code: [Select]
sudo apt-get update
Code: [Select]
sudo apt-get install broadcom-sta-dkms
Code: [Select]
Reboot your system
If this does not work, then please be patient as I'm sure someone with more WiFi experience than I will be able to get this working for you.  :)
« Last Edit: November 24, 2019, 04:49:24 am by clatterfordslim »
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: wifi wont connect at all
« Reply #3 on: November 24, 2019, 10:43:53 am »
Can we have the output from:
Code: [Select]
lspci -vnn | grep -i net
and
Code: [Select]
sudo lshw -C network
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline peppycrab

  • Jr. Member
  • **
  • Posts: 90
  • Karma: 17
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: wifi wont connect at all
« Reply #4 on: November 25, 2019, 05:00:48 pm »
I found this page valuable when using P8. See if you can install the Broadcom driver that you need.  https://askubuntu.com/questions/55868/installing-broadcom-wireless-drivers
If you are using a newer version of Peppermint, I'm surprised it did not connect automatically.

Offline bananatech

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: wifi wont connect at all
« Reply #5 on: December 01, 2019, 05:21:49 pm »
a day or two later it just started working again , im wondering if i just had some electrical interference ,i  remembered when i used to live close to fort hood i had the same issue with wifi i wonder if there were military exercises nearby, i didnt hear anything but could be im going to print this page to pdf for future refrence if i have issues in the future thank you everyone for your help .im moving to alabama in a few days so been busy .

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: wifi wont connect at all
« Reply #6 on: December 01, 2019, 08:49:41 pm »
Weird huh :-\

Maybe someone on the same channel as you with more powerful equipment .. might be worth switching channels in your router.

If you post the output from:
Code: [Select]
sudo iwlist scan
we might be able to suggest the least used channel.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec