Choose style:

Author Topic: SOLUTION authentication failure when using Mozilla Thunderbird and gmail imap  (Read 160 times)

0 Members and 1 Guest are viewing this topic.

Offline pepperOS

  • Jr. Member
  • **
  • Posts: 68
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
not a problem anymore but if you have the same trouble, a solution

after a password change in gmail i could not connect with gmail anymore and got a authentication failure wrong password ore account name.
so every time the program started i was redirected to a popup screen were i could login and state that the app (thunderbird) i was using had the rights to do so

this was the situation: peppermint 10 linux, thunderbird mail
after several tries i deleted the account in thunderbird, tried to install that again, but even thought i get rerouted to the gmail server to check if this device/app may change things, i get the authorization failure .
when i log in with firefox, no problem at all, so my password is correct.
my motorola phone has no problems after changing password
installed thunderbird again, no luck.
then i found this on a forum and it worked

set the Google imap account to ssl/tsl "normal password" after turning on Google's "allow less secure apps's" setting.

somehow google finds Thunderbird not save enough, duhhh :o


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Basically Google considers anything not controlled by them 'less secure' .. from a user standpoint it's kinda laughable, but I **kinda** understand their position :)

Thanks for the HowTo :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3145
  • Karma: 567
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Hi

I had a similar problem and totally forgot to mention the solution here - so here goes

It appears that google has just changed their OAuth process and started rejecting OAuth requests based on the User-Agent header.

Changing "general.useragent.compatMode.firefox" preference to "true" fixes the issue, google authentication works again.

Get access to this via about:config in firefox

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadrippe 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 1 x 43" 1 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P10 x64 Laptop - i7-7700HQ - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 340
  • Karma: 34
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Hi

I had a similar problem and totally forgot to mention the solution here - so here goes

It appears that google has just changed their OAuth process and started rejecting OAuth requests based on the User-Agent header.

Changing "general.useragent.compatMode.firefox" preference to "true" fixes the issue, google authentication works again.

Get access to this via about:config in firefox

Regards Zeb...

I had the same problem after update of Kernel 4.15.0-69 and that same evening up to 70. So my initial thought it was a Kernel thing, but thanks for this will take notes and save them away. I absolutely love Firefox and now I've gone 1080 and the option in Firefox to zoom text is brilliant on this Forum.  ;D
Not only is Peppermint an addictive OS to use.
But so is this Forum :)