Choose style:

Author Topic: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected  (Read 889 times)

0 Members and 1 Guest are viewing this topic.

Offline raywood

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« on: November 15, 2019, 11:09:31 pm »
A Google search finds nothing on this error in this forum. It appears in MenuLibre after I've attempted to add a Menu category (i.e., "Browsers") as advised in an Xfce wiki page. The full text of the error message:

Quote
Invalid desktop files detected! Please see details.

[The details said:] The following desktop files have failed parsing by the underlying library, and will therefore not show up in MenuLibre. ...

/home/ray/.local/share/desktop-directories/Browsers.desktop

Type value is invalid - currently 'Directory', should be 'Application'

I think I've followed the wiki's instructions. Possibly they are not entirely applicable to Peppermint 10?

It puzzles me that the error message says Browsers.desktop should be "Application," when I've specified Browsers as a menu category with what appear to be the required lines in ~/.config/menus/xfce-applications.menu.

With or without MenuLibre, Browsers is not appearing as a Menu category.
« Last Edit: November 15, 2019, 11:21:55 pm by raywood »

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1997
  • Karma: 344
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« Reply #1 on: November 16, 2019, 07:38:44 am »
You've named it .desktop instead of .directory

Offline raywood

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« Reply #2 on: November 18, 2019, 09:55:47 pm »
OK, I admit, that was lame.

They don't seem to have an L-on-forehead emoticon.

Let's make it best out of three.

I have now advanced somewhat. I have a menu category named Software. This category registers in MenuLibre, but not in Menu. I assume that's because I have not been able to get any launchers to populate it.

The current state of my launcher effort: MenuLibre does display a Software-Software category for some of the chosen launchers (e.g., Synaptic), when viewed in other categories (e.g., System), presumably because I have added Software to the Categories line in the .desktop files. These .desktop files are in ~/.local/share/applications, copied over from /usr/share/applications.

I think that's all I did to get one or two programs registered under the Browsers category I asked about previously. But no guarantees on that; there was a lot of flailing around in the process. I may have punched the right button by random chance.

I must be missing something. But what? I did try adding <Filename> lines for these programs, in the Software submenu in xfce-applications.menu, but Peppermint seems to be ignoring those.
« Last Edit: November 18, 2019, 11:01:42 pm by raywood »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« Reply #3 on: November 19, 2019, 06:29:29 am »
If you're going to seek help on something like this, you're gonna need to provide much more info

What are you trying to achieve .. ie. what new menu category do you want to add - name and where in the menu ?

what's the contents of your
Code: [Select]
xed $HOME/.config/menus/xfce-applications.menu
what's the name of the .directory file you've created

what's the location of the .directory file you've created

and what's the contents of the .directory file you've created
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline raywood

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« Reply #4 on: November 19, 2019, 11:35:50 am »
OK. Thanks for the fast response. The first case (i.e., the Browsers category) is simpler, so I'll go back to that, as I'm having the same problem there.

In Peppermint 10, I've added a Browsers category among the other top-level categories of Menu (e.g., Accessories, Multimedia). I added that category by copying the lines for another top-level category in ~/.config/menus/xfce-applications.menu and revising them for Browsers, like this:

Code: [Select]
<Menu>
   <Name>Browsers</Name>
   <Directory>xfce-browsers.directory</Directory>
   <DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
   <Include>
      <Category>Browsers</Category>
   </Include>
   <Layout>
      <Merge type="menus" />
      <Merge type="files" />
    </Layout>
</Menu>

I also added <Menuname>Browsers</Menuname> among the other Menuname entries near the bottom of xfce-applications.menu.

Next, I copied one of the other directory files in ~/.local/share/desktop-directories, named the copy xfce-browsers.directory, and revised it thus:

Code: [Select]
[Desktop Entry]
Version=1.1
Type=Directory
Name=Browsers
Comment=Browser-related applications
Icon=applications-development-web

Then I copied ice.desktop from the systemwide launcher pool at /usr/share/applications to ~/.local/share/applications, and edited it by simply adding "Browsers;" to its Categories line. I saved that, restarted MenuLibre, and observed that both Menu and MenuLibre were displaying a Browsers category with an Ice launcher. So far, so good.

Now I sought to add a second program's launcher to the Browsers category. The program: Firefox Send, whose launcher (firefoxsend.desktop) already existed in ~/.local/share/applications. I merely added "Browsers;" to its Categories line and saved the change. Now, even after a reboot, Ice was gone from the Browsers category, and (therefore) Browsers no longer appeared in Menu.

Questions at this point: did I do it right, why didn't Ice and Firefox Send appear in Browsers, and is there a better place to get icons?

The text of xfce-applications.menu at present:

Code: [Select]
<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE Menu
  PUBLIC '-//freedesktop//DTD Menu 1.0//EN'
  'http://standards.freedesktop.org/menu-spec/menu-1.0.dtd'>
<Menu>
<Name>Xfce</Name>
<DefaultAppDirs />
<DefaultDirectoryDirs />
<DefaultMergeDirs />
<Include>
<Category>X-Xfce-Toplevel</Category>
</Include>
<MergeFile type="parent">/etc/xdg/menus/xfce-applications.menu</MergeFile>
<Menu>
<Name>Settings</Name>
<Directory>xfce-settings.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Menu>
<Name>Screensavers</Name>
<Directory>xfce-screensavers.directory</Directory>
<Layout>
<Merge type="menus" />
<Merge type="files" />
</Layout>
</Menu>
<Layout>
<Merge type="menus" />
<Separator />
<Filename>software-properties-drivers.desktop</Filename>
<Filename>advert-block.desktop</Filename>
<Filename>arandr.desktop</Filename>
<Filename>blueman-manager.desktop</Filename>
<Filename>lxappearance.desktop</Filename>
<Filename>lxsession-default-apps.desktop</Filename>
<Filename>org.gnome.DiskUtility.desktop</Filename>
<Filename>xfce-display-settings.desktop</Filename>
<Filename>peppermint-firefox-themer.desktop</Filename>
<Filename>gufw.desktop</Filename>
<Filename>peppermint-font-dpi-settings.desktop</Filename>
<Filename>im-config.desktop</Filename>
<Filename>gnome-language-selector.desktop</Filename>
<Filename>light-locker-settings.desktop</Filename>
<Filename>lightdm-settings.desktop</Filename>
<Filename>menulibre.desktop</Filename>
<Filename>network.desktop</Filename>
<Filename>nm-connection-editor.desktop</Filename>
<Filename>numix-folders.desktop</Filename>
<Filename>peppermint-control-center.desktop</Filename>
<Filename>peppermint-proxy-configuration.desktop</Filename>
<Filename>peppermint-settings-panel.desktop</Filename>
<Filename>xfce4-power-manager-settings.desktop</Filename>
<Filename>system-config-printer.desktop</Filename>
<Filename>system-config-samba.desktop</Filename>
<Menuname>Screensavers</Menuname>
<Filename>shares.desktop</Filename>
<Filename>mintinstall.desktop</Filename>
<Filename>software-properties-gtk.desktop</Filename>
<Filename>peppermint-thunderbird-themer.desktop</Filename>
<Filename>time.desktop</Filename>
<Filename>mintUpdate.desktop</Filename>
<Filename>users.desktop</Filename>
<Filename>xfpanel-switch.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Accessories</Name>
<Directory>xfce-accessories.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Filename>xfce4-appfinder.desktop</Filename>
<Filename>file-roller.desktop</Filename>
<Filename>org.gnome.FileRoller.desktop</Filename>
<Filename>mate-calc.desktop</Filename>
<Filename>gucharmap.desktop</Filename>
<Filename>compton.desktop</Filename>
<Filename>org.gnome.DiskUtility.desktop</Filename>
<Filename>xreader.desktop</Filename>
<Filename>nemo.desktop</Filename>
<Filename>yad-icon-browser.desktop</Filename>
<Filename>menulibre.desktop</Filename>
<Filename>xfce4-run.desktop</Filename>
<Filename>xfce4-screenshooter.desktop</Filename>
<Filename>peppermint-scrot-helper.desktop</Filename>
<Filename>gnome-search-tool.desktop</Filename>
<Filename>xfce4-taskmanager.desktop</Filename>
<Filename>sakura.desktop</Filename>
<Filename>xed.desktop</Filename>
<Filename>nitrogen.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Development</Name>
<Directory>xfce-development.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Filename>python2.7.desktop</Filename>
<Filename>python3.6.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Education</Name>
<Directory>xfce-education.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Games</Name>
<Directory>xfce-games.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Filename>betterthanchess.desktop</Filename>
<Filename>entanglement.desktop</Filename>
<Filename>firstpersontetris.desktop</Filename>
<Filename>mahjong.desktop</Filename>
<Filename>solitaire.desktop</Filename>
<Filename>spidersolitaire.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Graphics</Name>
<Directory>xfce-graphics.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Filename>xviewer.desktop</Filename>
<Filename>editorbypixlr.desktop</Filename>
<Filename>expressbypixlr.desktop</Filename>
<Filename>simple-scan.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Browsers</Name>
<Directory>xfce-browsers.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Filename>ice.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Network</Name>
<Directory>xfce-network.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Filename>googledrive.desktop</Filename>
<Filename>transmission-gtk.desktop</Filename>
<Filename>dropbox.desktop</Filename>
<Filename>firefoxsend.desktop</Filename>
<Filename>firefox.desktop</Filename>
<Filename>ice.desktop</Filename>
<Filename>onlineuserguide.desktop</Filename>
<Filename>peppermintforum.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Multimedia</Name>
<Directory>xfce-multimedia.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Filename>guvcview.desktop</Filename>
<Filename>xplayer.desktop</Filename>
<Filename>pulseaudio-equalizer.desktop</Filename>
<Filename>pavucontrol.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Office</Name>
<Directory>xfce-office.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Filename>gmail.desktop</Filename>
<Filename>googlecalendar.desktop</Filename>
<Filename>microsoftexcelonline.desktop</Filename>
<Filename>microsoftonenoteonline.desktop</Filename>
<Filename>microsoftpowerpointonline.desktop</Filename>
<Filename>microsoftwordonline.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>Other</Name>
<Directory>xfce-other.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Include>
<Filename>gcr-prompter.desktop</Filename>
</Include>
<Include>
<Filename>nemo-autorun-software.desktop</Filename>
</Include>
<Include>
<Filename>panel-desktop-handler.desktop</Filename>
</Include>
<Include>
<Filename>gnome-disk-image-mounter.desktop</Filename>
</Include>
<Include>
<Filename>gnome-disk-image-writer.desktop</Filename>
</Include>
<Include>
<Filename>peppermint-logout.desktop</Filename>
</Include>
<Include>
<Filename>snap-handle-link.desktop</Filename>
</Include>
<Include>
<Filename>metacity.desktop</Filename>
</Include>
<Include>
<Filename>nm-applet.desktop</Filename>
</Include>
<Include>
<Filename>notification-daemon.desktop</Filename>
</Include>
<Include>
<Filename>xdg-desktop-portal-gtk.desktop</Filename>
</Include>
<Include>
<Filename>mintinstall-fp-handler.desktop</Filename>
</Include>
<Include>
<Filename>gcr-viewer.desktop</Filename>
</Include>
<Layout>
<Merge type="menus" />
<Filename>firefoxsend.desktop</Filename>
<Filename>ice.desktop</Filename>
<Filename>gcr-prompter.desktop</Filename>
<Filename>nemo-autorun-software.desktop</Filename>
<Filename>panel-desktop-handler.desktop</Filename>
<Filename>gnome-disk-image-mounter.desktop</Filename>
<Filename>gnome-disk-image-writer.desktop</Filename>
<Filename>peppermint-logout.desktop</Filename>
<Filename>snap-handle-link.desktop</Filename>
<Filename>metacity.desktop</Filename>
<Filename>nm-applet.desktop</Filename>
<Filename>notification-daemon.desktop</Filename>
<Filename>xdg-desktop-portal-gtk.desktop</Filename>
<Filename>mintinstall-fp-handler.desktop</Filename>
<Filename>gcr-viewer.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Menu>
<Name>System</Name>
<Directory>xfce-system.directory</Directory>
<DirectoryDir>/home/ray/.local/share/desktop-directories</DirectoryDir>
<Layout>
<Merge type="menus" />
<Filename>org.gnome.Software.Editor.desktop</Filename>
<Filename>ca.desrt.dconf-editor.desktop</Filename>
<Filename>gdebi.desktop</Filename>
<Filename>htop.desktop</Filename>
<Filename>lightdm-settings.desktop</Filename>
<Filename>network.desktop</Filename>
<Filename>system-config-printer.desktop</Filename>
<Filename>hplj1020.desktop</Filename>
<Filename>gksu.desktop</Filename>
<Filename>system-config-samba.desktop</Filename>
<Filename>peppermint-screenlock.desktop</Filename>
<Filename>shares.desktop</Filename>
<Filename>org.gnome.Software.desktop</Filename>
<Filename>gnome-software-local-file.desktop</Filename>
<Filename>mintinstall.desktop</Filename>
<Filename>synaptic.desktop</Filename>
<Filename>xfce4-taskmanager.desktop</Filename>
<Filename>time.desktop</Filename>
<Filename>mintUpdate.desktop</Filename>
<Filename>mintstick.desktop</Filename>
<Filename>mintstick-format.desktop</Filename>
<Filename>users.desktop</Filename>
<Filename>debian-uxterm.desktop</Filename>
<Filename>debian-xterm.desktop</Filename>
<Merge type="files" />
</Layout>
</Menu>
<Layout>
<Filename>xfce4-run.desktop</Filename>
<Separator />
<Separator />
<Menuname>Settings</Menuname>
<Separator />
<Menuname>Accessories</Menuname>
<Menuname>Development</Menuname>
<Menuname>Education</Menuname>
<Menuname>Games</Menuname>
<Menuname>Graphics</Menuname>
<Menuname>Browsers</Menuname>
<Menuname>Network</Menuname>
<Menuname>Multimedia</Menuname>
<Menuname>Office</Menuname>
<Menuname>Other</Menuname>
<Menuname>System</Menuname>
<Separator />
</Layout>
</Menu>

« Last Edit: November 19, 2019, 11:42:49 am by raywood »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« Reply #5 on: November 19, 2019, 02:24:23 pm »
So what happens if you run say
Code: [Select]
xed ~/.local/share/applications/firefox-test.desktop
when a blank file opens, make it read
Code: [Select]
[Desktop Entry]
Type=Application
Name=Firefox Test
Comment=Firefox test launcher
Exec=firefox
Icon=firefox
Categories=Browsers;
did that show up in the menu ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline raywood

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« Reply #6 on: November 19, 2019, 04:37:38 pm »
That produces ~/.local/share/applications/firefox-test.desktop, but even after a reboot, Menu shows no Browsers category, and MenuLibre shows the category but no launchers under it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« Reply #7 on: November 20, 2019, 10:59:31 am »
Run:
Code: [Select]
gksudo xed /usr/share/desktop-directories/xfce-browsers.directory
and make it read:-
Code: [Select]
[Desktop Entry]
Version=1.0
Type=Directory
Name=Browsers
Comment=Browser-related applications
Icon=applications-development-web
SAVE the file and exit the text editor.

Before going any further, backup your original xfce-applications.menu file:
Code: [Select]
cd /etc/xdg/menus
then:
Code: [Select]
sudo tar cvf xfce-applications.menu.original.tar.gz xfce-applications.menu
Okay open xfce-applications.menu for editing:
Code: [Select]
gksudo xed /etc/xdg/menus/xfce-applications.menu
and make it read:-
Code: [Select]
<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
  "http://www.freedesktop.org/standards/menu-spec/1.0/menu.dtd">

<Menu>
    <Name>Xfce</Name>

    <DefaultAppDirs/>
    <DefaultDirectoryDirs/>
    <DefaultMergeDirs/>

    <Include>
        <Category>X-Xfce-Toplevel</Category>
    </Include>

    <Layout>
        <Filename>xfce4-run.desktop</Filename>
        <Separator/>
        <Filename>exo-terminal-emulator.desktop</Filename>
        <Filename>exo-file-manager.desktop</Filename>
        <Filename>exo-mail-reader.desktop</Filename>
        <Filename>exo-web-browser.desktop</Filename>
        <Separator/>
        <Menuname>Settings</Menuname>
        <Separator/>
        <Merge type="all"/>
        <Separator/>
        <Filename>xfce4-about.desktop</Filename>
        <Filename>xfce4-session-logout.desktop</Filename>
    </Layout>

    <Menu>
        <Name>Settings</Name>
        <Directory>xfce-settings.directory</Directory>
        <Include>
            <Category>Settings</Category>
        </Include>

        <Layout>
            <Filename>xfce-settings-manager.desktop</Filename>
            <Separator/>
            <Merge type="all"/>
        </Layout>

        <Menu>
            <Name>Screensavers</Name>
            <Directory>xfce-screensavers.directory</Directory>
            <Include>
                <Category>Screensaver</Category>
            </Include>
        </Menu>
    </Menu>

    <Menu>
        <Name>Accessories</Name>
        <Directory>xfce-accessories.directory</Directory>
        <Include>
            <Or>
                <Category>Accessibility</Category>
                <Category>Core</Category>
                <Category>Legacy</Category>
                <Category>Utility</Category>
            </Or>
        </Include>
        <Exclude>
            <Or>
                <Filename>exo-file-manager.desktop</Filename>
                <Filename>exo-terminal-emulator.desktop</Filename>
                <Filename>xfce4-about.desktop</Filename>
                <Filename>xfce4-run.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

    <Menu>
        <Name>Browsers</Name>
        <Directory>xfce-browsers.directory</Directory>
        <Include>
            <Category>Browsers</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Development</Name>
        <Directory>xfce-development.directory</Directory>
        <Include>
            <Category>Development</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Education</Name>
        <Directory>xfce-education.directory</Directory>
        <Include>
            <Category>Education</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Games</Name>
        <Directory>xfce-games.directory</Directory>
        <Include>
            <Category>Game</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Graphics</Name>
        <Directory>xfce-graphics.directory</Directory>
        <Include>
            <Category>Graphics</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Multimedia</Name>
        <Directory>xfce-multimedia.directory</Directory>
        <Include>
            <Category>Audio</Category>
            <Category>Video</Category>
            <Category>AudioVideo</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Network</Name>
        <Directory>xfce-network.directory</Directory>
        <Include>
            <Category>Network</Category>
        </Include>
        <Exclude>
            <Or>
                <Filename>exo-mail-reader.desktop</Filename>
                <Filename>exo-web-browser.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

    <Menu>
        <Name>Office</Name>
        <Directory>xfce-office.directory</Directory>
        <Include>
            <Category>Office</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>System</Name>
        <Directory>xfce-system.directory</Directory>
        <Include>
            <Or>
                <Category>Emulator</Category>
                <Category>System</Category>
            </Or>
        </Include>
        <Exclude>
            <Or>
                <Filename>xfce4-session-logout.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

    <Menu>
        <Name>Other</Name>
        <Directory>xfce-other.directory</Directory>
        <OnlyUnallocated/>
        <Include>
            <All/>
        </Include>
    </Menu>

</Menu>
SAVE the file and exit the text editor.

Back in the terminal create a test launcher:
Code: [Select]
xed ~/.local/share/applications/firefox-test.desktop
and make it read
Code: [Select]
[Desktop Entry]
Type=Application
Name=Firefox Test
Comment=Firefox test launcher
Exec=firefox
Icon=firefox
Categories=Browsers;
SAVE the file and exit the text editor.

Look in the main menu, and if you don't see:-

Menu > Browsers > Firefox Test

launch menulibre
Code: [Select]
menulibre
in the left hand column, highlight the "Browsers" category .. then click the "Move Up" button


So it's now above the line:-


this will automatically regenerate your ~/.config/menus/xfce-applications.menu file.

And now the new menu category:-

Menu > Browsers

should show up in the main menu

« Last Edit: November 20, 2019, 11:13:33 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline raywood

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« Reply #8 on: November 21, 2019, 11:56:30 am »
Saving the newly created /usr/share/desktop-directories/xfce-browsers.directory file produced eight error messages, of which the first five were essentially "_gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed" and the last three were "Set document metadata failed: Setting attribute metadata::xed-spell-language not supported."

I guess /etc/xdg/menus/xfce-applications.menu is the all-users menu, superseding ~/.config/menus/xfce-applications.menu?

Am I correct in perceiving that the replacement xfce-applications.menu differs from the original just in adding these lines:

Code: [Select]
    <Menu>
        <Name>Browsers</Name>
        <Directory>xfce-browsers.directory</Directory>
        <Include>
            <Category>Browsers</Category>
        </Include>
    </Menu>

The Firefox test launcher appears to be the same as before. Pasting in the new suggestion,and then saving it, produced seven error messages: first, "gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed"; then a handful of "gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed"; and ending with "gtk_action_group_get_action: assertion 'GTK_IS_ACTION_GROUP (action_group)' failed." If I got any such error messages previously, I think I may have failed to report them. If so, that was due to the assumption that such error messages are commonplace.

After revising the Firefox test launcher, Menu and MenuLibre both show it in the Browsers category, along with my previously assigned Ice launcher. The Browsers category appears among the others (i.e., under Accessories in Menu, under Graphics in MenuLibre), not at the bottom.

Are we saying that the solution is to do the category-level surgery in the all-users /etc/xdg/menus/xfce-applications.menu file, not in my own account's ~/.config/menus/xfce-applications.menu? I notice that the former doesn't have the <Menuname> lines at the bottom. My account's xfce-applications.menu does have those, including one for the Browsers category. It also still has the Browsers submenu up above. Not sure what would happen at this point if I removed those lines from that file.
« Last Edit: November 21, 2019, 11:59:46 am by raywood »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: MenuLibre in Peppermint 10 : Invalid Desktop FIles Detected
« Reply #9 on: November 21, 2019, 04:19:30 pm »
Saving the newly created /usr/share/desktop-directories/xfce-browsers.directory file produced eight error messages, of which the first five were essentially "_gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed" and the last three were "Set document metadata failed: Setting attribute metadata::xed-spell-language not supported."

and

Quote
The Firefox test launcher appears to be the same as before. Pasting in the new suggestion,and then saving it, produced seven error messages: first, "gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed"; then a handful of "gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed"; and ending with "gtk_action_group_get_action: assertion 'GTK_IS_ACTION_GROUP (action_group)' failed." If I got any such error messages previously, I think I may have failed to report them. If so, that was due to the assumption that such error messages are commonplace.

IGNORE THOSE ERRORS .. in fact they are not errors, they are just WARNINGS from Gtk/Xed



Quote
Are we saying that the solution is to do the category-level surgery in the all-users /etc/xdg/menus/xfce-applications.menu file, not in my own account's

You probably **could** do it in your user specific files .. all I know is if you undo the changes you've made up to this point and follow my instructions IT WILL WORK.

Where you go from here as far as attempting it in your user specific files is up to you ;)
(I don't mean to sound awkward, but until the Peppermint 10 Respin is released I won't really have any more time to spend on this. If you still have questions then, I'll attempt to come back to this .. until then, there is a solution above should you choose to use it)
« Last Edit: November 21, 2019, 04:31:00 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec