Choose style:

Author Topic: Unable to boot after using Systemback(SOLVED)  (Read 922 times)

0 Members and 1 Guest are viewing this topic.

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1152
  • Karma: 86
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Unable to boot after using Systemback(SOLVED)
« Reply #15 on: November 16, 2019, 05:28:26 pm »
What happens if you try this:-

Boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb2 /mnt
then
Code: [Select]
sudo mount /dev/sdb1 /mnt/boot/efi
then
Code: [Select]
gksudo xed /mnt/etc/fstab
when fstab opens make it read
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb2 during installation
UUID=f4a64468-2bd4-450b-b573-3a1dd9ded925   /   ext4   noatime,errors=remount-ro   0   1
SAVE the file and exit the text editor.

Back in the terminal run:
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install --efi-directory=/mnt/boot/efi
then
Code: [Select]
update-grub
then hit Ctrl+D (to exit the chroot environment)

and finally reboot without the LiveUSB (after setting sdb as the primary boot device in the BIOS).

This happens,


Code: [Select]
peppermint@peppermint ~ $ sudo mount /dev/sdb2 /mnt
peppermint@peppermint ~ $ sudo mount /dev/sdb1 /mnt/boot/efi
mount: /mnt/boot/efi: mount point does not exist.
peppermint@peppermint ~ $ sudo ls /mnt/boot/efi/EFI
ls: cannot access '/mnt/boot/efi/EFI': No such file or directory
peppermint@peppermint ~ $ for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
peppermint@peppermint ~ $ sudo chroot /mnt
root@peppermint / # grub-install --efi-directory=/mnt/boot/efi
Installing for x86_64-efi platform.
grub-install: error: failed to get canonical path of `/mnt/boot/efi'.
root@peppermint / # exit
peppermint@peppermint ~ $

To me this is showing that there is no efi directory in sdb2 /boot. I looked in my installed version of P 10 and it has an efi directory in /boot. That-s why I asked if we could copy it over some way. I was able to copy the directory to my Documents.
« Last Edit: November 16, 2019, 10:58:24 pm by alynur »
What was I thinking?

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2087
  • Karma: 373
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Unable to boot after using Systemback
« Reply #16 on: November 16, 2019, 05:34:51 pm »
Make sure your BIOS is set to only boot in UEFI mode, not UEFI/Legacy.

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1152
  • Karma: 86
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Unable to boot after using Systemback
« Reply #17 on: November 16, 2019, 05:44:51 pm »
Make sure your BIOS is set to only boot in UEFI mode, not UEFI/Legacy.


Hi murraymint, I haven't been into my bios in a while, it could very well be set for UEFI/Legacy and the usb memory with the Systemback live image is just randomly booting into Legacy. I'll check that out now.
What was I thinking?

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1152
  • Karma: 86
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Unable to boot after using Systemback
« Reply #18 on: November 16, 2019, 07:03:04 pm »
Yup that was it, my bios was set up for UEFI/Legacy. I switched it to UEFI only and the usb memory doesn't show up. Apparently Systemback is too old for UEFI, just like Unitbooten for installing from one partition into another. I took a Timeshift snapshot of the P 9 install I had just finished the last touches on, so we'll see if it will boot up after the snapshot is finished restoring. At least we know we can't recommend Systemback for a UEFI clone.  :'(
What was I thinking?

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 527
  • Karma: 95
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: Unable to boot after using Systemback
« Reply #19 on: November 16, 2019, 07:39:13 pm »
Unfortunately Systemback only goes up to 4.4GB in ISO and for the life of me I could not get it going with Pep 10 only Pep 9 then upgraded to Pep 10 through PCNetSpec's upgrade tutorial.
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1152
  • Karma: 86
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Unable to boot after using Systemback
« Reply #20 on: November 16, 2019, 10:56:10 pm »
Unfortunately Systemback only goes up to 4.4GB in ISO and for the life of me I could not get it going with Pep 10 only Pep 9 then upgraded to Pep 10 through PCNetSpec's upgrade tutorial.

I see where Systemback could be a real winner for cloning a not-too-big system that is going to be installed into a blank harddrive with an MBR file system. My live image was about 7.3g and would have had a better chance of working if it wasn't getting installed into a GPT file system. I was able to salvage the installation by restoring the last Timeshift snapshot I had taken of my laptop and then while still booted in P 10, mounting the systemback partition in nemo and changing the fstab to have the correct UUID numbers, including my DATA partition. When I rebooted, it booted right up, albeit a few seconds slower than before but that's no biggie. Everything is there, or here, I'm in it, P 9, now. I did have to rename my computer and host name and reestablish my symlinks for my home folders but the DATA partition was already there and ready to go. I'm especially happy because the nemo file system crawl that I was experiencing in the upgraded version of P 10, is not present. Yay! Bye the way, my fresh install of P 10 in sdb9 is starting to experience the nemo crawl and is getting worse.
I'll go ahead and mark this as solved since I accomplished what I was trying to do with a little bit of a work around. Thanks PCNetSpec and murraymint for your help, you guys pointed my thinking in the right direction. Peppermint people are the best!   :-*
What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Unable to boot after using Systemback
« Reply #21 on: November 16, 2019, 11:10:50 pm »
Glad you got it sorted alynur, but I think murraymint deserves all the kudos for this one :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1152
  • Karma: 86
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Unable to boot after using Systemback
« Reply #22 on: November 16, 2019, 11:19:22 pm »
Glad you got it sorted alynur, but I think murraymint deserves all the kudos for this one :)


Indeed he does, but you put some effort into it also.  ;)
What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Unable to boot after using Systemback
« Reply #23 on: November 16, 2019, 11:29:37 pm »
Effort, but no cigar :))
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1152
  • Karma: 86
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Unable to boot after using Systemback(SOLVED)
« Reply #24 on: November 24, 2019, 09:39:55 pm »
As I had mentioned, before trying to boot into the systemback system, I changed the fstab file to reflect the proper UUID's of my hard drive and that bootup time was a few seconds slower. Well, it was actually about 40 seconds slower and that was starting to bother me, normal bootup was about 20 seconds. So I did a search for slow bootup in the forum search box and one of the listed posts was of the P 9 beta test by andymokum. In that it was discovered that not only in the fstab file did the correct UUID numbers have to be changed but also in the   
Code: [Select]
initramfs-tools/conf.d/resume
  file. so I ran the code

Code: [Select]
sudo xed /etc/initramfs-tools/conf.d/resume
and made the necessary changes and then ran

Code: [Select]
sudo update-initramfs -uk all

Now my bootup is back to around 20 seconds. I am a happy camper!     :)
What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Unable to boot after using Systemback(SOLVED)
« Reply #25 on: November 24, 2019, 10:20:50 pm »
Glad you found the solution alynur .. that's what the forum is here for, a permanent repository of previously discovered solutions :)
« Last Edit: November 24, 2019, 10:22:22 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec