Author Topic: Lightdm completely forzen and cant do anything  (Read 413 times)

Offline JRF

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Lightdm completely forzen and cant do anything
« on: November 12, 2019, 05:51:16 am »
Hi, Im a new user. It seems that Lightdm in my system is broken or "Frozen" to be exact and I literally cant do anything. Im stuck on the login screen with no keyboard button or mouse response, I cant even open the terminal anymore. I remember the last thing I did was install amd drivers https://askubuntu.com/questions/1066105/how-to-install-amd-graphic-drivers-on-ubuntu-18-04

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightdm completely forzen and cant do anything
« Reply #1 on: November 12, 2019, 07:06:51 am »
So you're not even able to Ctrl+Alt+F2 and drop to a text console ?

How far did you go with the instructions you linked to ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline JRF

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Lightdm completely forzen and cant do anything
« Reply #2 on: November 12, 2019, 02:47:56 pm »
No not really, Ctrl+Alt+F2 or even Ctrl+Alt+Del wont work, it doesnt do anything. Theres no response from my keyboard & mouse/touchpad. But I can drop a console through recovery mode though. I followed the instructions till the part where I reconfigured LightDM to the amdgpu driver. Somehow I forgot to restart the system afterwards but It was still working while I was using it for more than an hour after the install. The problem happened after it went to sleep/logged out, it completely froze on the Login screen and cant do anything.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightdm completely forzen and cant do anything
« Reply #3 on: November 12, 2019, 03:40:46 pm »
No response from the keyboard sounds like a kernel panic .. are you able to boot an earlier kernel (chosen from the GRUB menu) ?

By this:-

Quote
I followed the instructions till the part where I reconfigured LightDM to the amdgpu driver

do you mean until:-
Code: [Select]
sudo dpkg-reconfigure gdm3 ubuntu-session xserver-xorg-video-amdgp?



you do realise in Pep10 you're actually running the hwe-18.04 kernel and graphics stack.

So in those instructions, these 3 commands
Code: [Select]
sudo apt install --reinstall xserver-xorg-video-amdgpu
sudo dpkg --configure -a
sudo dpkg-reconfigure gdm3 ubuntu-session xserver-xorg-video-amdgpu
should really have read
Code: [Select]
sudo apt install --reinstall xserver-xorg-video-amdgpu-hwe-18.04
sudo dpkg --configure -a
sudo dpkg-reconfigure lightdm peppermint-default-session xserver-xorg-video-amdgpu-hwe-18.04
but considering the PPA you added doesn't contain xserver-xorg-video-amdgpu-hwe-18.04, the entire exercise was pointless from the beginning

Anyway, if you can get to a root prompt (via recovery)...

First make the / partition writeable with
Code: [Select]
mount -o rw,remount /then
Code: [Select]
apt-get remove --purge xserver-xorg-video-amdgputhen
Code: [Select]
sudo dpkg-reconfigure lightdm peppermint-default-session xserver-xorg-video-amdgpu-hwe-18.04then REBOOT

HOPEFULLY that'll fix things .. but no guarantees, because I have no idea what got removed when you added (or attempted to add) xserver-xorg-video-amdgpu back in.



If that works, I suggest your next step shyhould be to purge that PPA
Code: [Select]
sudo apt-get install ppa-purge
sudo ppa-purge ppa:graphics-drivers/ppa



If you can't get to a root prompt .. have you got a Peppermint LiveUSB ?
« Last Edit: November 12, 2019, 04:02:06 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline JRF

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Lightdm completely forzen and cant do anything
« Reply #4 on: November 13, 2019, 02:38:23 am »
No luck, still doesnt work.

Id also like to point out that I just remembered doing a full backup using Timeshift 2 days before doing that "blind" driver install. Is there any way of restoring that snapshot of the system on console or liveUSB? and is it even possible for that backup to fix this issue?

And yes I do still have the LiveUSB installer for peppermint

Thanks
« Last Edit: November 13, 2019, 02:42:22 am by JRF »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightdm completely forzen and cant do anything
« Reply #5 on: November 13, 2019, 06:58:52 am »
You can restore a timeshift backup by booting a LiveUSB, installing timeshift, then browsing to the folder that contains the backup:
https://itsfoss.com/backup-restore-linux-timeshift/

as for whether it'll fix things .. I can't say because I don't know which settings you used.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline JRF

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Lightdm completely forzen and cant do anything
« Reply #6 on: November 15, 2019, 04:28:08 pm »
Well I managed to restore the backup through the LiveUSB and now lightdm is working once again. But thanks for your help I very much appreciate it.

The only reason I  tried to do that "blind" amd driver install was that I was under the impression that there were no installed drivers for my amdgpu because it wasnt utilizing it when I use apps like Kdenlive, Gimp or Inkscape but rather it uses the integrated intel graphics, I know should've gotten help first before even doing anything. With lspci and lsmod | grep -i amd it does seem to recognize my gpu. But anyway, when I try to do the DRI_PRIME=1 glxinfo | grep "OpenGL renderer" it doesnt show my descrete amdgpu which it supposed to show because it should load the amdgpu kernel module that needs to be loaded, it only shows my intel one. Are there any possible ways to utilize my discrete amdgpu on apps or is it just stuck using the intel igpu?

Again, Thanks for the Help!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightdm completely forzen and cant do anything
« Reply #7 on: November 15, 2019, 05:14:36 pm »
What's the output from:
Code: [Select]
inxi -Fz
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline JRF

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Lightdm completely forzen and cant do anything
« Reply #8 on: November 15, 2019, 07:16:31 pm »
Here is the output:

System:    Host: zn0n-HP-Laptop-14-bs0xx Kernel: 5.0.0-36-generic x86_64 bits: 64
           Desktop: N/A Distro: Peppermint Ten
Machine:   Device: laptop System: HP product: HP Laptop 14-bs0xx v: Type1ProductConfigId serial: N/A
           Mobo: HP model: 831F v: 17.42 serial: N/A
           UEFI: Insyde v: F.45 date: 07/02/2019
Battery    BAT0: charge: 7.9 Wh 20.5% condition: 38.8/38.8 Wh (100%)
CPU:       Dual core Intel Core i3-7020U (-MT-MCP-) cache: 3072 KB
           clock speeds: max: 2300 MHz 1: 900 MHz 2: 900 MHz 3: 900 MHz 4: 900 MHz
Graphics:  Card-1: Intel HD Graphics 620
           Card-2: Advanced Micro Devices [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 M520]
           Display Server: x11 (X.Org 1.20.4 ) driver: intel
           Resolution: 1366x768@60.01hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           version: 4.5 Mesa 19.0.8
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k5.0.0-36-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: eno1 state: down mac: <filter>
           Card-2: Realtek Device d723 driver: rtl8723de
           IF: wlo1 state: up speed: N/A duplex: N/A mac: <filter>
Drives:    HDD Total Size: 1004.2GB (7.1% used)
           ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB
           ID-2: USB /dev/sdb model: SD/MMC/MS_PRO size: 4.0GB
Partition: ID-1: / size: 35G used: 17G (50%) fs: ext4 dev: /dev/sda6
           ID-2: /home size: 94G used: 44G (50%) fs: ext4 dev: /dev/sda9
           ID-3: swap-1 size: 8.12GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 44.0C mobo: N/A gpu: 36.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 251 Uptime: 10 min Memory: 1420.2/3828.7MB
           Client: Shell (bash) inxi: 2.3.56


Radeon R5 M330  is the exact model of my Discrete AMD GPU
« Last Edit: November 15, 2019, 07:20:37 pm by JRF »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightdm completely forzen and cant do anything
« Reply #9 on: November 16, 2019, 05:56:17 am »
Nope, I'm afraid there's no Linux driver for the M330 any more .. AMD dropped it along with MANY other older cards when they dropped their proprietary FGLRX (it's not covered by amdgpu or amdgpu-pro).

I have exactly the same problem on a Dell E6540 with
Code: [Select]
mark@E6540 ~ $ inxi -G
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           Card-2: Advanced Micro Devices [AMD/ATI] Mars XTX [Radeon HD 8790M]
           Display Server: x11 (X.Org 1.20.4 ) driver: intel
           Resolution: 1600x900@60.00hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile version: 4.5 Mesa 19.1.4
:(
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec