Choose style:

Author Topic: I apologise... VERY stupid questions from a Windows person now on Linux  (Read 104 times)

0 Members and 1 Guest are viewing this topic.

Offline Ferdi

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Hi, Sorry man, just loaded Peppermint on the PC. Loaded cool etc. Now I have the disks icon showing the two HDD's but anchored on the boot one. I have formatted the other HDD which is now empty. The stupid question: In Win I could double click on  MyPC etc and open the HDD with a Double click and see whats inside. Could then also drag and drop a file in there and click on it to open.  How do I do that sort of thing in Linux?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: I apologise... VERY stupid questions from a Windows person now on Linux
« Reply #1 on: November 09, 2019, 12:13:10 pm »
Open the file manager ('Files' in the menu)

Click on the drive/partition in the left-hand column.

now you should see the contents in the right-hand pane.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ferdi

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: I apologise... VERY stupid questions from a Windows person now on Linux
« Reply #2 on: November 10, 2019, 05:44:19 am »
Thanks for the answer.
Finally figured it out by reading the rather sketchy help for newbies on the net and playing with menus and stuff.
1. I formatted the 2nd disk in " Disks"  (from menu at the top of the window) .
2. Finally realised the disk has to be partioned as well. Found that in another menu  - little gear at the bottom of the representation of the disk volume.
3. Then it was automatically mounted (it seems).
4. Then I could copy to it by opening " Files"  and going to the left pane to " Devices"  and clicking on trhe name I gave to the partition.
5. Then the final; trick (it seems) - I had to make a folder, name it and then I could move/save a file to that folder. It seems it does not accept copying into the root of the disk.
Well, it works. But I must say this a a bit clunky.
Thanks.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: I apologise... VERY stupid questions from a Windows person now on Linux
« Reply #3 on: November 10, 2019, 11:26:01 am »
2. Finally realised the disk has to be partioned as well. Found that in another menu  - little gear at the bottom of the representation of the disk volume.

Yep it definitely needs partitioning :)

3. Then it was automatically mounted (it seems).
4. Then I could copy to it by opening " Files"  and going to the left pane to " Devices"  and clicking on trhe name I gave to the partition.

mounted or automounted, there is a difference .. automounted means it's mounted at bootup (we'll figure this out in a bit)

5. Then the final; trick (it seems) - I had to make a folder, name it and then I could move/save a file to that folder. It seems it does not accept copying into the root of the disk.

It should allow copying to the root of the partition (assuming it is mounted correctly, and you have write permission there .. which you must have else you wouldn't be able to create a folder) :-\

with the partition open in the file manager (so it's mounted) .. can you open a terminal and post the output from
Code: [Select]
mount
and
Code: [Select]
sudo fdisk -l
and
Code: [Select]
blkid
and the contents of:-
Code: [Select]
xed /etc/fstab
« Last Edit: November 10, 2019, 11:34:21 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ferdi

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: I apologise... VERY stupid questions from a Windows person now on Linux
« Reply #4 on: November 11, 2019, 10:31:32 am »
Thanks.
It automounts at boot. That suits me. I am getting there playing with it. And yes - you are right - I copied files into the root of the extra disk with the file manager just now. Also figured out that in settings I can tell file manager to open on the location I want to copy to. Then I can drag the file over.
Part of the confusion on my side is I installed it on an old ( slow, duel core Intel) PC so the effects of my clicks etc takes time to register.
It also seems better to wait and reboot after installing something so it can show up.
I will blunder on here and ask when I am in a jam but once one figures out something - like the copying - things tend to fall in the patterns one see more and more clearly.
Thanks again.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: I apologise... VERY stupid questions from a Windows person now on Linux
« Reply #5 on: November 11, 2019, 10:38:46 am »
Oddly some applications installed as snaps/flatpaks don't populate in the main menu until you log off/on.

Or you can just restart the menu with:
Code: [Select]
xfce4-panel -r
and they'll then populate
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec