Author Topic: Some videos not playing on Opera and Chromium (SOLVED)  (Read 1591 times)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera and Chromium
« Reply #30 on: October 30, 2019, 02:40:20 pm »
Did you do anything else to chromium trying to fix widevine before coming here ?

Maybe try purging chromium and pepperflashplugin-nonfree
Code: [Select]
sudo apt-get remove --purge chromium-browser pepperflashplugin-nonfreethen making sure nothing got left behind
Code: [Select]
sudo rm -rv /usr/lib/chromium-browserthen
Code: [Select]
sudo rm -rv /etc/chromium-browserthen reinstall chromium
Code: [Select]
sudo apt-get install chromium-browser pepperflashplugin-nonfreethen try the instructions above again
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera and Chromium
« Reply #31 on: October 30, 2019, 02:49:11 pm »
I did all the steps, but still no DRM enabled. So basically the same as before! :-\

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera and Chromium
« Reply #32 on: October 30, 2019, 02:54:21 pm »
I found the solution! 8) 


The problem was, that I ran the latest Chromium, version 78.0.3904.70-0ubuntu0.18.04.1. Both for Chromium and Chromium widevine I had PPA's installed, that gave access to that latest version.


So that brought me to the idea to boot the installation USB of Peppermint 10 x64, and then to follow all your steps: that resulted in a working Chromium with DRM-support! So I found that the (original) Chromium version on the USB is still 77.0.3865.90, and on thát very version all the customization steps worked out as desired!


I went back into my installed Pep10, deselected both PPA's, removed the Chromium installation of version 78.0.3904.70, and installed version 77.0.3865.90, executed the steps as you described, and all is working now, inclusive DRM-support. Both sites to test were positive! :)


So PCNetSpec, I really want to thank you: without your steps, both for Opera and Chromium, it was still not possible to watch DRM-related videos, and I would have had to abandon my beloved Opera, and Chromium, as a very nice alternative! 8)


I will mark this topic as SOLVED.
« Last Edit: October 31, 2019, 08:59:54 am by paulus »