Author Topic: Installing ROS on Peppermint 10  (Read 694 times)

Offline dzikriihsani

  • Newly Subscribed
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Installing ROS on Peppermint 10
« on: November 07, 2019, 11:57:14 pm »
I have installed ROS Melodic on my Peppermint OS. I follow this instruction when i try rosdep command, i get this error.

reading in sources list data from /etc/ros/rosdep/sources.list.d
Query rosdistro index
Skip end-of-life distro "ardent"
Skip end-of-life distro "bouncy"
Add distro "crystal"

ERROR: Rosdep experienced an error: Could not detect OS, tried ['windows', 'nixos', 'clearlinux', 'ubuntu', 'slackware', 'rhel', 'qnx', 'osx', 'tizen', 'opensuse', 'opensuse', 'opensuse', 'openembedded', 'neon', 'mx', 'mint', 'linaro', 'gentoo', 'funtoo', 'freebsd', 'fedora', 'elementary', 'elementary', 'debian', 'cygwin', 'centos', 'manjaro', 'arch', 'alpine']
Please go to the rosdep page [1] and file a bug report with the stack trace below.
[1] :

rosdep version: 0.17.1

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 144, in rosdep_main
    exit_code = _rosdep_main(args)
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 426, in _rosdep_main
    return _no_args_handler(command, parser, options, args)
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 435, in _no_args_handler
    return command_handlers[command](options)
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 646, in command_update
    skip_eol_distros=not options.include_eol_distros)
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 498, in update_sources_list
    rosdep_data = get_gbprepo_as_rosdep_data(dist_name)
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 150, in get_gbprepo_as_rosdep_data
    ctx = create_default_installer_context()
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 90, in create_default_installer_context
  File "/usr/lib/python2.7/dist-packages/rosdep2/platforms/", line 55, in register_platforms
  File "/usr/lib/python2.7/dist-packages/rosdep2/platforms/", line 82, in register_elementary
    (os_name, os_version) = context.get_os_name_and_version()
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 115, in get_os_name_and_version
    os_name = self.os_detect.get_name()
  File "/usr/lib/python2.7/dist-packages/rospkg/", line 685, in get_name
  File "/usr/lib/python2.7/dist-packages/rospkg/", line 655, in detect_os
    raise OsNotDetected("Could not detect OS, tried %s" % attempted)
OsNotDetected: Could not detect OS, tried ['windows', 'nixos', 'clearlinux', 'ubuntu', 'slackware', 'rhel', 'qnx', 'osx', 'tizen', 'opensuse', 'opensuse', 'opensuse', 'openembedded', 'neon', 'mx', 'mint', 'linaro', 'gentoo', 'funtoo', 'freebsd', 'fedora', 'elementary', 'elementary', 'debian', 'cygwin', 'centos', 'manjaro', 'arch', 'alpine']

Any Solution?
Thanks before.
« Last Edit: November 08, 2019, 12:09:07 am by dzikriihsani »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Installing ROS on Peppermint 10
« Reply #1 on: November 08, 2019, 02:10:57 pm »
Okay, if I had to guess, I'd guess the installer is referencing lsb_release to get information about the distro (so it knows how to install itself)

if you run (as the installer probably is)
Code: [Select]
lsb_release -ayou'll see output like
Code: [Select]
Distributor ID: Peppermint
Description: Peppermint 10 Ten
Release: 10
Codename: bionic
Now it's possible to change this to the Ubuntu output in that terminal session by running
Code: [Select]
export LSB_ETC_LSB_RELEASE=/etc/upstream-release/lsb-releasenow if you (in the same terminal session) run
Code: [Select]
lsb_release -aagain, you'll now see
Code: [Select]
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic
which is probably what the installer is looking for.

So open a terminal, and run:
Code: [Select]
export LSB_ETC_LSB_RELEASE=/etc/upstream-release/lsb-releaseand now in the SAME terminal session, try running the installer again.

The other option is to either ask the ROS developers to add "Peppermint|peppermint" as an available detected OS and treat it the same as "Ubuntu|ubuntu" .. or modify the installer yourself.
« Last Edit: November 08, 2019, 02:13:20 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint