Author Topic: Sound output is not full sounding - but it sounds great in windows  (Read 1008 times)

Offline TacoHammer

  • Newly Subscribed
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Howdy,

I have a Dell Alienware 17-R5 laptop - in windows 10 the sound is full sounding out of both the headphones and the internal speakers. But in Peppermint OS 10, the sound is very thin sounding at best and distorts very quickly.

Here is the output of inxi -Axx
Audio:     Card-1 Intel Cannon Lake PCH cAVS
           driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a348
           Card-2 NVIDIA GP104 High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:10f0
           Sound: Advanced Linux Sound Architecture v: k5.0.0-32-generic

Is there a driver update for the intel sound card that is built into the mother board.?

Anyone able to help me out. I am at a loss on what to do. Everything else seems to be working great.



Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Sound output is not full sounding - but it sounds great in windows
« Reply #1 on: November 04, 2019, 02:33:44 pm »
Can you post the output from:
Code: [Select]
cat /proc/asound/card0/codec* | grep Codecand has sound ever worked in any other Linux distro ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline TacoHammer

  • Newly Subscribed
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Sound output is not full sounding - but it sounds great in windows
« Reply #2 on: November 04, 2019, 03:00:37 pm »
as per requested .. and thank you for any and all help

cat /proc/asound/card0/codec* | grep Codec
Codec: Realtek ALC3266
Codec: Intel Kabylake HDMI


and this is the first distro I have tired on this machine .. Ill boot up Ubuntu from a USB and see how it sounds.

Update.. Ubuntu sounds full and fine .. just not as loud. I think I may be over pumping the volume. I just noticed that the volume slider at 100% is in the middle on Peppermint OS ...)  maybe I am just not paying attention and over modulating the volume at like 120%. . If there is a update great if not, ill pay better attention on the sound. Maybe its just me.

So far really impressed with Peppermint 10

Thank you ..



« Last Edit: November 04, 2019, 03:24:21 pm by TacoHammer »

Offline 151tom

  • Member
  • ***
  • Posts: 95
  • Karma: 16
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 (64 Bit)
Re: Sound output is not full sounding - but it sounds great in windows
« Reply #3 on: November 19, 2019, 10:46:22 am »
Hello TacoHammer,


Not hijacking your thread but I to also have poor audio output quality on a Dell-Inspiron-660 desktop.

I believe the problem is the lack of the proprietary audio driver because when running Windows 7 or Windows 10 the audio output quality is fantastic. (No Disrespect to Linux or Peppermint)

Fortunately I have several other Linux desktops where the audio is excellent so when needing excellent audio I use one of those desktops.

Here's my output.

Spoiler (click here to view / hide)
[close]

Here's the desktop.

Spoiler (click here to view / hide)
[close]




“Under certain circumstances, profanity provides a relief denied even to prayer.” - Mark Twain

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 624
  • Karma: 149
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: Sound output is not full sounding - but it sounds great in windows
« Reply #4 on: November 19, 2019, 04:22:53 pm »
Also make sure you have all the codecs.
Code: [Select]
sudo apt install ubuntu-restricted-extrasThese codecs are quite a vital part in my experience, as you should notice the difference. Especially if you're wearing headphones.

Here is my output on my Lenovo as I'm at work at the moment and have done all my chores, so vegging out here on Peppermint forums is a great way to sit back and relax, not to relaxed though or I'll full asleep and where this is a wakeful night shift The walls have ears, plus those flies that annoy you during the summer, are actually spies for the government and they don't actually get eaten properly by the spiders, as they are in cahoots with each other.

Spoiler (click here to view / hide)
[close]

Here are my specs of my machine
Spoiler (click here to view / hide)
[close]
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 624
  • Karma: 149
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: Sound output is not full sounding - but it sounds great in windows
« Reply #5 on: November 19, 2019, 04:27:57 pm »
Before anyone asks I upgraded via Pep 9 to Pep 10, through PCNetSpec's guide which allows me to have the normal Kernel instead of the 5.0 Kernel.  ;D
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Sound output is not full sounding - but it sounds great in windows
« Reply #6 on: November 20, 2019, 06:34:55 am »
@clatterfordslim

Was it you that had audio issues with the 5.0 kernel (which is why you went with 4.15 from Pep9) ?

I'm wondering if the OP should maybe try a different kernel
(he could test if audio quality is better from a Pep9 LiveUSB first)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 624
  • Karma: 149
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: Sound output is not full sounding - but it sounds great in windows
« Reply #7 on: November 20, 2019, 07:33:08 am »
@clatterfordslim

Was it you that had audio issues with the 5.0 kernel (which is why you went with 4.15 from Pep9) ?

I'm wondering if the OP should maybe try a different kernel
(he could test if audio quality is better from a Pep9 LiveUSB first)

The sound is fine in Intel it was AMD I'm having problems with, with the 5.0 Kernel. Distorts and buzzing I was getting. It'll be worth a shot I reckon him trying out Pep 9. I'll leave a link here https://forum.peppermintos.com/index.php?topic=7843.0 Download it Tacohammer and try it out on USB with the sound, just to see if it makes any difference. Here is link if you decide to install Pep 9, this link will give you instructions to upgrade to Pep 10 Read through them carefully and do not add the 5.0 Kernel as you could find yourself in trouble. https://forum.peppermintos.com/index.php/topic,8784.0.html  :)
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Sound output is not full sounding - but it sounds great in windows
« Reply #8 on: November 20, 2019, 08:25:11 am »
Here's the direct download links for the Pep9 Respin ISO's

Peppermint 9 (64bit)
https://peppermintos.com/iso/Peppermint-9-20190102-amd64.iso
md5sum: 245bd2d7bb12e5adac7d09e71cca7f98

Peppermint 9 (32bit)
https://peppermintos.com/iso/Peppermint-9-20190102-i386.iso
md5sum: 776779bc22d78c46ed33fb811df2a414

Just in case the OP wants to try it on a LiveUSB

If audio is better on Pep9, it can be upgraded to Pep10 (but without moving to the 5.0 kernel) by following the instructions here:
https://forum.peppermintos.com/index.php/topic,8442.msg86655.html#msg86655
« Last Edit: November 20, 2019, 08:28:20 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec