Choose style:

Author Topic: Some videos not playing on Opera and Chromium (SOLVED)  (Read 1268 times)

0 Members and 1 Guest are viewing this topic.

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Some videos not playing on Opera and Chromium (SOLVED)
« on: October 27, 2019, 05:36:42 am »
Hi all,


After a while I'm glad to be back on Peppermint (10)!


I am still struggling with the above problem. I performed all the steps, even with the newest libffmpeg.so from the site https://github.com/iteufel/nwjs-ffmpeg-prebuilt/releases/. This is version 0.41.3, 64bit.

But in my case Chromium does not play the videos either, so that is also a problem! But replacing with the newest version of libffmpeg.so, version 0.41.3, should have solved the problem in Opera, but it didn't.

Opera (stable) = version 64.0.3417.73, and Chromium = version 78.0.3904.70; the same version of chromium-codecs-ffmpeg-extra. I run Peppermint 10 for 64 bit.

Who can help me further?
« Last Edit: October 31, 2019, 12:00:32 pm by paulus »

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera
« Reply #1 on: October 27, 2019, 07:19:10 am »
To add to my post:


Example of video that does NOT play, both in Opera and Chromium: https://www.npostart.nl/live/npo-1. This site is reached without being logged in.


Maybe the above steps don't apply anymore, because of the updates, both of Opera and Chromium? Or is a setting wrong in my installation of Peppermint 10 or of ffmpeg?
« Last Edit: October 27, 2019, 09:44:32 am by paulus »

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera
« Reply #2 on: October 27, 2019, 09:36:02 am »
In the meantime I don't sit there and do nothing! ;)


I installed libavcodec-dev 7:4.1.3-0ppa1~18.04, but that didn't do better.


What to try next? :-\
« Last Edit: October 27, 2019, 09:44:59 am by paulus »

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera
« Reply #3 on: October 27, 2019, 10:57:03 am »
I tried Google Chrome and Slimjet 24.0.5.0: both show all videos without moderation!


So I tend to believe my installation of Peppermint 10 and of ffmpeg are fine. Is that assumption justified?!

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera
« Reply #4 on: October 27, 2019, 11:54:47 am »
Is it possible that anyone tries to reach mentioned site and tries to play videos on that site?


It is not difficult to do: just visit with a not-customized latest version of opera-stable that site, and tell if that is possible. And if not: what are the needed customizations to make it possible?

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5722
  • Karma: 1077
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Some videos not playing on Opera
« Reply #5 on: October 27, 2019, 12:22:58 pm »
Is it possible that anyone tries to reach mentioned site and tries to play videos on that site?

Videos don't play in Opera, for me, but the live radio streams work   ;)



Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera
« Reply #6 on: October 27, 2019, 12:29:55 pm »
Hi VinDSL,


Thanks for trying. That's right: radio stream is not the problem.


Do you have a solution for it to also play videos, or an explanation for not able to do it anymore as described above?

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5722
  • Karma: 1077
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Some videos not playing on Opera
« Reply #7 on: October 27, 2019, 07:43:06 pm »
Do you have a solution for it to also play videos, or an explanation for not able to do it anymore as described above?

Nope. Just saying...

I tried turning off the 'VPN' feature - no difference.

Then, I turned off the 'Ad Blocker' - no difference.

I turned off the 'Tracker Blocker' - no difference.

All I got was the swirlygig when trying to watch videos  ::)

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera
« Reply #8 on: October 28, 2019, 06:32:13 am »
I know. I always had those features turned off. But before it was possible to watch videos, as the subject line of this thread indicates!


So the cause is not in the features you turned off to check whether it made any difference. It should be possible to track down the dis-function of Opera to watch certain videos.


These videos are always DRM-related: in Firefox you have to enable DRM, in order to play these videos.


So my question still is: who is able to track down the cause of not being able any more to watch DRM-based videos in Opera? Who knows the solution to this?



Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera
« Reply #9 on: October 28, 2019, 01:46:44 pm »
Nobody out there? :o

Offline jlschwartz

  • Trusted User
  • Member
  • *****
  • Posts: 391
  • Karma: 163
  • Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10 - 64bit
Re: Some videos not playing on Opera
« Reply #10 on: October 28, 2019, 04:10:26 pm »
My only suggestion is switch to Firefox.

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera
« Reply #11 on: October 28, 2019, 05:23:54 pm »
I understand your proposal, but that is just a going-around the problem, not a solution.


Of course I have to use another browser if there will not come up a solution. But the lightness of Opera, the stepless pop-out feature of videos, without loss of quality when hovering over it, as seen with Google Chrome, the further unique features of Opera, are such advantages that I will miss those very much when switching to another browser. >:(


In case no solution is found, I think the addition of "(SOLVED)" in the subject line of this thread, should be removed, as this case is not solved at all! :'(

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5722
  • Karma: 1077
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Some videos not playing on Opera
« Reply #12 on: October 28, 2019, 05:50:56 pm »
[...] I think the addition of "(SOLVED)" in the subject line of this thread, should be removed, as this case is not solved at all! :'(

Agreed!

Topic split...  8)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Some videos not playing on Opera
« Reply #13 on: October 28, 2019, 08:24:44 pm »
Is this purely an Opera problem ?

I mean, do these videos play in say Chromium ?

Can you gimme a link to one that doesn't work in Opera, so I can be sure I'm testing a known problematic video ?



Oh, the earlier topic COULDN'T be unmarked as (SOLVED) because you didn't own (start) the topic, and we're not about to change the marking on someone else's topic when they obviously DID consider it solved. This is precisely why we ask people to start their own topics rather than add to other peoples ;)
« Last Edit: October 28, 2019, 08:28:52 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5722
  • Karma: 1077
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Some videos not playing on Opera
« Reply #14 on: October 28, 2019, 08:31:03 pm »
Nudge, nudge, wink, wink...  :)