Choose style:

Author Topic: RealVNC covering/overlapping switchers in fullscreen  (Read 161 times)

0 Members and 1 Guest are viewing this topic.

Offline jasonamendola

  • nOOb
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
RealVNC covering/overlapping switchers in fullscreen
« on: November 01, 2019, 01:23:51 pm »
Hello,
I'm not sure if this is the correct place, but it's where I'm going to start.
I'm trying to run RealVNC viewer in fullscreen.
I'm currently trying to use the application cairo-dock switcher, but the same issue occurs with the stock installed workspace switcher on the panel.
I have both the switchers to always remain on top which works fine until I go fullscreen then the swichers are hidden.
I have tried setting the vncviewer application to below but that doesn't work.
The thing is of all the linux distros that I have tested the only distro where it works as expected is Linux Mint Cinnamon.
I am currently using that but want switch as it is meant for newer graphics and I'm running on an old server.
Do you know what could be causing this and it there is a workaround?  Or is this a RealVNC issue?  I've also tried playing around with wmctrl to no avail.

Thanks,
Jason Amendola

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26313
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: RealVNC covering/overlapping switchers in fullscreen
« Reply #1 on: November 02, 2019, 01:07:32 pm »
You could try installing, then switching to the muffin window manager (as used by Linux Mint), but I doubt if that on its own will work because full screen apps are 'supposed' to override window manager stacking priorities.
(in fact I'm surprised you say it works in Mint)



As muffin is a fork of metacity it might be better to try that first.

First make sure metacity is installed (I think it is installed by default anyway for the installer .. but check anyway)
Code: [Select]
sudo apt-get install metacity
then either swap to the metacity window manager just for this session with
Code: [Select]
metacity --replace
or make it permanent by going to

Menu > Settings > Default applications for LXSession > Core applications (tab)

and changing:-

Window Manager: xfwm4

to:-

Window Manager: metacity

Close the LXSession configuration window

then log off and on.



As I said, you can also try muffin instead of metacity .. but something tells me neither will do what you want.
« Last Edit: November 02, 2019, 01:21:26 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec