Author Topic: Microsoft .NET Framework 4.6.2 under Peppermint 10  (Read 594 times)

Offline naairuj

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Microsoft .NET Framework 4.6.2 under Peppermint 10
« on: October 27, 2019, 10:22:34 am »
I have Peppermint 10 installed, and I want to run some software I wrote under Windows with Visual Studio for Microsoft .NET Framework 4.6.2 (x86 and x64), I know it is possible, but I am searching for a step by step tutorial on how to run it.

Juriaan

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 624
  • Karma: 149
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: Microsoft .NET Framework 4.6.2 under Peppermint 10
« Reply #1 on: October 27, 2019, 05:59:38 pm »
If you're trying to run Microsoft .NET you'll need WINE installed, it stands for Wine Is Not Emulator. Basically it lets you run Windows programs.
Link to install wine instructions below.

https://tinyurl.com/yyt6namq
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Microsoft .NET Framework 4.6.2 under Peppermint 10
« Reply #2 on: October 28, 2019, 05:30:18 pm »
Why do you want .NET installed in the first place ?

What are you trying to run that requires it ?
(I mean is there any guarantee it'll run in Linux? .. or does it require Windows?)

What I'm asking is - is all you require say mono and some of its libs/modules (maybe try installing mono-complete) ?
https://www.linux.com/news/running-net-applications-linux-mono/

I'd assume if you wrote it you'd be the best person to know what it requires .. maybe search the Synaptic Package Manager for mono and see if any of the LOADS of mono packages/libs jumps out at you.
« Last Edit: October 28, 2019, 05:43:36 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline naairuj

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Microsoft .NET Framework 4.6.2 under Peppermint 10
« Reply #3 on: October 29, 2019, 04:17:21 am »
Thank you for your reply: I know I need this WINE installed. What I am looking is a step by step tutorial, and since WINE is related to the app, I would like to add it is an app written in Visual Studio 2017 with  Microsoft .NET Framework 4.6.2 (x86 and x64)


If you're trying to run Microsoft .NET you'll need WINE installed, it stands for Wine Is Not Emulator. Basically it lets you run Windows programs.
Link to install wine instructions below.

https://tinyurl.com/yyt6namq