Choose style:

Author Topic: Capslock  (Read 169 times)

0 Members and 1 Guest are viewing this topic.

Offline Johan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Capslock
« on: October 05, 2019, 10:10:39 am »
Hi all,

I added setxkbmap -option caps:none in Autostart to kill Capslock, but after almost every new kernel update Capslock is back on, but it's still in Autostart. Is there a way to kill capslock permanantly? I hate Capslock and never use it. Thanks in advance.
Once Peppermint, always Peppermint.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Capslock
« Reply #1 on: October 05, 2019, 11:07:21 am »
Undo what you've already done (remove it from autostart) .. then run:
Code: [Select]
xed ~/.config/autostart/disable-capslock.desktop
and when a blank file opens, make it read:-
Code: [Select]
[Desktop Entry]
Type=Application
Name=Disable CapsLock
Comment=Disable the CapsLock key.
Exec=bash -c '/usr/bin/setxkbmap -option "caps:none" && /usr/bin/setxkbmap -option "shift:both_capslock"'
Terminal=false
SAVE the file .. then log off/on (or reboot) to test.

BTW, the above should disable the CapsLock key, but allow you to toggle (enable/disable) CapsLock by pressing BOTH Shift keys simultaneously.



To UNDO permanently
Code: [Select]
rm -v ~/.config/autostart/disable-capslock.desktop ; setxkbmap -option
To UNDO temporarily (until next login)
Code: [Select]
setxkbmap -option
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Johan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Capslock
« Reply #2 on: October 05, 2019, 01:23:56 pm »
Thanks Mark 8) Capslock is disabled after reboot, but each time when I click on Capslock I get this: <<<<<
Once Peppermint, always Peppermint.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Capslock
« Reply #3 on: October 05, 2019, 01:46:39 pm »
run:
Code: [Select]
setxkbmap -option
then
Code: [Select]
/usr/bin/setxkbmap -option "caps:none"
do you still get that "<<<<<" when you click the CapsLock?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Johan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Capslock
« Reply #4 on: October 05, 2019, 02:52:34 pm »
No, but after reboot yes this: <
Once Peppermint, always Peppermint.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Capslock
« Reply #5 on: October 05, 2019, 03:01:55 pm »
Run:
Code: [Select]
xed ~/.config/autostart/disable-capslock.desktop
and change to read :
Code: [Select]
[Desktop Entry]
Type=Application
Name=Disable CapsLock
Comment=Disable the CapsLock key.
Exec=bash -c '/usr/bin/setxkbmap -option "caps:none"'
Terminal=false
SAVE the file .. reboot to test.
« Last Edit: October 05, 2019, 04:06:09 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Johan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Capslock
« Reply #6 on: October 05, 2019, 03:33:21 pm »
No still this < when I click on Capslock.
« Last Edit: October 05, 2019, 03:45:17 pm by Johan »
Once Peppermint, always Peppermint.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Capslock
« Reply #7 on: October 05, 2019, 04:05:47 pm »
I can only assume then that you haven't fully undone what you'd done originally.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Johan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Capslock
« Reply #8 on: October 05, 2019, 04:36:25 pm »
I used setxkbmap -option caps:none to disable Capslock and I added that command in Autostart. Before I applied your script, I removed it from Autostart and pasted setxkbmap -option in terminal to enable Capslock again. Then I applied the script. But it's not a big deal Mark. It's very strange because Capslock isn't enabled after each kernel update. Thanks anyway  ;)
Once Peppermint, always Peppermint.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Capslock
« Reply #9 on: October 05, 2019, 04:42:44 pm »
Well all my autostart script does is the same thing .. it runs:
Code: [Select]
/usr/bin/setxkbmap -option "caps:none"
at each login.

So if removing all changes with
Code: [Select]
setxkbmap -option
then running
Code: [Select]
/usr/bin/setxkbmap -option "caps:none"
results in the CapsLock disabled and NOT leaving ">>>>"

Then I can only assume that when you reboot, something else is still being changed :-\



What's the output from:
Code: [Select]
ls ~/.config/autostart
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Johan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Capslock
« Reply #10 on: October 06, 2019, 12:40:22 am »
This: disable-capslock.desktop  peppermint-control-center.desktop
light-locker.desktop      xbindkeys.desktop
Once Peppermint, always Peppermint.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Capslock
« Reply #11 on: October 06, 2019, 07:37:49 am »
I wonder if changing it to
Code: [Select]
[Desktop Entry]
Type=Application
Name=Disable CapsLock
Comment=Disable the CapsLock key.
Exec=bash -c '/usr/bin/setxkbmap -option && /usr/bin/setxkbmap -option "caps:none"'
Terminal=false
would make a difference ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Johan

  • Jr. Member
  • **
  • Posts: 82
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Capslock
« Reply #12 on: October 06, 2019, 10:55:45 am »
No didn't make a difference. But it's not that big a deal. I use setxkbmap -option caps:none. Like I did before to disable Capslock, so I won't get this < If I use Shift Capslock this: >
Once Peppermint, always Peppermint.

Offline windrose

  • Jr. Member
  • **
  • Posts: 36
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): current just downloaded
Re: Capslock
« Reply #13 on: October 10, 2019, 11:50:09 pm »
No where near the knowledge of others trying to help but l experienced a similar situation while trying to change keyboard "country".
Being a Canadian l was wanting to change the little American Flag in the bottom right corner that signify s the keyboard layout. Long story short..there is no Canadian flag so l opted for the flag of Great Britain but the key pad changed and whenever l pressed " @" l typed  something else..can't recall now what..but it was driving me crazy when entering an email address...switched back to the USA flag and back to normal.

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1777
  • Karma: 469
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Capslock
« Reply #14 on: October 11, 2019, 03:59:57 am »
Hi windrose,

Is the standard keyboard layout in Canada different from the one in USA? If so, which keys are different?

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome