Choose style:

Author Topic: Steam DX11 feature level 10.0 is required  (Read 221 times)

0 Members and 1 Guest are viewing this topic.

Offline kloos

  • Member
  • ***
  • Posts: 102
  • Karma: 10
  • Fairly new at Linux
    • View Profile
  • Peppermint version(s): Peppermint 9 & 10 (64 bit)
Steam DX11 feature level 10.0 is required
« on: September 26, 2019, 03:25:12 pm »
Hi all,

I have downloaded a couple of games lately (Life is Strange 2 & Adventures of Captain Spirit) which come up with the above error when I try to run them.  According to ProtonDB the compatibility is Platinum so they should run ok.  Can anyone help me out please on whether Peppermint can run these games and how I can do it?

I am trying to run them using Proton 4.11-6.

Thanks

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Steam DX11 feature level 10.0 is required
« Reply #1 on: September 26, 2019, 03:40:20 pm »
What's the output from:
Code: [Select]
inxi -Fz
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kloos

  • Member
  • ***
  • Posts: 102
  • Karma: 10
  • Fairly new at Linux
    • View Profile
  • Peppermint version(s): Peppermint 9 & 10 (64 bit)
Re: Steam DX11 feature level 10.0 is required
« Reply #2 on: September 26, 2019, 03:43:41 pm »
System:    Host: martin-PORTEGE-R930 Kernel: 4.15.0-64-generic x86_64 bits: 64
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: laptop System: TOSHIBA product: PORTEGE R930 v: PT330E-0DC044EN serial: N/A
           Mobo: TOSHIBA model: PORTEGE R930 v: Version A0 serial: N/A
           BIOS: TOSHIBA v: Version 6.60 date: 01/15/2013
CPU:       Dual core Intel Core i5-3230M (-MT-MCP-) cache: 3072 KB
           clock speeds: max: 3200 MHz 1: 2809 MHz 2: 2798 MHz 3: 2804 MHz
           4: 2780 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.17hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile
           version: 4.2 Mesa 19.0.8
Audio:     Card Intel 7 Series/C216 Family High Def. Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-64-generic
Network:   Card-1: Intel 82579V Gigabit Network Connection driver: e1000e
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6235 driver: iwlwifi
           IF: wlp4s0 state: up mac: <filter>
Drives:    HDD Total Size: 256.1GB (73.0% used)
           ID-1: /dev/sda model: Crucial_CT256MX1 size: 256.1GB
Partition: ID-1: / size: 44G used: 41G (99%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 63.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 236 Uptime: 1:15 Memory: 3215.4/7871.0MB
           Client: Shell (bash) inxi: 2.3.56

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Steam DX11 feature level 10.0 is required
« Reply #3 on: September 26, 2019, 03:45:56 pm »
I don't know if your graphics card is up to the job, but try installing
Code: [Select]
sudo apt-get install mesa-vulkan-drivers mesa-vulkan-drivers:i386 libvulkan1 libvulkan1:i386
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kloos

  • Member
  • ***
  • Posts: 102
  • Karma: 10
  • Fairly new at Linux
    • View Profile
  • Peppermint version(s): Peppermint 9 & 10 (64 bit)
Re: Steam DX11 feature level 10.0 is required
« Reply #4 on: September 26, 2019, 04:10:58 pm »
The good news is that YAY it works. :D
The rather bad news is that I just dropped my laptop and the wifi has stopped working (connected using the shortest cable in the world and sat on the hall floor typing this). :'(

Sigh.... Maybe I will have to save up my pennies and buy a new one as per my other post a few weeks ago

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Steam DX11 feature level 10.0 is required
« Reply #5 on: September 26, 2019, 09:04:49 pm »
Ouch :(
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec