Choose style:

Author Topic: modprobe i2c-i801 working , but not permanently (SOLVED)  (Read 89 times)

0 Members and 1 Guest are viewing this topic.

Offline Meridian

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): PepperminTen
modprobe i2c-i801 working , but not permanently (SOLVED)
« on: September 03, 2019, 01:33:28 pm »
Hello,

I am running PeppemintTen on a Asus P4T-E (P4 Rambus) with 1 Gig Ram /fairly old PC, dual boot with W2K (extended Kernel Version).
So there are fans running all the time , so I want them and the temps to be recognized and later on regulated automatically.

This is the situation, after boot: i2c-i801 is not recognized permanently.
I have created a .conf file containing one Line:
i2c-i801
on various locations /etc/moduke-load.d/TheFile.conf
but this did not work.
After rebooting and executing this in the console:

bk@WUERM ~ $ sensors
nouveau-pci-0100
Adapter: PCI adapter
temp1:        +32.0C  (high = +95.0C, hyst =  +3.0C)
                       (crit = +130.0C, hyst = +10.0C)
                       (emerg = +135.0C, hyst =  +5.0C)

bk@WUERM ~ $ sudo modprobe i2c-i801
[sudo] Passwort fr bk:
bk@WUERM ~ $ sensors
nouveau-pci-0100
Adapter: PCI adapter
temp1:        +32.0C  (high = +95.0C, hyst =  +3.0C)
                       (crit = +130.0C, hyst = +10.0C)
                       (emerg = +135.0C, hyst =  +5.0C)

as99127f-i2c-3-2d
Adapter: SMBus I801 adapter at e800
in0:          +1.44 V  (min =  +1.14 V, max =  +1.55 V)
in1:          +1.76 V  (min =  +1.14 V, max =  +1.55 V)  ALARM
in2:          +3.26 V  (min =  +2.96 V, max =  +3.63 V)
in3:          +2.91 V  (min =  +2.67 V, max =  +3.28 V)
in4:          +3.17 V  (min =  +2.51 V, max =  +3.79 V)
in5:          +0.62 V  (min =  +0.08 V, max =  +1.02 V)
in6:          +3.58 V  (min =  +0.54 V, max =  +1.17 V)
fan1:        3276 RPM  (min = 2732 RPM, div = 2)
fan2:        2710 RPM  (min = 2689 RPM, div = 2)  ALARM
fan3:        3750 RPM  (min = 6428 RPM, div = 2)
temp1:        +28.0C  (high = +29.0C, hyst =  -5.0C)
temp2:        +35.0C  (high = +100.0C, hyst = +90.0C)
temp3:         -0.5C  (high = +122.0C, hyst = +121.0C)
cpu0_vid:    +1.500 V
beep_enable: enabled

bk@WUERM ~ $

________
Thanks for your advise , Greeting B.Kochs
« Last Edit: September 05, 2019, 02:03:52 pm by Meridian »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: modprobe i2c-i801 working , but not permanently
« Reply #1 on: September 03, 2019, 07:56:00 pm »
Try this....

First you'll need to remove the blacklist for the i2c_i801 module, so run:
Code: [Select]
gksudo xed /etc/modprobe.d/blacklist.conf
find the line that reads
Code: [Select]
blacklist i2c_i801
and change it to
Code: [Select]
# blacklist i2c_i801
SAVE the file and exit the text editor.

REBOOT now  <-- IMPORTANT

Once rebooted check to see if the i2c_i801 (aka. i2c-i801) module is now being loaded automagically at bootup by running
Code: [Select]
lsmod | grep i2c_i801
if you get any output from that command great you can STOP HERE.

If on the other hand you get NO output from that command you'll need to manually add the module to /etc/modules so it loads at bootup automagically...

Run:
Code: [Select]
gksudo xed /etc/modules
add a NEW LINE at the bottom that reads
Code: [Select]
i2c_i801
SAVE the file and exit the text editor.

Reboot to test.
« Last Edit: September 03, 2019, 08:33:26 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Meridian

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): PepperminTen
Re: modprobe i2c-i801 working , but not permanently
« Reply #2 on: September 04, 2019, 05:50:26 am »
Hello,

i2c_i801 removing from blacklist helped.

Thanks a lot.

Greetings B.Kochs

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: modprobe i2c-i801 working , but not permanently
« Reply #3 on: September 04, 2019, 10:26:07 am »
You're most welcome, glad I could help :)

If you now consider this topic (SOLVED) can you please remember to mark it so, you can do this by editing the FIRST posting in this topic and changing:-

Subject: modprobe i2c-i801 working , but not permanently (SOLVED)

Thanks in advance.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec