Choose style:

Author Topic: gufw not autostart on (SOLVED)  (Read 190 times)

0 Members and 1 Guest are viewing this topic.

Offline leepton

  • nOOb
  • *
  • Posts: 4
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
gufw not autostart on (SOLVED)
« on: August 31, 2019, 03:53:22 pm »
hello , i m starting to use linux with peppermint 10 i come from win10. i love peppermint 10 .

the problem : when login gufw its off

how to set gufw on on computer startup

thats all

thanks in advance

Sir Leepton Hais Tee
« Last Edit: September 03, 2019, 07:24:18 pm by PCNetSpec, Reason: marked as (SOLVED) »
Best Regards,

Sir Leepton Hais Tee

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25930
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: gufw not autostart on
« Reply #1 on: September 01, 2019, 06:37:22 pm »
Hi leepton and welcome to the forum :)

Open a terminal by hitting Ctrl+Alt+T

In the terminal enter this command:
Code: [Select]
sudo ufw enable
and hit the Enter key to run the command.

You will be prompted to enter your password, enter your password and hit Enter again.
(please be aware, when entering your password nothing will be echoed to screen, not even **** but this is normal .. just enter your password then hit Enter).

Now test that gufw is started upon boot.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline leepton

  • nOOb
  • *
  • Posts: 4
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: gufw not autostart on
« Reply #2 on: September 02, 2019, 03:51:55 pm »
Hello Thanks for your really clear explanantion .

i written the command in the terminal and i got the message that ufw was set on autostart. after i opened gufw and was on .

unfortunaly when i shutoff the pc and i started again the gufw was off .

there is a way to set the gufw on at staring?

i have win10 and peppermint 10 in dual bot on the pc in object

Best Regards,

Sir Leepton Hais Tee

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25930
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: gufw not autostart on
« Reply #3 on: September 02, 2019, 06:17:20 pm »
Are you using anything else that might be using iptables ?
(a VPN maybe ?)

What's the output from:
Code: [Select]
sudo iptables -S
and
Code: [Select]
sudo ip6tables -S
and
Code: [Select]
cat /etc/ufw/ufw.conf
and
Code: [Select]
systemctl | grep -i exited



These links are here for my future reference
https://forums.linuxmint.com/viewtopic.php?f=47&t=256760&start=20

https://bbs.archlinux.org/viewtopic.php?id=169846

https://bugs.launchpad.net/ubuntu/+source/ufw/+bug/1726856

https://askubuntu.com/questions/1040539/how-do-i-get-ufw-to-start-on-boot
« Last Edit: September 02, 2019, 06:40:05 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline leepton

  • nOOb
  • *
  • Posts: 4
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: gufw not autostart on
« Reply #4 on: September 02, 2019, 06:39:17 pm »
yes sorry i forgot to tell i have nordvpn installed on autostart.

i ll try to re write your command with vpn off

sudo iptables -S

leepton@hais-tee ~ $ sudo iptables -S
[sudo] password for leepton:
-P INPUT DROP
-P FORWARD ACCEPT
-P OUTPUT DROP
-A INPUT -i tun0 -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A INPUT -s 185.128.27.237/32 -i lo -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A INPUT -s 127.0.0.0/8 -i lo -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A INPUT -s 185.128.27.237/32 -i wlp1s0 -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A INPUT -s 192.168.1.0/24 -i wlp1s0 -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A INPUT -s 185.128.27.237/32 -i tun0 -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A INPUT -s 10.8.8.0/24 -i tun0 -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A OUTPUT -d 103.86.99.99/32 -o lo -p udp -m udp --dport 53 -j ACCEPT
-A OUTPUT -d 103.86.96.96/32 -o lo -p udp -m udp --dport 53 -j ACCEPT
-A OUTPUT -d 103.86.99.99/32 -o tun0 -p udp -m udp --dport 53 -j ACCEPT
-A OUTPUT -d 103.86.96.96/32 -o tun0 -p udp -m udp --dport 53 -j ACCEPT
-A OUTPUT -o tun0 -j ACCEPT
-A OUTPUT -d 185.128.27.237/32 -o lo -j ACCEPT
-A OUTPUT -d 127.0.0.0/8 -o lo -j ACCEPT
-A OUTPUT -d 185.128.27.237/32 -o wlp1s0 -j ACCEPT
-A OUTPUT -d 192.168.1.0/24 -o wlp1s0 -j ACCEPT
-A OUTPUT -d 185.128.27.237/32 -o tun0 -j ACCEPT
-A OUTPUT -d 10.8.8.0/24 -o tun0 -j ACCEPT
-A OUTPUT -o lo -j ACCEPT
leepton@hais-tee ~ $

i ll ry to power off and on to see if the firewall autostart with vpn autoconnect off and killswitch off

Best Regards,

Sir Leepton Hais Tee

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25930
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: gufw not autostart on
« Reply #5 on: September 02, 2019, 06:41:22 pm »
Yeah ufw/gufw is just a frontend for iptables, so if something else is already configuring iptables.....
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline leepton

  • nOOb
  • *
  • Posts: 4
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: gufw not autostart on
« Reply #6 on: September 02, 2019, 06:43:33 pm »
thanks you solved the mistery !!!!

now gufw start on pc power on

thnaks a lot
Best Regards,

Sir Leepton Hais Tee

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25930
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: gufw not autostart on
« Reply #7 on: September 03, 2019, 07:23:54 pm »
You're welcome :)

Can you please remember to mark your topics (SOLVED) when you consider them so. You can do this by editing the FIRST posting in your topic and changing

Subject: gufw not autostart on (SOLVED)

I've done this one for you, but can you please remember for the future .. TIA :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec