Choose style:

Author Topic: Application runs but only shows a black screen (RStudio)  (Read 202 times)

0 Members and 1 Guest are viewing this topic.

Offline Skyler

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Application runs but only shows a black screen (RStudio)
« on: August 12, 2019, 06:10:07 am »
Hi Everyone,

for a couple of days now, I have been having problems with RStudio.
Whenever I open it, the program starts up but all I see is a black screen.

The program seems to be useable, however, it just doesn't show anything on the screen.
I can hover over the place where buttons should be and my cursor indicates that there are clickable buttons.
I can even open some of the options-menus (but not select any of those options).

This happened from one day to another with no apparent explanation.
I didn't install/delete any software, I didn't do any updates, etc.

My system is running Peppermint 10 and everything is fully up to date.
Reinstalling RStudio has not helped.
Base R (version 3.6.1) and all other applications are running fine, it's just RStudio.

Does anyone have any idea what might be causing this problem?
I would be very grateful for your advice.

Kind regards,
Skyler

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26037
  • Karma: 2837
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Application runs but only shows a black screen (RStudio)
« Reply #1 on: August 12, 2019, 08:44:07 am »
what's the output from:
Code: [Select]
ls ~/.config
and
Code: [Select]
ls ~/.cache
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Skyler

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Application runs but only shows a black screen (RStudio)
« Reply #2 on: August 12, 2019, 04:20:57 pm »
Hi PCNetSpec,

Thank you for your reply.

The first command gives me the following output:
Code: [Select]
~ $ ls ~/.config
 autostart                nemo                        transmission
 chromium                 nitrogen                    Trolltech.conf
 dconf                    numix-folders               Turtl
 enchant                  okularpartrc                tutanota-desktop
 google-chrome            okularrc                    user-dirs.dirs
 gtk-2.0                  pcloud                      user-dirs.locale
 gtk-3.0                  peppermint-control-center   vivaldi
 kactivitymanagerdrc      pulse                       vlc
 libfm                    QtProject.conf              xed
 libreoffice              R                           xfce4
 linuxmint                RStudio                     xplayer
 lxsession                sakura                      xviewer
 lxsession-default-apps  'Standard Notes'             yelp
 mimeapps.list            torbrowser

The second command generates this output:
Code: [Select]
~ $ ls ~/.cache
 dconf
 event-sound-cache.tdb.936f510438b417af2c85c1fc5c0f8f19.x86_64-pc-linux-gnu
 flatpak
 fontconfig
 gnome-help
 gnome-software
 google-chrome
 gstreamer-1.0
 icon-cache.kcache
 kio_http
'ksycoca5_en_tUH_7zpp8BqW32fi8yVKaI2bYfo='
 lxsession
 lxsession-default-apps
 mesa_shader_cache
 mintinstall
 mozilla
 qt_compose_cache_little_endian_936f510438b417af2c85c1fc5c0f8f19
 qtshadercache
 thumbnails
 torbrowser
 vivaldi
 wallpaper
 xreader
 yelp

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26037
  • Karma: 2837
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Application runs but only shows a black screen (RStudio)
« Reply #3 on: August 12, 2019, 05:24:27 pm »
What happens if you (with RStudio CLOSED), delete the config folder

~/.config/RStudio

THEN start RStudio

?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Skyler

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Application runs but only shows a black screen (RStudio)
« Reply #4 on: August 13, 2019, 02:09:31 am »
Thank you for your recommendation. I deleted the folder, but that didn't change anything.

When I open RStudio now, I still only get a black screen even though the underlying program seems to be functioning (I can still click on buttons, I just cannot see what I am actually doing).

« Last Edit: August 13, 2019, 01:56:28 pm by PCNetSpec, Reason: fixed image link »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26037
  • Karma: 2837
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Application runs but only shows a black screen (RStudio)
« Reply #5 on: August 13, 2019, 01:41:03 pm »
I'm afraid I've no idea then, this is probably more a question for the RStudio developers.

[EDIT]

Apparently it's already known about over there:
https://github.com/rstudio/rstudio/issues/2755

One of the possible solutions suggests renaming the directory:-

~/.Rprofile



Others suggest simply using an older version.
« Last Edit: August 13, 2019, 01:57:55 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Skyler

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Application runs but only shows a black screen (RStudio)
« Reply #6 on: August 14, 2019, 05:23:18 am »
Okay, I will look into that option.
I hadn't stumbled across that GitHub feed, there seem to be a number of suggested solutions on there.

Thank you so much for your help, I really appreciate it!

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26037
  • Karma: 2837
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Application runs but only shows a black screen (RStudio)
« Reply #7 on: August 14, 2019, 03:04:36 pm »
Good luck, sorry I couldn't help more :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec