Choose style:

Author Topic: Resolution and panel problem after new install (SOLVED)  (Read 308 times)

0 Members and 1 Guest are viewing this topic.

Offline censor

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Resolution and panel problem after new install (SOLVED)
« on: August 04, 2019, 03:45:04 pm »
I have set in the powermgmt under Display  blank  after 4min and put to sleep after 8min. when the screen goes in locked mode the resolution sets in 800x600 and sets back on 1920x1080 after login and desktop loads.
Nvidia driver is version 390
Another problem i have after install Pepp10 is that i cant get the default taskpanel active on my primary monitor, its only appear on the last monitor of 3.

Peppermint 10


Hardware spec
Machine: Type: Desktop Mobo: ASUSTeK model: SABERTOOTH P67 v: Rev 1.xx serial: <filter> UEFI: American Megatrends
v: 3602 date: 11/01/2012
Battery: Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M560 charge: 0% status: Discharging
CPU: Topology: Quad Core model: Intel Core i5-3470S bits: 64 type: MCP arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23275
Speed: 2481 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 2416 2: 2775 3: 2785 4: 2450
Graphics: Device-1: NVIDIA GK104 [GeForce GTX 680] vendor: eVga.com. driver: nvidia v: 430.40 bus ID: 01:00.0
Display: x11 server: X.Org 1.19.6 driver: nvidia resolution: 1920x1200~60Hz, 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 680/PCIe/SSE2 v: 4.6.0 NVIDIA 430.40 direct render: Yes
Audio: Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 00:1b.0
« Last Edit: August 06, 2019, 03:25:24 am by censor »

Offline censor

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Resolution and panel problem after new install
« Reply #1 on: August 05, 2019, 04:42:05 am »
I have set in the powermgmt under Display  blank  after 4min and put to sleep after 8min. when the screen goes in locked mode the resolution sets in 800x600 and sets back on 1920x1080 after login and desktop loads.
Nvidia driver is version 390
Another problem i have after install Pepp10 is that i cant get the default taskpanel active on my primary monitor, its only appear on the last monitor of 3.

Peppermint 10


Hardware spec
Machine: Type: Desktop Mobo: ASUSTeK model: SABERTOOTH P67 v: Rev 1.xx serial: <filter> UEFI: American Megatrends
v: 3602 date: 11/01/2012
Battery: Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M560 charge: 0% status: Discharging
CPU: Topology: Quad Core model: Intel Core i5-3470S bits: 64 type: MCP arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23275
Speed: 2481 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 2416 2: 2775 3: 2785 4: 2450
Graphics: Device-1: NVIDIA GK104 [GeForce GTX 680] vendor: eVga.com. driver: nvidia v: 430.40 bus ID: 01:00.0
Display: x11 server: X.Org 1.19.6 driver: nvidia resolution: 1920x1200~60Hz, 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 680/PCIe/SSE2 v: 4.6.0 NVIDIA 430.40 direct render: Yes
Audio: Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 00:1b.0


After change the monitors on the Gcard and switch primary to DVI-0 and 3rd monitor to DVI-1  and reconfigure Nvidiai Settings i solve the TaskPanel probelm. Resolution problem on locked screen just moved over to the 3rd monitor now connected to DVI-1. That strange that it show the locked OS window in my 3rd monitor instead of the primary
« Last Edit: August 05, 2019, 04:59:57 am by censor »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Resolution and panel problem after new install
« Reply #2 on: August 05, 2019, 02:36:12 pm »
So what exactly is the problem here ?

Is it just about the resolution at the login screen ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline censor

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Resolution and panel problem after new install
« Reply #3 on: August 05, 2019, 02:49:21 pm »
Hi. Problem is the resolution i get when pepp goes in locked mode, its sets in 800x600 instead of stay in 1920x1200

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Resolution and panel problem after new install
« Reply #4 on: August 05, 2019, 03:13:48 pm »
What's the output from:
Code: [Select]
dpkg -l | grep nvidia
?



Just putting these links here for my own future reference:
https://bugs.launchpad.net/ubuntu/+source/light-locker/+bug/1760068
and
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1757202
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline censor

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Resolution and panel problem after new install
« Reply #5 on: August 05, 2019, 03:21:05 pm »
ii  libnvidia-cfg1-390:amd64                390.116-0ubuntu0.18.04.1                         amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-390                    390.116-0ubuntu0.18.04.1                         all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-390:amd64             390.116-0ubuntu0.18.04.1                         amd64        NVIDIA libcompute package
ii  libnvidia-compute-390:i386              390.116-0ubuntu0.18.04.1                         i386         NVIDIA libcompute package
ii  libnvidia-decode-390:amd64              390.116-0ubuntu0.18.04.1                         amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-390:i386               390.116-0ubuntu0.18.04.1                         i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-390:amd64              390.116-0ubuntu0.18.04.1                         amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-390:i386               390.116-0ubuntu0.18.04.1                         i386         NVENC Video Encoding runtime library
ii  libnvidia-fbc1-390:amd64                390.116-0ubuntu0.18.04.1                         amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-390:i386                 390.116-0ubuntu0.18.04.1                         i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-390:amd64                  390.116-0ubuntu0.18.04.1                         amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-390:i386                   390.116-0ubuntu0.18.04.1                         i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-390:amd64                390.116-0ubuntu0.18.04.1                         amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-390:i386                 390.116-0ubuntu0.18.04.1                         i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  nvidia-compute-utils-390                390.116-0ubuntu0.18.04.1                         amd64        NVIDIA compute utilities
ii  nvidia-dkms-390                         390.116-0ubuntu0.18.04.1                         amd64        NVIDIA DKMS package
ii  nvidia-driver-390                       390.116-0ubuntu0.18.04.1                         amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-390                390.116-0ubuntu0.18.04.1                         amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-390                390.116-0ubuntu0.18.04.1                         amd64        NVIDIA kernel source package
ii  nvidia-prime                            0.8.8.2                                          all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                         390.77-0ubuntu0.18.04.1                          amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-390                        390.116-0ubuntu0.18.04.1                         amd64        NVIDIA driver support binaries
ii  xserver-xorg-video-nvidia-390           390.116-0ubuntu0.18.04.1                         amd64        NVIDIA

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Resolution and panel problem after new install
« Reply #6 on: August 05, 2019, 03:28:02 pm »
Does
Code: [Select]
xed /etc/X11/xorg.conf
open a file, and if so what are its contents ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline censor

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Resolution and panel problem after new install
« Reply #7 on: August 05, 2019, 03:31:16 pm »
Code: [Select]
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 390.77  (buildd@lcy01-amd64-022)  Thu Sep  6 07:51:39 UTC 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SMS24A450/460"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 680"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-3"
    Option         "metamodes" "DVI-I-1: nvidia-auto-select +0+31 {rotation=left}, DP-1: nvidia-auto-select +1080+0 {rotation=left}, DVI-D-0: nvidia-auto-select +2160+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
« Last Edit: August 05, 2019, 03:39:20 pm by PCNetSpec »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Resolution and panel problem after new install
« Reply #8 on: August 05, 2019, 03:38:50 pm »
Run:
Code: [Select]
gksudo xed /etc/X11/xorg.conf
and make it read:-
Code: [Select]
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 390.77  (buildd@lcy01-amd64-022)  Thu Sep  6 07:51:39 UTC 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    ModulePath     "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
    ModulePath     "/usr/lib/xorg/modules"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SMS24A450/460"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 680"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-3"
    Option         "metamodes" "DVI-I-1: nvidia-auto-select +0+31 {rotation=left}, DP-1: nvidia-auto-select +1080+0 {rotation=left}, DVI-D-0: nvidia-auto-select +2160+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
SAVE the file, and reboot to test.
« Last Edit: August 05, 2019, 09:48:46 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline censor

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Resolution and panel problem after new install
« Reply #9 on: August 05, 2019, 03:47:20 pm »
1 run gksudo xed /etc/X11/xorg.conf
2 copy your output into this new xorg.conf file and save > restart ?
« Last Edit: August 05, 2019, 09:49:22 pm by PCNetSpec »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Resolution and panel problem after new install
« Reply #10 on: August 05, 2019, 04:10:40 pm »
Basically you're just opening your existing xorg.conf and changing
Code: [Select]
Section "Files"
EndSection
to
Code: [Select]
Section "Files"
    ModulePath     "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
    ModulePath     "/usr/lib/xorg/modules"
EndSection
and saving .. then rebooting
« Last Edit: August 05, 2019, 04:34:34 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline censor

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Resolution and panel problem after new install
« Reply #11 on: August 05, 2019, 07:15:22 pm »
Yep, it solve the problem with the resolution in locked mode :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Resolution and panel problem after new install
« Reply #12 on: August 05, 2019, 09:51:57 pm »
Great news .. sorry about the typo in the command earlier (now fixed above).

If you're happy with the solution can you please remember to mark the topic (SOLVED), you can do this by editing the FIRST posting in this topic and changing:-

Subject: Resolution and panel problem after new install (SOLVED)

Thanks in advance :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3106
  • Karma: 564
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Resolution and panel problem after new install (SOLVED)
« Reply #13 on: August 07, 2019, 09:44:54 am »
Hi

For your panel problem - automatic or primary does not always work.



You will need to click on the down arrow next to Output and select the actual monitor you wish it to appear on.

Not ideal but the results work

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadrippe 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 1 x 43" 1 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P10 x64 Laptop - i7-7700HQ - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline censor

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Resolution and panel problem after new install (SOLVED)
« Reply #14 on: August 07, 2019, 10:08:24 am »
Thanks zeb, that was a quick and simple solution :)