Choose style:

Author Topic: MacBook late 2007  (Read 180 times)

0 Members and 1 Guest are viewing this topic.

Offline bob_lauciano

  • nOOb
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
MacBook late 2007
« on: July 02, 2019, 02:38:49 pm »
Greetings:

Problems and solutions:
Wifi would not connect. Uninstalled the default broadcom driver, wl.  Check blacklist for b43 driver. b43 driver was already installed and the wifi stated working.
Slow boot time, 5 mins.  Edited grub config file: replaced "quiet splash" with "nomodeset"  resulted in boot time 43sec

Other issues not yet solved
black screen after waking up from suspend
does not returned to the saved state after installing and running hibernate.
Solution:
Instead of suspend: lock screen
Instead of hibernate  live without it



bob@bob-MacBook ~ $ inxi -Fxz
System:    Host: bob-MacBook Kernel: 4.18.0-25-generic x86_64 bits: 64 gcc: 7.4.0
           Desktop: N/A Distro: Peppermint Ten
Machine:   Device: unknown System: Apple product: MacBook3 1 v: 1.0 serial: N/A
           Mobo: Apple model: Mac-F22788C8 v: PVT serial: N/A
           UEFI: Apple v: MB31.88Z.008E.B02.0803051832 date: 03/05/08
CPU:       Dual core Intel Core2 Duo T7500 (-MCP-)
           arch: Conroe rev.11 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 8777
           clock speeds: max: 2200 MHz 1: 1196 MHz 2: 1196 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.20.1 )
           drivers: fbdev (unloaded: modesetting,vesa)
           Resolution: 1280x800@76.00hz
           OpenGL: renderer: llvmpipe (LLVM 7.0, 128 bits)
           version: 3.3 Mesa 18.2.8 Direct Render: Yes
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.18.0-25-generic
Network:   Card-1: Broadcom and subsidiaries BCM4321 802.11a/b/g/n
           driver: b43-pci-bridge bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Marvell 88E8058 PCI-E Gigabit Ethernet Controller
           driver: sky2 v: 1.30 port: 2000 bus-ID: 03:00.0
           IF: ens5 state: down mac: <filter>
Drives:    HDD Total Size: 240.1GB (29.1% used)
           ID-1: /dev/sda model: CT240BX500SSD1 size: 240.1GB
Partition: ID-1: / size: 219G used: 66G (32%) fs: ext4 dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 61.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 200 Uptime: 3:24 Memory: 1812.5/3925.7MB
           Init: systemd runlevel: 5 Gcc sys: 7.4.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56
bob@bob-MacBook ~ $

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25730
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: MacBook late 2007
« Reply #1 on: July 02, 2019, 03:10:12 pm »
Welcome to the forum bob_lauciano :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5329
  • Karma: 945
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: MacBook late 2007
« Reply #2 on: July 02, 2019, 07:52:20 pm »
Welcome aboard, Bob  :)