Choose style:

Author Topic: Stop Kaffeine Updates (SOLVED)  (Read 202 times)

0 Members and 1 Guest are viewing this topic.

Offline Ralph

  • Member
  • ***
  • Posts: 130
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Stop Kaffeine Updates (SOLVED)
« on: July 01, 2019, 07:12:40 am »
Kaffeine in the repositories is version 2.0.14
That version does not work completely. One can't schedule a recording.
I have downloaded and installed 2.0.5 and that version works just fine. I have stopped the Update Manager from upgrading to 2.0.14 by adding kaffeine to the ignore group but if I try to update Peppermint through the terminal it will install the broken 2.0.14.
How can I stop Kaffeine from being upgraded through the terminal?
« Last Edit: July 01, 2019, 02:22:40 pm by Ralph »
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Stop Kaffeine Updates
« Reply #1 on: July 01, 2019, 07:28:32 am »
If the packagename is actually kaffeine

Run:
Code: [Select]
echo "kaffeine hold" | sudo dpkg --set-selections
to undo that package hold (eg. if you ever want to update it)
Code: [Select]
echo "kaffeine install" | sudo dpkg --set-selections
« Last Edit: July 01, 2019, 08:48:17 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 130
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Stop Kaffeine Updates
« Reply #2 on: July 01, 2019, 08:19:18 am »
So in my Download fold it says:  kaffeine_2.0.5-1_amd64.deb
Synaptic refers to it as just kaffeine
Update Manager ignores it with just using the word kaffeine.
So I copied and pasted your suggested command and got this error.
Spoiler (click here to view / hide)
~ $ echo "kaffeine hold" | sudo dpkg --set-selected
[sudo] password for buz:
dpkg: error: unknown option --set-selected

Type dpkg --help for help about installing and deinstalling packages
  • ;

Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked
  • produce a lot of output - pipe it through 'less' or 'more' !
[close]

 ???
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Stop Kaffeine Updates
« Reply #3 on: July 01, 2019, 08:51:28 am »
My apologies, typo .. should have been --set-selections not --set-selected

I've fixed the commands in my previous post .. please try it again with
Code: [Select]
echo "kaffeine hold" | sudo dpkg --set-selections
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 130
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Stop Kaffeine Updates
« Reply #4 on: July 01, 2019, 02:22:00 pm »
 ;D :P Once again thank you. That did the trick.
A little knowledge is dangerous, I'm proof of it.