Choose style:

Author Topic: Change scrollbar click behavior *Solved*  (Read 205 times)

0 Members and 1 Guest are viewing this topic.

Offline ellinger

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Change scrollbar click behavior *Solved*
« on: June 19, 2019, 06:19:47 am »
Hello all,

New Peppermint user here--trying to make it my every-day distro.
I've long had a gripe with the way scrollbars work in the Linux desktops I've used. I would like to set the scrollbars to move only one page up or down when I click anywhere above/below the slider.
The most common solution I've found is to create a settings.ini file in ~/.config/gtk-3.0 containing:

[Settings]
gtk-primary-button-warps-slider = false

The solution doesn't work in my case. I've tried both the above directory and the current theme's global directory.
Any advice is greatly appreciated.

Thanks
« Last Edit: June 19, 2019, 11:17:13 am by ellinger »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25692
  • Karma: 2820
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Change scrollbar click behavior
« Reply #1 on: June 19, 2019, 08:50:54 am »
Hi ellinger, and welcome to the forum :)

Adding:-
Code: [Select]
gtk-primary-button-warps-slider=false
(note no spaces around the "=" .. dunno if this is important .. EDIT:- it's not important)

to the bottom of:
Code: [Select]
xed ~/.config/gtk-3.0/settings.ini
so it  now read:-
Code: [Select]
[Settings]
gtk-theme-name=Peppermint-10-Red-Dark
gtk-icon-theme-name=Pepirus-Dark
gtk-font-name=Ubuntu 11
gtk-cursor-theme-name=DMZ-White
gtk-cursor-theme-size=18
gtk-toolbar-style=GTK_TOOLBAR_BOTH_HORIZ
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintfull
gtk-xft-rgba=rgb
gtk-primary-button-warps-slider=false
works for me (had to restart Firefox before it applied though).

Are you using a non-default  gtk theme that may be overriding the setting ?
« Last Edit: June 19, 2019, 09:00:24 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ellinger

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Change scrollbar click behavior *Solved*
« Reply #2 on: June 19, 2019, 11:23:47 am »
I had originally created settings.ini from scratch and used
Code: [Select]
[settings] 
for the section heading (note: lower case 's'). When I reopened the file, gtk(?) had added a
Code: [Select]
[Settings]
section with a mess of settings similar to your example. I moved
Code: [Select]
gtk-primary-button-warps-slider=false
to the bottom of the new section and all is well.

Many thanks PCNetSpec!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25692
  • Karma: 2820
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Change scrollbar click behavior *Solved*
« Reply #3 on: June 19, 2019, 02:14:08 pm »
You're most welcome, and "thanks" right back at you for marking the topic solved :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec