Choose style:

Author Topic: DVD auto play  (Read 360 times)

0 Members and 1 Guest are viewing this topic.

Offline arky217

  • Member
  • ***
  • Posts: 170
  • Karma: 10
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
DVD auto play
« on: June 11, 2019, 10:08:17 am »
I'm trying to get a video or audio DVD to automatically start playing
when I insert it.

I've looked in Nemo under behavior and the
'Prompt or autorun/autostart programs when media is inserted'
is checked, but the DVD will not autostart.

Any suggestions ?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25933
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: DVD auto play
« Reply #1 on: June 11, 2019, 10:11:03 am »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline arky217

  • Member
  • ***
  • Posts: 170
  • Karma: 10
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: DVD auto play
« Reply #2 on: June 11, 2019, 08:35:51 pm »
You might want to read this:-
https://forum.peppermintos.com/index.php/topic,7102.msg72678.html#msg72678

I installed the file at that link, logged off and back on and
now the cd/dvd mounts automatically but when VLC opens to play
it errors out, saying it can't find the music file.

However, with VLC still open, I can go to that music file and it plays ok.

I think it may have something to do with the 'Removable Drives and Media' menu
under the multimedia tab, the command for both audio cds and video cds/dvds
is vlc /dev/sr0

Somehow, that dev/sr0 must not be the right target for the dvd player.

Any suggestions ?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25933
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: DVD auto play
« Reply #3 on: June 11, 2019, 09:12:39 pm »
Try
Code: [Select]
vlc /dev/cdrom
or maybe just
Code: [Select]
vlc
If those don't work let me know and I'll see what I can come up with tomorrow.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline arky217

  • Member
  • ***
  • Posts: 170
  • Karma: 10
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: DVD auto play
« Reply #4 on: June 11, 2019, 09:31:47 pm »
Try
Code: [Select]
vlc /dev/cdrom
or maybe just
Code: [Select]
vlc
If those don't work let me know and I'll see what I can come up with tomorrow.

With VLC as the target, VLC just opens.

With VLC /dev/cdrom, I get basically the same error as before except instead
of saying 'VLC is unable to open the MRL 'file:///dev/sr0', it says
'VLC is unable to open the MRL 'file:///dev/cdrom'

When I open Nemo and hover over the Audio Disc,
it says              cdda://sr0/ (/dev/sr0)

When I type in the Terminal  vlc /dev/sr0
I get the same error; it also says 'no such file or directory'.

HOWEVER, when I insert a DVD instead of a CD, it works; it
automatically starts playing.

( I tried several CDs (all give that same error), but I only have that one DVD, so I don't
know if other DVDs will play also )
« Last Edit: June 11, 2019, 09:56:47 pm by arky217 »

Offline arky217

  • Member
  • ***
  • Posts: 170
  • Karma: 10
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: DVD auto play
« Reply #5 on: June 11, 2019, 11:39:01 pm »
Ok, I'm getting closer to the problem (maybe).
The problem seems to be that DVDs are automatically mounted,
whereas CD's are not.

In dconf Editor, I set the desktop to show mounted volumes, and
in the auto start menu, I unchecked to auto play audio and video files
and unchecked browse inserted media, so that the only thing left
checked was auto mount inserted media.

I just wanted to see what would be auto mounted and what would not.
Well, I tried several DVDs and they all auto mounted.

Then I tried several CDs and none auto mounted.

But when I have a CD inserted and click on it in Nemo
it mounts and then I start VLC and it plays.

(However, when I try to open an audio CD with the Media Player that
comes with Peppermint, (XPlayer) it won't play)

So, just to eliminate this particular DVD player,
I setup another desktop identically and I get the same results.

That leaves 2 questions:
1) Why do the DVDs auto mount and not the CDs ?
2) Why will VLC play the audio CDs but XPlayer won't ?

Update:
     When I insert any audio CD that has .wav files on it,
it will not automount.

When I click on it in Nemo, it mounts and
all the tracks are displayed. (Track 1.wav, Track 2.wav, etc.)

If I right click on a track and open with vlc, it plays ok.
If I right click and open with Media Player (Xplayer),
I get the error, 'The specified movie could not be found'.

Also, on each track icon there is a lock symbol in the lower right corner.
If I copy a track to the hard drive, the icon on the copied track no longer
has the lock symbol, and the copied track then plays ok with media player.

Evidently, that lock symbol is what is stopping the CD from automounting
and stopping Xplayer from playing it.

Why vlc will play it from the CD but not Xplayer, I don't know,
but even though vlc will play it from the CD after clicking on a track,
vlc won't automount or autoplay it like it does with a DVD.

Do the tracks on some audio CDs have a lock symbol and some don't ?

As I said, I've tried this on anothe desktop with identical setup with same results.
I also tried it using the MX Linux OS and it also gave the same results.

(Just for the heck of it, I also tried all these audio CDs I've been using on a computer
with Windows 7 and there was no problem)
« Last Edit: June 12, 2019, 04:03:44 pm by arky217 »