Author Topic: A Pepp 10 graphics Issue **Solved**  (Read 2727 times)

Offline stevesveryown

  • Trusted User
  • Member
  • *****
  • Posts: 423
  • Karma: 173
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 10
A Pepp 10 graphics Issue **Solved**
« on: June 09, 2019, 07:17:03 pm »
Hi Peppermint Team,

I recently upgraded to Peppermint 10 from Peppermint 8.  I have run into a couple of odd issues I never had on Pepp 8.  The main one may be an nvidia driver issue.  The other day, while my wife was on Pepp 10, the screen went to 640x480 when she logged into her profile.  I have never seen that happen before.  I had to reboot twice before I saw my desktop at 1920x1080. The log in screen also had the wrong resolution.  I have not seen the issue since but now when booting into Pepp 10 the Peppermint logo can't be seen and all you see is the gray background.  You can tell to boot is at 640x480 as some of the boot dialog is rather large. 

Note: I was in the process of editing this post when my issues happened again.  I have now reinstalled the nouveau drivers and purged the nvidia drivers.  This has me scratching my head as this had never happened on Pepp 8.  So much for being Poppa Peppermint.

Spoiler (click here to view / hide)
[close]
« Last Edit: June 15, 2019, 04:35:01 pm by stevesveryown »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue
« Reply #1 on: June 10, 2019, 03:47:58 am »
The above output suggests you're on the modesetting driver not nouveau :-\

Have you tried adding the graphics PPA and installing the 415 / 418 / 430 drivers ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline stevesveryown

  • Trusted User
  • Member
  • *****
  • Posts: 423
  • Karma: 173
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue
« Reply #2 on: June 10, 2019, 03:53:59 am »
The above output suggests you're on the modesetting driver not nouveau :-\

Have you tried adding the graphics PPA and installing the 415 / 418 / 430 drivers ?

No I haven't.  I was just happy to get back to normal.  I will give it a try when I get home from work.

Offline stevesveryown

  • Trusted User
  • Member
  • *****
  • Posts: 423
  • Karma: 173
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue
« Reply #3 on: June 13, 2019, 05:41:41 pm »
Well, installed the ppa and installed the 418 driver.  So far so good.

Spoiler (click here to view / hide)
[close]

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue
« Reply #4 on: June 15, 2019, 02:06:06 am »
Great news Steve :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 624
  • Karma: 149
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: A Pepp 10 graphics Issue
« Reply #5 on: June 15, 2019, 07:23:02 am »
Well, installed the ppa and installed the 418 driver.  So far so good.

Okay to get the splash screen on boot to display properly we have to edit grub file
Code: [Select]
sudo xed /etc/default/grub
In there you will find the line
Code: [Select]
GRUB_GFXMODE=640x480 delete the hash at the beginning and put in 1920x1080
Next add directly underneath
Code: [Select]
GRUB_GFXPAYLOAD_LINUX=keep So it looks like this
                                         
Save the file and keep your Terminal open and type or copy and paste
Code: [Select]
sudo update-initramfs -u
Then finally
Code: [Select]
sudo update-grub2
The initramfs -u builds the background image, then updating the grub puts it all together. This should then display your splash screen properly. ;D That's neater and better with the code like that, thank you future Clatterfordslim.
You're very welcome past Clatterfordslim.
« Last Edit: December 27, 2019, 04:17:06 pm by clatterfordslim »
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 624
  • Karma: 149
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: A Pepp 10 graphics Issue
« Reply #6 on: June 15, 2019, 07:42:42 am »
Also Steve setup your Nvidia Settings resolution and set Force Full Composition Pipeline, save the file. Do not restart computer at this point.
Instead open a Terminal and type
Code: [Select]
sudo xed /etc/X11/xorg.conf
In there you will find a line called Section "Monitor"
Under
Code: [Select]
Option "DPMS" add
             
Code: [Select]
Option         "DPI" "96   x   96"
Then directly underneath
Code: [Select]
Section "Monitor" is Section "Device"Under Boardname, which has the name of your graphic card add this to it, remember to keep the lines you're adding inline with the rest of the text.
add this
Code: [Select]
Option         "TripleBuffer" "1"Save the file
You can now restart your computer and no more screen tearing, plus the login screen will be the same resolution as your desktop.  ;D The Triplebuffer gets rid of any screen blanking, or it's meant to? Although DPI fonts is already set at 96 in the little utility Mark added, for me it did not work after installing Nvidia Drivers, so hence why DPI 96X96 is added to the xorg.conf file. I wish Nvidia would just add it automatically. By the way you probably know all this already and I did not want to appear rude and assume so, just sharing my knowledge that's all. I do the above on every Linux system I have, with Nvidia cards.  :)

This looks so much better than before, saves squinting or straining your eyes too much.  :D
« Last Edit: December 27, 2019, 04:25:31 pm by clatterfordslim »
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline stevesveryown

  • Trusted User
  • Member
  • *****
  • Posts: 423
  • Karma: 173
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue
« Reply #7 on: June 15, 2019, 08:55:42 am »
Great news Steve :)
No, not really, same issue occurred yesterday.....

Sent from my SM-G950U using Tapatalk


Offline stevesveryown

  • Trusted User
  • Member
  • *****
  • Posts: 423
  • Karma: 173
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue
« Reply #8 on: June 15, 2019, 08:57:38 am »
Also Steve setup your Nvidia Settings resolution and set Force Full Composition Pipeline, save the file. Do not restart computer at this point.
Instead open a Terminal and type sudo xed /etc/X11/xorg.conf
In there you will find a line called Section "Monitor"
Under Option "DPMS" add
             Option         "DPI" "96   x   96"

Then directly underneath Section "Monitor" is Section "Device"
Under Boardname, which has the name of your graphic card add this to it, remember to keep the lines you're adding inline with the rest of the text.
add this
Option         "TripleBuffer" "1"
Save the file
You can now restart your computer and no more screen tearing, plus the login screen will be the same resolution as your desktop.  ;D The Triplebuffer gets rid of any screen blanking, or it's meant to? Although DPI fonts is already set at 96 in the little utility Mark added, for me it did not work after installing Nvidia Drivers, so hence why DPI 96X96 is added to the xorg.conf file. I wish Nvidia would just add it automatically. By the way you probably know all this already and I did not want to appear rude and assume so, just sharing my knowledge that's all. I do the above on every Linux system I have, with Nvidia cards.
Actually I just learned this from your video. Thanks!

Sent from my SM-G950U using Tapatalk


Offline stevesveryown

  • Trusted User
  • Member
  • *****
  • Posts: 423
  • Karma: 173
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue
« Reply #9 on: June 15, 2019, 01:20:48 pm »
Well, installed the ppa and installed the 418 driver.  So far so good.

Okay to get the splash screen on boot to display properly we have to edit grub file
sudo xed /etc/default/grub

In there you will find the line GRUB_GFXMODE=640x480 delete the hash at the beginning and put in 1920x1080
Next add directly underneath GRUB_GFXPAYLOAD_LINUX=keep
Save the file and keep your Terminal open and type or copy and paste sudo update-initramfs -u
Then finally sudo update-grub
The initramfs -u builds the background image, then updating the grub puts it all together. This should then display your splash screen properly.  ;D

Slim,
When you say delete the hash you do mean the #?  And do I replace the 640x480 with 1920x1080?  Because the splash screen still is huge.

Thanks!
« Last Edit: June 15, 2019, 01:23:42 pm by stevesveryown »

Offline stevesveryown

  • Trusted User
  • Member
  • *****
  • Posts: 423
  • Karma: 173
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue
« Reply #10 on: June 15, 2019, 02:45:44 pm »
Never mind, Slim, I just watched your video again and got my answer.

Sent from my SM-G950U using Tapatalk


Offline stevesveryown

  • Trusted User
  • Member
  • *****
  • Posts: 423
  • Karma: 173
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue
« Reply #11 on: June 15, 2019, 04:33:17 pm »
Ok, redid the settings and now boot screen is proper.  Installed the 430 driver, too.  Thanks Slim.

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 624
  • Karma: 149
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: A Pepp 10 graphics Issue
« Reply #12 on: June 15, 2019, 09:40:02 pm »
Slim,
When you say delete the hash you do mean the #?  And do I replace the 640x480 with 1920x1080?  Because the splash screen still is huge.
Thanks!


Even though you have this sorted, thought I'd answer anyway. :)) Yes to both of these questions, sorry for the late reply  ;D
« Last Edit: June 15, 2019, 09:44:07 pm by clatterfordslim »
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 624
  • Karma: 149
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: A Pepp 10 graphics Issue
« Reply #13 on: June 15, 2019, 09:50:06 pm »
Ok, redid the settings and now boot screen is proper.  Installed the 430 driver, too.  Thanks Slim.




You're very welcome Steve. I have the 1050ti card and now it's paired up with a Ryzen 5 2600 Processor and 16GB of ram, Pep 10 just flies along.  ;D
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline stevesveryown

  • Trusted User
  • Member
  • *****
  • Posts: 423
  • Karma: 173
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 10
Re: A Pepp 10 graphics Issue **Solved**
« Reply #14 on: June 16, 2019, 08:38:21 am »
So now, time to test out making videos and I may have to try out Steam.  :D