Choose style:

Author Topic: Gnome-maps is not working.  (Read 444 times)

0 Members and 1 Guest are viewing this topic.

Offline justsrad

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Gnome-maps is not working.
« on: May 28, 2019, 01:37:47 am »
Hi all,

It closes itself immediately when i do a search  in the search bar.

I have tried to do apt-get update / apt-get upgrade

And also reinstall the gnome-maps , but the issue remains.

Not sure, whether anyone in here got solution to this.

Thanks.


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25270
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Gnome-maps is not working.
« Reply #1 on: May 28, 2019, 07:38:03 am »
Working for me (in Peppermint 9 64bit .. not tested in 10 yet, but will later), are you signing into openstreetmaps ? .. or does it crash even when you search whilst NOT signed in ?

What's the output from:
Code: [Select]
inxi -Fz
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2995
  • Karma: 560
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Gnome-maps is not working.
« Reply #2 on: May 28, 2019, 09:32:22 am »
It closes here too in Peppermint 10 when you hit return on a search

Regards Zeb...

this is what it shows in the terminal

Code: [Select]
zebedee@i7-peppermint ~ $ gnome-maps

(org.gnome.Maps:5403): dbind-WARNING **: 14:34:09.531: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(org.gnome.Maps:5403): GLib-GObject-CRITICAL **: 14:34:18.887: g_value_set_boolean: assertion 'G_VALUE_HOLDS_BOOLEAN (value)' failed

** (org.gnome.Maps:5403): WARNING **: 14:34:18.887: XEP attribute 'viewbox' unhandled

** (org.gnome.Maps:5403): WARNING **: 14:34:18.887: XEP attribute 'bounded' unhandled
Segmentation fault
zebedee@i7-peppermint ~ $
« Last Edit: May 28, 2019, 09:34:58 am by zebedeeboss »
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P9/10 @ P9 x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25270
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Gnome-maps is not working.
« Reply #3 on: May 28, 2019, 12:37:26 pm »
That's not the command to start it zeb .. it crashes for me too if started that way.

Here's the correct command
Code: [Select]
gapplication launch org.gnome.Maps
« Last Edit: May 28, 2019, 12:44:50 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2995
  • Karma: 560
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Gnome-maps is not working.
« Reply #4 on: May 28, 2019, 12:43:44 pm »
it still crashes - using either command

only your way there is no other output

EDIT inxi info

Spoiler (click here to view / hide)
zebedee@i7-peppermint ~ $ inxi -Fz
System:    Host: i7-peppermint Kernel: 4.18.0-20-generic x86_64 bits: 64 Desktop: N/A
           Distro: Peppermint Ten
Machine:   Device: desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x serial: N/A
           UEFI: American Megatrends v: 3805 date: 05/16/2018
Battery    hidpp__0: charge: 100% condition: NA/NA Wh
           hidpp__1: charge: N/A condition: NA/NA Wh
CPU:       Quad core Intel Core i7-6700K (-MT-MCP-) cache: 8192 KB
           clock speeds: max: 4300 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz 5: 800 MHz 6: 800 MHz
           7: 800 MHz 8: 800 MHz
Graphics:  Card: NVIDIA GP104 [GeForce GTX 1070 Ti]
           Display Server: x11 (X.Org 1.20.1 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 3840x2160@60.00hz, 3840x2160@60.00hz, 3440x1440@59.94hz
           OpenGL: renderer: GeForce GTX 1070 Ti/PCIe/SSE2 version: 4.6.0 NVIDIA 430.14
Audio:     Card-1 Intel 100 Series/C230 Series Family HD Audio Controller driver: snd_hda_intel
           Card-2 NVIDIA GP104 High Def. Audio Controller driver: snd_hda_intel
           Card-3 Logitech driver: USB Audio
           Card-4 C-Media driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.18.0-20-generic
Network:   Card: Intel Ethernet Connection (2) I219-V driver: e1000e
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 11708.4GB (59.4% used)
           ID-1: /dev/nvme0n1 model: SAMSUNG_MZVLV256HCHP size: 256.1GB
           ID-2: /dev/sda model: MKNSSDRE1TB size: 1000.2GB
           ID-3: /dev/sdb model: Samsung_SSD_860 size: 1000.2GB
           ID-4: /dev/sdc model: SanDisk_SSD_PLUS size: 120.0GB
           ID-5: /dev/sdd model: Samsung_SSD_850 size: 250.1GB
           ID-6: /dev/sde model: SanDisk_Ultra_II size: 960.2GB
           ID-7: /dev/sdf model: SanDisk_SSD_PLUS size: 120.0GB
           ID-8: USB /dev/sdg model: Backup+_Hub_BK size: 8001.6GB
Partition: ID-1: / size: 196G used: 84G (45%) fs: ext4 dev: /dev/nvme0n1p2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 41C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 263 Uptime: 3:25 Memory: 2936.9/32105.2MB Client: Shell (bash) inxi: 2.3.56
zebedee@i7-peppermint ~ $
[close]
« Last Edit: May 28, 2019, 12:53:25 pm by zebedeeboss »
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P9/10 @ P9 x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25270
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Gnome-maps is not working.
« Reply #5 on: May 28, 2019, 12:46:17 pm »
Weird .. as I said working for me (oddly now with BOTH commands) :-\

Might help if you gave your
Code: [Select]
inxi -Fz
so we can compare it with the OP's when he posts his.

[EDIT]

Can you also install
Code: [Select]
sudo apt-get install dconf-cli
then post the output from
Code: [Select]
dconf dump /org/gnome/maps/
and
Code: [Select]
namei -mo ~/.config/dconf/user
« Last Edit: May 28, 2019, 01:08:28 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline justsrad

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Gnome-maps is not working.
« Reply #6 on: May 29, 2019, 09:06:51 pm »
Here you are...

Output of inxi -Fz

Spoiler (click here to view / hide)
System:    Host: dragonFly Kernel: 4.18.0-20-generic x86_64 bits: 64 Desktop: N/A
           Distro: Peppermint Ten
Machine:   Device: desktop Mobo: ASUSTeK model: TUF B360-PRO GAMING (WI-FI) v: Rev 1.xx serial: N/A
           UEFI: American Megatrends v: 0802 date: 06/14/2018
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
CPU:       Quad core Intel Core i3-8100 (-MCP-) cache: 6144 KB
           clock speeds: max: 3600 MHz 1: 977 MHz 2: 2834 MHz 3: 2231 MHz
           4: 2515 MHz
Graphics:  Card: Intel 8th Gen Core Processor Gaussian Mixture Model
           Display Server: x11 (X.Org 1.20.1 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2)
           version: 4.5 Mesa 18.2.8
Audio:     Card Intel Cannon Lake PCH cAVS driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.18.0-20-generic
Network:   Card-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi
           IF: wlo1 state: up mac: <filter>
           Card-2: Intel Ethernet Connection (7) I219-V driver: e1000e
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 240.1GB (4.7% used)
           ID-1: /dev/sda model: WDC_WDS240G2G0B size: 240.1GB
Partition: ID-1: / size: 49G used: 11G (24%) fs: ext4 dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 39.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 209 Uptime: 1 min Memory: 854.5/7815.0MB
           Client: Shell (bash) inxi: 2.3.56
[close]

Output of "dconf dump /org/gnome/maps"
Spoiler (click here to view / hide)
[/]
window-maximized=true
window-position=[369, 388]
window-size=[768, 594]
last-viewed-location=[35.454425647445852, 35.384129677894741, 139.46499824523926, 139.62979316711426]
transportation-type='pedestrian'
[close]


Output of "namei -mo  ~/.config/dconf/user"


Spoiler (click here to view / hide)
f: /home/jus/.config/dconf/user
 drwxr-xr-x root root /
 drwxr-xr-x root root home
 drwxr-xr-x jus  jus  jus
 drwxr-xr-x jus  jus  .config
 drwx------ jus  jus  dconf
 -rw-r--r-- jus  jus  user
[close]
« Last Edit: May 29, 2019, 09:12:39 pm by justsrad »

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2995
  • Karma: 560
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Gnome-maps is not working.
« Reply #7 on: May 30, 2019, 01:28:10 am »
and here is my two

dump one
Spoiler (click here to view / hide)
zebedee@i7-peppermint ~ $ dconf dump /org/gnome/maps/
[/]
window-maximized=false
window-position=[5524, 438]
window-size=[1844, 1320]
last-viewed-location=[85.051128779799996, 76.434603583495033, 98.96484375, 180.0]
transportation-type='pedestrian'
zebedee@i7-peppermint ~ $
[close]

name one
Spoiler (click here to view / hide)
zebedee@i7-peppermint ~ $ namei -mo  ~/.config/dconf/user
f: /home/zebedee/.config/dconf/user
 drwxr-xr-x root    root    /
 drwxr-xr-x root    root    home
 drwxr-xr-x zebedee zebedee zebedee
 drwxr-xr-x zebedee zebedee .config
 drwx------ zebedee zebedee dconf
 -rw-r--r-- zebedee zebedee user
zebedee@i7-peppermint ~ $
[close]

just for comparison

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P9/10 @ P9 x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5170
  • Karma: 939
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Gnome-maps is not working.
« Reply #8 on: May 30, 2019, 07:15:46 am »
Hrm...  :-\

Output (Zsh)
╭─vindsl@Boogaloo-6 ~
╰─$ dconf dump /org/gnome/maps/

╭─vindsl@Boogaloo-6 ~
╰─$ namei -mo ~/.config/dconf/user
f: /home/vindsl/.config/dconf/user
 drwxr-xr-x root   root   /
 drwxr-xr-x root   root   home
 drwxr-xr-x vindsl vindsl vindsl
 drwxr-xr-x vindsl vindsl .config
 drwx------ vindsl vindsl dconf
 -rw-r--r-- vindsl vindsl user
╭─vindsl@Boogaloo-6 ~
╰─$
[close]

Output (Bash)
vindsl@Boogaloo-6 ~ $ dconf dump /org/gnome/maps/
vindsl@Boogaloo-6 ~ $ namei -mo ~/.config/dconf/user
f: /home/vindsl/.config/dconf/user
 drwxr-xr-x root   root   /
 drwxr-xr-x root   root   home
 drwxr-xr-x vindsl vindsl vindsl
 drwxr-xr-x vindsl vindsl .config
 drwx------ vindsl vindsl dconf
 -rw-r--r-- vindsl vindsl user
vindsl@Boogaloo-6 ~ $
[close]

« Last Edit: May 30, 2019, 07:21:11 am by VinDSL, Reason: Addendum »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25270
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Gnome-maps is not working.
« Reply #9 on: May 30, 2019, 09:23:02 am »
So it's not working for any of you guys .. actually I'm asking VinDSL ?

If that's the case, maybe I have something installed that's fixing the issue, and we'll have to try figure out what that may be .. though it could equally be coincidental.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5170
  • Karma: 939
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Gnome-maps is not working.
« Reply #10 on: May 30, 2019, 07:07:56 pm »
So it's not working for any of you guys .. actually I'm asking VinDSL ?

Let me check a more 'pure' install.  ;)

BRB

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5170
  • Karma: 939
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Gnome-maps is not working.
« Reply #11 on: May 30, 2019, 07:15:01 pm »
Okay... N'yet on my 32bit P10 Asus netbook install, too...

Eee PC 1000HD
vindsl@Torb-10 ~ $ dconf dump /org/gnome/maps/
vindsl@Torb-10 ~ $ namei -mo ~/.config/dconf/user
f: /home/vindsl/.config/dconf/user
 drwxr-xr-x root   root   /
 drwxr-xr-x root   root   home
 drwxr-xr-x vindsl vindsl vindsl
 drwxr-xr-x vindsl vindsl .config
 drwx------ vindsl vindsl dconf
 -rw-r--r-- vindsl vindsl user
vindsl@Torb-10 ~ $
[close]





« Last Edit: May 30, 2019, 07:20:27 pm by VinDSL, Reason: Typo Demon Strikes Again »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25270
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Gnome-maps is not working.
« Reply #12 on: May 30, 2019, 07:29:28 pm »
Thanks Mr Dizzle, okay I'll set up a stock VM and if it's broken there,I'll try figure out what I installed that fixed it.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline spence

  • Trusted User
  • Veteran
  • *****
  • Posts: 1883
  • Karma: 187
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin
Re: Gnome-maps is not working.
« Reply #13 on: May 31, 2019, 02:03:45 am »
Not working here either...

Code: [Select]
spence@antec ~ $ dconf dump /org/gnome/maps/
[/]
window-maximized=true
last-viewed-location=[38.087350486629894, 38.070375356405769, -78.936188220977783, -78.894989490509033]
transportation-type='pedestrian'

Code: [Select]
spence@antec ~ $  namei -mo  ~/.config/dconf/user
f: /home/spence/.config/dconf/user
 drwxr-xr-x root   root   /
 drwxr-xr-x root   root   home
 drwxr-xr-x spence spence spence
 drwxr-xr-x spence spence .config
 drwx------ spence spence dconf
 -rw-r--r-- spence spence user

 :-\




spence
PeppermintOS 10installed  on:
'16 Antec Aria rebuild
 '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25270
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Gnome-maps is not working.
« Reply #14 on: May 31, 2019, 08:31:15 am »
The fact it's not working for anyone except me is oddly GOOD news .. it means it's much more likely that it's something I have installed (but they didn't list as a dependency in the package) that fixed it .. now I just need to figure out what.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec