Choose style:

Author Topic: Loose the internet every time computer goes into sleep mode. Not Fixed!  (Read 618 times)

0 Members and 1 Guest are viewing this topic.

Offline gclark94560

  • Member
  • ***
  • Posts: 138
  • Karma: 4
  • New Forum User
    • View Profile
    • GunBuilds.com
  • Peppermint version(s): 5
Hi Everyone!  I recently upgraded from Peppermint 5 to 9. 
Now, every time the computer goes to sleep there's no internet connection when I wake it.
I have to reboot or shut down to get it back.  Other devices work fine on WIFI so I know it's not the modem/cable.
I am up to date on system updates as of ten minutes ago.
Any suggestions?
« Last Edit: June 07, 2019, 11:39:33 am by gclark94560 »
Man plans, God laughs!

Offline gclark94560

  • Member
  • ***
  • Posts: 138
  • Karma: 4
  • New Forum User
    • View Profile
    • GunBuilds.com
  • Peppermint version(s): 5
Here is the system info -

Code: [Select]
System:    Host: greg-Inspiron-531 Kernel: 4.15.0-50-generic i686
           bits: 32 gcc: 7.3.0
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: desktop System: Dell product: Inspiron 531 v: 00 serial: N/A
           Mobo: Dell model: 0RY206 v: serial: N/A
           BIOS: Dell v: 1.0.10 date: 04/07/2008
CPU:       Single core AMD Sempron LE-1300 (-UP-) arch: K8 rev.F+ cache: 512 KB
           flags: (lm nx pae sse sse2 sse3) bmips: 4621 speed: 2300 MHz (max)
Graphics:  Card: NVIDIA C61 [GeForce 6150SE nForce 430] bus-ID: 00:0d.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nouveau (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: NV4C version: 2.1 Mesa 18.2.8 Direct Render: Yes
Audio:     Card NVIDIA MCP61 High Def. Audio driver: snd_hda_intel bus-ID: 00:05.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-50-generic
Network:   Card: NVIDIA MCP61 Ethernet driver: forcedeth port: ec00 bus-ID: 00:07.0
           IF: enp0s7 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 660.1GB (5.6% used)
           ID-1: /dev/sda model: ST3160815AS size: 160.0GB
           ID-2: USB /dev/sdb model: FreeAgent size: 500.1GB
Partition: ID-1: / size: 146G used: 35G (26%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 57.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
           deb http://us.archive.ubuntu.com/ubuntu/ bionic universe
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe
           deb http://us.archive.ubuntu.com/ubuntu/ bionic multiverse
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu bionic-security main restricted
           deb http://security.ubuntu.com/ubuntu bionic-security universe
           deb http://security.ubuntu.com/ubuntu bionic-security multiverse
           Active apt sources in file: /etc/apt/sources.list.d/peppermint.list
           deb http://ppa.launchpad.net/peppermintos/p9-release/ubuntu bionic main
           deb http://ppa.launchpad.net/peppermintos/p9-respin/ubuntu bionic main
Info:      Processes: 175 Uptime: 28 min Memory: 592.1/3974.6MB
           Init: systemd runlevel: 5 Gcc sys: 7.4.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56
Man plans, God laughs!

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 863
    • View Profile
  • Peppermint version(s): Peppermint 9
I've had this before, in past versions of Peppermint and other Linux distributions. I use a WIFI dongle, so I usually just unplug it and plug it back in and it comes back. Of course, if it's built in WIFI, that makes things more complicated.  Logging out and logging back in doesn't turn it back on? Sometimes, that works with resetting stuff, other times it doesn't.

Offline gclark94560

  • Member
  • ***
  • Posts: 138
  • Karma: 4
  • New Forum User
    • View Profile
    • GunBuilds.com
  • Peppermint version(s): 5
I have a separate modem/router connected by cable.  Even though the desktop Linux computer can't connect, all other devices in the house can.
Man plans, God laughs!

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1964
  • Karma: 341
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
What happens if you deselect Enable networking in the network manager right-click menu, then enable it again?

Offline gclark94560

  • Member
  • ***
  • Posts: 138
  • Karma: 4
  • New Forum User
    • View Profile
    • GunBuilds.com
  • Peppermint version(s): 5
Yesterday I installed all of the system updates and today it seems to be working.  Perhaps one of the gurus in the ether fixed it for me.  Will watch it today.
Man plans, God laughs!

Offline clatterfordslim

  • Member
  • ***
  • Posts: 249
  • Karma: 29
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Many a time on my computer over the years, especially on other Distros, I have racked my brains to nearly death, trying to solve as to why my computer will do as it's told one day, but going to do the same thing again the next day, it does not wanna know? Then you search the Internet for answers and nothing there as a way of an answer, then you do a reboot, or shutdown your computer for a while, boot it back up and voila it works, what you've been trying to do and nearly chucking your computer out of the window the day before, cause it wasn't having none of it. Strange when this happens. ;D
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline gclark94560

  • Member
  • ***
  • Posts: 138
  • Karma: 4
  • New Forum User
    • View Profile
    • GunBuilds.com
  • Peppermint version(s): 5
Yesterday I installed all of the system updates and today it seems to be working.  Perhaps one of the gurus in the ether fixed it for me.  Will watch it today.

I guess the Spirit of Linus Benedict Torvalds is watching over me.  The system seems to have healed itself.  Thank you to all the Code Warriors who monitor this stuff!
Man plans, God laughs!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25718
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
You've gotta love it when that happens :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gclark94560

  • Member
  • ***
  • Posts: 138
  • Karma: 4
  • New Forum User
    • View Profile
    • GunBuilds.com
  • Peppermint version(s): 5
Well, the patient is not healed but is better.

 Now I loose the internet only every few days and must reboot.  It's driving me nuts.  >:(

Any things I can try?
Man plans, God laughs!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25718
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Have you tried switching to the MATE power manager ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gclark94560

  • Member
  • ***
  • Posts: 138
  • Karma: 4
  • New Forum User
    • View Profile
    • GunBuilds.com
  • Peppermint version(s): 5
I tried to install and launch MATE Power Manager.  It did nothing.  It seems MATE is a family of apps/programs and they are not installed on my box.  I'm a bit afraid of installing the entire package as I have no concept of what it all does.
Man plans, God laughs!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25718
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
No DO NOT install the entire MATE desktop environment .. just the MATE power manager.

I take it you installed mate-power-manager, uninstalled xfce4-power-manager, set mate-power-manager to autostart, then rebooted before testing ?

Do you need instructions to do this ?
« Last Edit: June 09, 2019, 04:12:43 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gclark94560

  • Member
  • ***
  • Posts: 138
  • Karma: 4
  • New Forum User
    • View Profile
    • GunBuilds.com
  • Peppermint version(s): 5
No DO NOT install the entire MATE desktop environment .. just the MATE power manager.

I take it you installed mate-power-manager, uninstalled xfce4-power-manager, set mate-power-manager to autostart, then rebooted before testing ?

Do you need instructions to do this ?

Installed MATE Power Manager.  Uninstalled xfce4.  Clicked on Launch for MATE.  Nothing happened.  Re-booted, repeat on trying to launch MATE.  Nothing happened.  Can't figure out how to set MATE to Autostart.
« Last Edit: June 19, 2019, 08:24:01 am by gclark94560 »
Man plans, God laughs!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25718
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
If you've already done:
Code: [Select]
sudo apt-get install mate-power-manager
then
Code: [Select]
sudo apt-get remove xfce4-power-manager xfce4-power-manager-data xfce4-power-manager-plugins
Now go to:-

Menu > Settings > Default Applications for LXSession > Core applications (tab)

Change:-

Power Manager: xfce4-power-manager

to

Power Manager: mate-power-manager

exit the LXSession configuration app

Reboot. <-- IMPORTANT

The power manager in the system tray should now open the MATE Power Manager instead of the Xfce Power Manager.
« Last Edit: June 09, 2019, 05:03:28 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec