Choose style:

Author Topic: Troubles Installing/Running Electrum Wallet on Peppermint 8 (KINDA SOLVED)  (Read 380 times)

0 Members and 1 Guest are viewing this topic.

Offline completeidiot

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
When I try to follow what the doctor orders here: https://electrum.org/#download

...and I try to run Electrum without installing, it ends up giving me this:

Code: [Select]
python3 Electrum-3.3.6/run_electrum
  File "Electrum-3.3.6/run_electrum", line 64
    sys.exit(f"Error: {str(e)}. Try 'sudo python3 -m pip install <module-name>'")
                                                                               ^
SyntaxError: invalid syntax

When I do the pip install, it gives me this:

Code: [Select]
The directory '/home/al/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/al/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting Electrum-3.3.6
  Could not find a version that satisfies the requirement Electrum-3.3.6 (from versions: )
No matching distribution found for Electrum-3.3.6
You are using pip version 8.1.1, however version 19.1.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

When do as said, it gives me:

Code: [Select]
Traceback (most recent call last):
  File "/usr/bin/pip", line 9, in <module>
    from pip import main
ImportError: cannot import name main

All in all, I cannot get Electrum to work. Is there any way to overcome this and come out on top of it all?



« Last Edit: May 29, 2019, 07:57:44 am by completeidiot »

Offline completeidiot

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #1 on: May 27, 2019, 11:23:50 am »
Just to expound on this a little, I have tried running older versions of Electrum. They're all fine -- up until Electrum 3.3.0 -- that's where it gets buggy.

(I would be fine with older versions, it's just that blockchain sync takes ages.)

If nobody feels like digging into this, never mind. Although I used to like this wallet a lot, it's been getting on my nerves lately and I'm about to give up on it for good.

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1989
  • Karma: 341
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #2 on: May 27, 2019, 11:26:24 am »
I've run it before on Peppermint 7 but I can't remember which version. I see they have a version packaged as an appimage, have you tried that?

Offline completeidiot

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #3 on: May 27, 2019, 12:14:08 pm »
Yes yes. It doesn't do a thing. Is it possible that Electrum versions north of 3.3.0 stopped supporting Peppermint 8 (or whatever it's based on)?

Perhaps I should upgrade to 9 at least, but I like 8 much better. I would rather give up Electrum than this version.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26111
  • Karma: 2844
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #4 on: May 27, 2019, 12:39:05 pm »
Run these commands in sequence:
Code: [Select]
sudo chown al:al -R /home/al/.cache
then
Code: [Select]
sudo rm -rv /home/al/.cache/pip
then
Code: [Select]
sudo apt-get install --reinstall python-pip python3-pip python3-pyqt5
then
Code: [Select]
rm -v Electrum-3.3.6.tar.gz
then
Code: [Select]
wget https://download.electrum.org/3.3.6/Electrum-3.3.6.tar.gz
then
Code: [Select]
python3 -m pip install --user Electrum-3.3.6.tar.gz[fast]
and if that all goes well, you can run it with
Code: [Select]
/home/al/.local/bin/electrum
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline completeidiot

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #5 on: May 27, 2019, 12:58:47 pm »
Thank you.

Unfortunately, it once again gave me:

Code: [Select]
python3 -m pip install --user Electrum-3.3.6.tar.gz[fast]
Processing ./Electrum-3.3.6.tar.gz
    Complete output from command python setup.py egg_info:
    Error: Electrum requires Python version >= 3.6.1...
   
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-k045a3zc-build/
You are using pip version 8.1.1, however version 19.1.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26111
  • Karma: 2844
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #6 on: May 27, 2019, 01:46:52 pm »
Quote
Error: Electrum requires Python version >= 3.6.1

What's the output from:
Code: [Select]
python3 -V
« Last Edit: May 27, 2019, 01:48:28 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline completeidiot

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #7 on: May 27, 2019, 02:58:20 pm »
Python 3.5.2 

So I've installed Python 3.6.8 and re-run the commands again. This time, the installation got through, but it still gave me this:

Code: [Select]
Successfully installed Electrum aiohttp aiohttp-socks aiorpcx async-timeout attrs certifi chardet-2.3.0 dnspython ecdsa idna idna-ssl jsonrpclib-pelix multidict protobuf pyaes pycryptodomex qdarkstyle qrcode setuptools-20.7.0 six-1.10.0 typing-extensions yarl
You are using pip version 8.1.1, however version 19.1.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

When I attempted to run the wallet, this was the outcome:

Code: [Select]
/home/al/.local/bin/electrum
Traceback (most recent call last):
  File "/home/al/.local/bin/electrum", line 359, in <module>
    d.init_gui(config, plugins)
  File "/home/al/.local/lib/python3.6/site-packages/electrum/daemon.py", line 348, in init_gui
    gui = __import__('electrum.gui.' + gui_name, fromlist=['electrum'])
  File "/home/al/.local/lib/python3.6/site-packages/electrum/gui/qt/__init__.py", line 39, in <module>
    from PyQt5.QtGui import QGuiApplication
ModuleNotFoundError: No module named 'PyQt5.QtGui'

 





Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26111
  • Karma: 2844
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #8 on: May 27, 2019, 03:33:22 pm »
I wish you wouldn't get ahead of my questions .. I'll pretty much bet you'll have broken other things on your system by attempting to upgrade python.

Have you installed
Code: [Select]
sudo apt-get install python3-pyqt5
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline completeidiot

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #9 on: May 27, 2019, 04:05:40 pm »
Sorry.

I had attempted that, but it still left me with what I began with.

I followed these instructions:

http://ubuntuhandbook.org/index.php/2017/07/install-python-3-6-1-in-ubuntu-16-04-lts/

It seems I can still switch to Python 3.5 through

Code: [Select]
sudo update-alternatives --config python3

I swear I'll do nothing but what I'm told to do from now on  :'(
« Last Edit: May 27, 2019, 04:08:24 pm by completeidiot »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26111
  • Karma: 2844
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #10 on: May 27, 2019, 04:19:42 pm »
Aint gonna hurt to try that now.

Give it a shot.



Personally I've never managed to upgrade python without something breaking .. but as that appears to install both, you may just get lucky.
« Last Edit: May 27, 2019, 04:22:31 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline completeidiot

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #11 on: May 27, 2019, 04:43:15 pm »
Terminal did warn me I am not to remove Python 3.5 unless I wanna wreak havoc on myself, so I went eeny, meeny, miny, moe, pressed some keys and hey, still breathing.

What am I to do now tho?

EDIT: Oh, nothing! I'll try.  8)

Offline completeidiot

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #12 on: May 28, 2019, 05:16:41 pm »
I installed Peppermint 10 and the newest Electrum runs just fine.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26111
  • Karma: 2844
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Troubles Installing/Running Electrum Wallet on Peppermint 8
« Reply #13 on: May 28, 2019, 05:41:32 pm »
Great stuff :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec