Choose style:

Author Topic: Nvidia Powermizer [SOLVED]  (Read 216 times)

0 Members and 1 Guest are viewing this topic.

Offline neggard

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Nvidia Powermizer [SOLVED]
« on: May 26, 2019, 08:05:56 am »
I using Nvidia and have make some changes in the GUIconfig like remove Sync to VBlank and Allow Flipping. These settings are saved when I restart.
But Nvidias Powermizer is standard set to AUTO. I change it to Prefer Maximum Performance. This setting is not saved and set to AUTO after restart.
How could I get this to be  Prefer Maximum Performance even when I restart the copmputer?
« Last Edit: May 26, 2019, 02:32:16 pm by neggard »

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3046
  • Karma: 563
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Nvidia Powermizer
« Reply #1 on: May 26, 2019, 08:12:23 am »
Good question

I have looked and looked and looked but cannot find a working solution.

I hope someone else can help so I can use it too  :)

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P9/10 @ P9 x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25692
  • Karma: 2820
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Nvidia Powermizer
« Reply #2 on: May 26, 2019, 09:28:14 am »
As nvidia-settings seems to reset the configuration, maybe try creating an autostart script that runs:-
Code: [Select]
nvidia-settings -a '[gpu:0]/GPUPowerMizerMode=1'
which should automatically switch the PowerMizer setting to Prefer Maximum Performance at login.



Key:-

GPUPowerMizerMode=0     ==     Adaptive
GPUPowerMizerMode=1     ==     Prefer Maximum Performance
GPUPowerMizerMode=2     ==     Auto



Here's how I did it...

Create a (hidden) .powermizer-autoset.sh shell script by running:
Code: [Select]
xed $HOME/.powermizer-autoset.sh
when a blank file opens, make it read:-
Code: [Select]
#!/bin/bash

nvidia-settings -a '[gpu:0]/GPUPowerMizerMode=1'
SAVE the file and exit the text editor

Back in the terminal, make that script executable:
Code: [Select]
chmod +x $HOME/.powermizer-autoset.sh
Now fire up:-

Menu > Settings > Default applications for LXSession

Navigate to the "Autostart" tab.

In the text box Just to the right of the [+Add] button, enter:-
Code: [Select]
/home/<username>/.powermizer-autoset.sh
(replacing <username> with YOUR username)

Then click the [+Add] button.

Now log off/on a few times to test.
« Last Edit: May 26, 2019, 10:00:49 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline neggard

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Nvidia Powermizer [SOLVED]
« Reply #3 on: May 26, 2019, 02:33:20 pm »
You are the best PCNetSpec
Thanks for the help with this.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25692
  • Karma: 2820
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Nvidia Powermizer [SOLVED]
« Reply #4 on: May 26, 2019, 03:23:23 pm »
You're most welcome, glad I could help :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec