Choose style:

Author Topic: How do i enabled system sound effects??? SOLVED  (Read 10673 times)

0 Members and 1 Guest are viewing this topic.

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: How do i enabled system sound effects???
« Reply #30 on: August 16, 2014, 10:58:09 am »
that worked thanks everyone!!! i will go ahead and mark this as solved now thanks so much!
http://iamesper.bandcamp.com
boring drone music from NJ

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1812
  • Karma: 474
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: How do i enabled system sound effects???
« Reply #31 on: August 16, 2014, 11:00:35 am »
Sorry, I also had to make a correction in my reply #22 (which should now be in the correct form). Now to your question:


If you put your new file startupukejazzy.mp3 in the location that you gave me:
Code: [Select]
/home/iamesper/Music/startupukejazzy.mp3


then (as found in reply #22) in the step where you change this line:
Code: [Select]
Exec=/usr/bin/mplayer /usr/share/sounds/ubuntu/stereo/desktop-login.ogg

you change it to be this:

Code: [Select]
Exec=/usr/bin/mplayer /home/iamesper/Music/startupukejazzy.mp3
Note that there is only ONE space in that line (between mplayer and /home). Your best bet is to click on the word Select for the new line given above, then you can paste it into the file without worrying about making a typing error.

Save the file login-file.desktop and then log off/on and listen if it works.

Regards,
-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1812
  • Karma: 474
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: How do i enabled system sound effects??? SOLVED
« Reply #32 on: August 16, 2014, 11:02:53 am »
Hey, you answer so fast (and I type so slowly) that you have solved your problem before my detailed reply has been posted! :P


Glad to hear that it worked,
-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: How do i enabled system sound effects??? SOLVED
« Reply #33 on: August 16, 2014, 11:03:02 am »
thanks for the help it worked!!!! I'm going to try to find a better sound quality recording ill mess with it until i get the right sound but now i know how to do it thanks guys :D
http://iamesper.bandcamp.com
boring drone music from NJ

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How do i enabled system sound effects??? SOLVED
« Reply #34 on: August 16, 2014, 11:07:00 am »
You can adjust the volume of your login sound by use of the "--volume=n" parameter, where n = a volume between 0 and 100

eg.
Code: [Select]
Exec=/usr/bin/mplayer --volume=50 /home/iamesper/Music/startupukejazzy.mp3
« Last Edit: August 16, 2014, 11:09:18 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: How do i enabled system sound effects??? SOLVED
« Reply #35 on: August 16, 2014, 11:24:43 am »
perfect thanks! just trying to see if there is a site online with more log in jingles for now this works though thanks again!
http://iamesper.bandcamp.com
boring drone music from NJ

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: How do i enabled system sound effects??? SOLVED
« Reply #36 on: August 16, 2014, 12:56:12 pm »
how would i go about making a log out sound? i should have asked that before but i forgot to ask.
http://iamesper.bandcamp.com
boring drone music from NJ

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1812
  • Karma: 474
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: How do i enabled system sound effects??? SOLVED
« Reply #37 on: August 16, 2014, 01:42:19 pm »
This is just a wild guess, but if it does not work it will not cause problems, so it is worth a try.


Basically, do everything as for your login sound, just change the name of the newly created file from login-sound.desktop file to logout-sound.desktop and then logout/login and maybe logout again to see if it works.


Regards,
-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How do i enabled system sound effects??? SOLVED
« Reply #38 on: August 16, 2014, 01:58:18 pm »
Nope that won't work.

There is NO easy way to play a logout sound.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: How do i enabled system sound effects??? SOLVED
« Reply #39 on: August 16, 2014, 02:02:56 pm »
ok thank you for the answer no worries than i just won't have a logout sound not a huge deal figured i'd ask first before doing
something that will mess everything up. thanks again!
http://iamesper.bandcamp.com
boring drone music from NJ

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How do i enabled system sound effects??? SOLVED
« Reply #40 on: November 29, 2016, 06:18:56 pm »
If you want system sounds, open a terminal and run:
Code: [Select]
sudo pluma /etc/gtk-3.0/settings.ini
add this new line at the bottom:
Code: [Select]
gtk-modules = canberra-gtk-module
SAVE the file and exit pluma.

Now log off/on

That should have given you the default "freedesktop" sound theme .. eg. right-click on a file and choose "Delete" and you should hear a sound.

If you want the "ubuntu" sound theme it'll need to be installed first, in the terminal run:
Code: [Select]
sudo apt-get install ubuntu-sounds
and log off/on.
(but be warned, I think the ubuntu sound theme is too much .. the default freedesktop ones are much better, ie. you won't hear them very often, nly for warnings like "delete", etc.)

If you want to switch themes, look in this directory
/usr/share/sounds
that's where the sound themes are stored.

And they're set in
/etc/gtk-3.0/settings.ini
by the line
gtk-sound-theme-name = ubuntu



Further info

If you want to set a different theme on a "per user" basis, set the gtk-sound-theme-name in
~/.config/gtk-3.0/settings.ini
« Last Edit: November 29, 2016, 06:23:11 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec