Choose style:

Author Topic: Cannot use updater and a quick font question. (SOLVED)  (Read 1977 times)

0 Members and 1 Guest are viewing this topic.

Offline d.knight

  • Jr. Member
  • **
  • Posts: 54
  • Karma: 1
  • New Forum User
    • View Profile
Cannot use updater and a quick font question. (SOLVED)
« on: October 26, 2014, 12:18:07 pm »
I am unable to use graphical updater. It wont let me tick the boxes here (screenshot) (image no longer available)
and as a side issue, when I got an updates available message it did this (screenshot) (image no longer available)

The output is:
Spoiler (click here to view / hide)
W:Failed to fetch cdrom://Peppermint 5 _Five_ - Release amd64 (20140617.2)/dists/trusty/main/binary-amd64/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Peppermint 5 _Five_ - Release amd64 (20140617.2)/dists/trusty/multiverse/binary-amd64/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Peppermint 5 _Five_ - Release amd64 (20140617.2)/dists/trusty/restricted/binary-amd64/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Peppermint 5 _Five_ - Release amd64 (20140617.2)/dists/trusty/universe/binary-amd64/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Peppermint 5 _Five_ - Release amd64 (20140617.2)/dists/trusty/main/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Peppermint 5 _Five_ - Release amd64 (20140617.2)/dists/trusty/multiverse/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Peppermint 5 _Five_ - Release amd64 (20140617.2)/dists/trusty/restricted/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Peppermint 5 _Five_ - Release amd64 (20140617.2)/dists/trusty/universe/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, E:Some index files failed to download. They have been ignored, or old ones used instead.
[close]

As it seems to be trying to update a cdrom Im not sure it's something I want or need to do anyway, it's just that it popped up as a needed update that made me wonder. it's the first one that won't let me tick the boxes that bothers me.

The font question:  How do I change the size of fixed width font monospace from 11 to something readable like around 32. Oh, and the taskbar font will only go to 20 which is a bit annoying as I can't see it very well when it's that small.
Background info: The screen is being output onto a tv via a nvidia Gforce and hdmi cable at 1950*1080 and needs to have much bigger fonts as I'm using Nvidias drivers - the xserver driver freezes the display too often to be usable.
« Last Edit: October 28, 2014, 06:57:26 am by d.knight »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 2885
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Cannot use updater and a quick font question.
« Reply #1 on: October 26, 2014, 01:42:39 pm »
Can you please open a terminal and run:
Code: [Select]
gedit /etc/apt/sources.list
and post the contents back here.

Can you also post the output from:
Code: [Select]
ls -al /usr/share/python-apt/templates
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4887
  • Karma: 1042
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Cannot use updater and a quick font question.
« Reply #2 on: October 26, 2014, 01:49:12 pm »
Hi d.knight.  I see that the output you returned is very long.  In future, could you please encapsulate long outputs with the Sp Spoiler function.  This is located just above the crying  :'( emoticon.  It makes it much easier for people to read and keeps things neat and tidy.  This time Iíve done this for you.  When posting images to this forum, please use an image hosting service such as: www.postimage.org or https://imgur.com/.  For further instructions please see the following link: Posting Images to the Forum.

Your font issue is not related to the original query.  To keep things streamlined for future visitors, please start a new topic line for each query. Thanks in advance ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline d.knight

  • Jr. Member
  • **
  • Posts: 54
  • Karma: 1
  • New Forum User
    • View Profile
Re: Cannot use updater and a quick font question.
« Reply #3 on: October 26, 2014, 03:25:40 pm »
Here is the output of
Code: [Select]
ls -al /usr/share/python-apt/templates
Spoiler (click here to view / hide)
total 216
drwxr-xr-x 2 root root  4096 Jun 17 15:01 .
drwxr-xr-x 3 root root  4096 Apr 16  2014 ..
-rw-r--r-- 1 root root  5802 Apr  2  2014 Debian.info
-rw-r--r-- 1 root root 27746 Apr  1  2014 Debian.mirrors
-rw-r--r-- 1 root root  1590 Apr  2  2014 gNewSense.info
-rw-r--r-- 1 root root 16349 Apr  1  2014 gNewSense.mirrors
-rw-r--r-- 1 root root 52073 May  7 20:51 Peppermint.info
-rw-r--r-- 1 root root 17048 Apr  1  2014 Peppermint.mirrors
-rw-r--r-- 1 root root  1169 Apr  2  2014 Tanglu.info
-rw-r--r-- 1 root root   115 Apr  1  2014 Tanglu.mirrors
-rw-r--r-- 1 root root 52060 Apr  2  2014 Ubuntu.info
-rw-r--r-- 1 root root 17048 Apr  1  2014 Ubuntu.mirrors
[close]
This is the output of
Code: [Select]
gedit /etc/apt/sources.list
Spoiler (click here to view / hide)
deb cdrom:[Peppermint 5 _Five_ - Release amd64 (20140617.2)]/ trusty main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://gb.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://gb.archive.ubuntu.com/ubuntu/ trusty-updates restricted main
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://gb.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty universe
deb http://gb.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://gb.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://gb.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://gb.archive.ubuntu.com/ubuntu/ trusty-backports multiverse restricted main universe
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main
deb http://security.ubuntu.com/ubuntu/ trusty-security multiverse restricted main universe
deb http://gb.archive.ubuntu.com/ubuntu/ trusty-proposed multiverse restricted main universe
[close]
btw this gave me this error
** (gedit:3342): WARNING **: Could not load Gedit repository: Typelib file for namespace 'GtkSource', version '3.0' not found
and cut and pasting that error gave me this error
Spoiler (click here to view / hide)
(gedit:3342): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
[close]
and led to gedit jumping off the nearest cliff.
Apologies too all for the long output previous (you live and learn) Will repost font part as a seperate question.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4887
  • Karma: 1042
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Cannot use updater and a quick font question.
« Reply #4 on: October 26, 2014, 04:00:03 pm »
Hi d.knight, the command gedit /etc/apt/sources.list needs to be opened as "ROOT".  Sorry, its our shorthand.  Use this command:
Code: [Select]
gksudo gedit /etc/apt/sources.list
Enter your user password in the popup window.  That should do it.  I hope this helped  ;)!!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 2885
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Cannot use updater and a quick font question.
« Reply #5 on: October 26, 2014, 04:19:26 pm »
Ignore the Gtk-WARNING(s), they're not a problem (they're only caused because we're not using the whole gnome desktop) so they're safe to ignore).

Run:
Code: [Select]
sudo gedit /etc/apt/sources.list
and comment out the first line by prefixing it with an "#" and a space .. so you're changing

deb cdrom:[Peppermint 5 _Five_ - Release amd64 (20140617.2)]/ trusty main multiverse restricted universe

to

# deb cdrom:[Peppermint 5 _Five_ - Release amd64 (20140617.2)]/ trusty main multiverse restricted universe

SAVE the file, and exit gedit.

Back in the terminal run:
Code: [Select]
sudo apt-get update
then
Code: [Select]
sudo apt-get dist-upgrade



As for not being able to tick those 4 boxes, I'm still trying to figure out exactly what causes that .. it only affects SOME people and I'm unable to reproduce it
BUT
According to the contents of your sources.list .. those 4 boxes are ALREADY ticked (even though they're displaying as not.



Can you start a new topic about the fonts, and I'll see what I can dig up.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline d.knight

  • Jr. Member
  • **
  • Posts: 54
  • Karma: 1
  • New Forum User
    • View Profile
Re: Cannot use updater and a quick font question. (SOLVED)
« Reply #6 on: October 26, 2014, 04:47:34 pm »
Ah right, so it was trying to read off the cd that was no longer in the drive I assume. Thanks. They are indeed now showing as ticked. Hopefully no more issues. Just in case it helps at all, I could tick any one of them before, at which point it asked for my password. As soon as I entered that, it un-ticked the box and wouldn't let me alter them.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 2885
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Cannot use updater and a quick font question. (SOLVED)
« Reply #7 on: October 26, 2014, 05:02:59 pm »
Ah right, so it was trying to read off the cd that was no longer in the drive I assume.

Egg Zactly. :)

Thanks for marking the topic solved.
« Last Edit: October 26, 2014, 05:06:45 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec