Choose style:

Author Topic: not booting automatically (Solved)  (Read 669 times)

0 Members and 1 Guest are viewing this topic.

Offline grecodiverdi

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
not booting automatically (Solved)
« on: May 05, 2019, 04:56:32 pm »
Hello,

I'm new to Linux after being given an old HP laptop and replacing with Peppermint. Everything was fine until I tried to live boot with an other distro, as my original plan was to live boot Peppermint onto an old Macbook which just wasn't working, it couldn't read the USB. I tried it on the laptop and now I either get a blank screen when starting up or the Grub menu and it takes longer to load. I attempted to change the grub settings which I was unable to achieve and then reloaded Peppermint but the start up is still the same.
Any help would be much appreciated.
« Last Edit: May 15, 2019, 10:01:16 am by grecodiverdi »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25266
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: not booting automatically
« Reply #1 on: May 05, 2019, 06:25:10 pm »
Okay you lost me there...

Is Peppermint the only OS on the drive ?

What's the output from:
Code: [Select]
sudo fdisk -l
and
Code: [Select]
blkid
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline grecodiverdi

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: not booting automatically
« Reply #2 on: May 06, 2019, 05:03:31 am »
I think I lost myself too! Yes Peppermint is the only OS.

Disk /dev/sda: 232.9 GiB, 250059350016 bytes, 488397168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x9da1fc6e

Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1  *     2048 488396799 488394752 232.9G 83 Linux

and

/dev/sda1: UUID="555bc65d-93f7-4bfe-b433-37a6a4eea0bc" TYPE="ext4" PARTUUID="9da1fc6e-01"

Cheers for this.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25266
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: not booting automatically
« Reply #3 on: May 06, 2019, 07:09:24 am »
Okay so what's the problem now ?

Is it just that the GRUB screen is displaying (where it normally doesn't when only a single OS is installed) ?

Have you tried running:
Code: [Select]
sudo update-grub
then rebooting to see if it makes any difference ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline grecodiverdi

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: not booting automatically
« Reply #4 on: May 06, 2019, 10:28:04 am »
When the problem started I reloaded just the grub manager, and then the whole OS itself, when that didn't solve the problem. I tried your advice and updated GRUB but still the same issues.
Quite often I only get a blank screen when starting up and have to reboot and then get the GRUB where as previously it booted up no problem. It happened after attempting the liveboot so I presumed reloading the entire OS would have solved it but unfortunately not!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25266
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: not booting automatically
« Reply #5 on: May 06, 2019, 11:41:34 am »
Can you post the output from:
Code: [Select]
inxi -Fz
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline grecodiverdi

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: not booting automatically
« Reply #6 on: May 06, 2019, 01:23:17 pm »
System:    Host: bob-HP-G70-Notebook-PC Kernel: 4.15.0-48-generic i686 bits: 32
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: laptop System: Hewlett-Packard product: HP G70 Notebook PC v: F.32 serial: N/A
           Mobo: Wistron model: 360C v: 09.48 serial: N/A
           BIOS: Hewlett-Packard v: F.32 date: 11/20/2008
Battery    BAT0: charge: 12.0 Wh 144.2% condition: 8.3/47.5 Wh (18%)
CPU:       Dual core Intel Pentium Dual T3400 (-MCP-) cache: 1024 KB
           clock speeds: max: 2166 MHz 1: 1316 MHz 2: 1301 MHz
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1440x900@59.94hz
           OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express x86/MMX/SSE2
           version: 2.1 Mesa 18.2.8
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-48-generic
Network:   Card-1: Realtek RTL810xE PCIE Fast Ethernet controller driver: r8169
           IF: enp1s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express)
           driver: ath5k
           IF: wls1 state: up mac: <filter>
Drives:    HDD Total Size: 250.1GB (3.4% used)
           ID-1: /dev/sda model: ST9250320AS size: 250.1GB
Partition: ID-1: / size: 229G used: 7.9G (4%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 66.0C mobo: 65.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 163 Uptime: 3:02 Memory: 559.8/2957.5MB
           Client: Shell (bash) inxi: 2.3.56

Offline Pepper9

  • Jr. Member
  • **
  • Posts: 25
  • Karma: 3
  • Peppermint OS: Rest for the weary.
    • View Profile
  • Peppermint version(s): peppermint 10 64bit
Re: not booting automatically
« Reply #7 on: May 07, 2019, 03:27:29 am »
Having the same issue on a HP Compaq nx 7400, P9 32 bit. Have tried the solutions posted here to no avail.

It's no deal-breaker for me, just a tad annoying having to start the laptop twice every time. Other than that everything's just fine. Still  a happy camper.  :D
If it ain't broke.........

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25266
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: not booting automatically
« Reply #8 on: May 07, 2019, 06:11:54 pm »
Have you tried booting the earlier kernel ?

If that works, I wonder what would happen if you enabled the HWE with the first command here
https://wiki.ubuntu.com/Kernel/LTSEnablementStack
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Pepper9

  • Jr. Member
  • **
  • Posts: 25
  • Karma: 3
  • Peppermint OS: Rest for the weary.
    • View Profile
  • Peppermint version(s): peppermint 10 64bit
Re: not booting automatically
« Reply #9 on: May 08, 2019, 03:08:08 am »
Have you tried booting the earlier kernel ?

If that works, I wonder what would happen if you enabled the HWE with the first command here
https://wiki.ubuntu.com/Kernel/LTSEnablementStack

No I haven't. Neither have I recovered the journal to read what was going on. Life is happening at the moment so I don't have boat loads of time at the moment.

I'll look into it and will try to fix it and will post the output here for development sake.  8)
If it ain't broke.........

Offline grecodiverdi

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: not booting automatically
« Reply #10 on: May 08, 2019, 02:59:27 pm »
Have you tried booting the earlier kernel ?

If that works, I wonder what would happen if you enabled the HWE with the first command here
https://wiki.ubuntu.com/Kernel/LTSEnablementStack

Okay I found a post explaining changing the kernel. I donloaded the following three files as it said.

linux-headers-4.14.116-0414116_4.14.116-0414116.201905040435_all.deb
linux-headers-4.14.116-0414116-generic_4.14.116-0414116.201905040435_i386.deb
linux-image-4.14.116-0414116-generic_4.14.116-0414116.201905040435_armhf.deb

but it said there were errors when i entered

sudo dpkg -i *.deb

I updated the Grub and unsurprisingly the kernel hasn't changed.
« Last Edit: May 08, 2019, 04:39:28 pm by grecodiverdi »

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1724
  • Karma: 464
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 9 - 64bit
Re: not booting automatically
« Reply #11 on: May 09, 2019, 04:30:09 am »
Hi grecodiverdi,

It's no wonder that you had errors trying to install an incorrect package: the package name that ends with armhf.deb is not for your Intel Pentium cpu !! Arm-based processors are not made by Intel and are (particularly from the kernel perspective) completely different than any Intel Pentium processors (which is what is in your computer).

Go back and check the instructions on that page again. I do not see that package mentioned anywhere. The armhf.deb package is for Arm-based processors and you can read about them here if you wish -- but for you that would just be a waste of time since you need i386 architecture packages.  ;)

If you are still not sure which packages you need, ask here before trying any of this -- otherwise you alone are responsible for what results.

Regards,

-- Slim
 
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1823
  • Karma: 250
    • View Profile
Re: not booting automatically
« Reply #12 on: May 09, 2019, 04:49:52 am »
Aside from what Slim said, you're missing one package.
Also, the 4.14 series is now at .117. Have a look here https://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.117/
You need the following packages:
linux-headers-4.14.117-0414117_4.14.117-0414117.201905080729_all.deb
linux-headers-4.14.117-0414117-generic_4.14.117-0414117.201905080729_i386.deb
linux-image-4.14.117-0414117-generic_4.14.117-0414117.201905080729_i386.deb
linux-modules-4.14.117-0414117-generic_4.14.117-0414117.201905080729_i386.deb

Install these, reboot and pick the 4.14.117 kernel from the GRUB menu.
Once your system is ready, make sure you are using the 4.14.117 kernel by typing in the terminal
Code: [Select]
uname -a

Please post here the output of
Code: [Select]
dpkg -l | grep linux-image
so we can help you clean-up your system from unwanted kernel bits and pieces.

We will need some follow-up outputs from you, but I can't give you the correct commands before you post the output from the command above.
Good luck!

EDIT: By default GRUB will always boot the kernel with highest number first. In your case this is good, as you have pulled-in ARM stuff instead of i386  ;)
« Last Edit: May 09, 2019, 04:53:40 am by pin »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25266
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: not booting automatically
« Reply #13 on: May 09, 2019, 02:11:33 pm »
That's not exactly what I meant by booting an earlier kernel .. I simply meant from the GRUB menu.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline grecodiverdi

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: not booting automatically
« Reply #14 on: May 09, 2019, 02:44:31 pm »
That's not exactly what I meant by booting an earlier kernel .. I simply meant from the GRUB menu.

Ok you've lost me now!  :D
What is my next step? I'm finding my feet as I've not had to operate this way since my ZXSpectrum days.