Choose style:

Author Topic: hanging shutdown  (Read 359 times)

0 Members and 1 Guest are viewing this topic.

Offline mariasourbinou

  • nOOb
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
hanging shutdown
« on: May 05, 2019, 06:41:05 am »
Good morning i use peppermint 9 one year but i can't shutdown neither reboot properly. It hangs always to shutdown and i have to press the power button  I'll change a lot of things to grub but nothing Can you help me please?????

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1010
  • Karma: 56
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: hanging shutdown
« Reply #1 on: May 05, 2019, 09:13:28 am »
Hi mariasourbinou, welcome to Peppermint. In order to help you, we need more information from you. Could you please open a terminal and enter the following code
Code: [Select]
inxi -Fz
and then copy and paste the entire results back here?
What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25718
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: hanging shutdown
« Reply #2 on: May 05, 2019, 06:41:09 pm »
If you hit the Esc key at the "Shutting Down" screen, is any text displayed ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline DARKBOW923

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 11
  • All linux problem have solutions.
    • View Profile
  • Peppermint version(s): Peppermint 7 64 bit :D
Re: hanging shutdown
« Reply #3 on: May 17, 2019, 04:21:39 am »
Good morning i use peppermint 9 one year but i can't shutdown neither reboot properly. It hangs always to shutdown and i have to press the power button  I'll change a lot of things to grub but nothing Can you help me please?????

Yo dude!!!

Last year i have the same problem, annoing as hell.

But i solved it (at least for me!) and i think we have the same problem.

https://forum.peppermintos.com/index.php/topic,8193.msg84036.html#msg84036

This is the post i maked for solve my problem, as i said, i haved the same problem as you.

First of all, you need to open the
Code: [Select]
etc/default/grub
file and then edit the grub default line and put this:

Code: [Select]
noapic acpi=force reboot=b


What makes this?

This command, noapic acpi=force reboot=b forces the acpi module to reboot. If you want other options than 'b' like off the noapic, but i can't find it right now.

Then, please go to the BIOS and disable the 'wake up for USB' or something like this, Then just reboot the system and see if this works.

See ya!

Now with new machine! Medion AKOYA intel core i3 7100 3mb caché 7th gen, 4GB RAM DDR4 Intel HD Graphics 630 1TB HDD space.

Offline Pepper9

  • Jr. Member
  • **
  • Posts: 27
  • Karma: 3
  • Peppermint OS: Rest for the weary.
    • View Profile
  • Peppermint version(s): peppermint 10 64bit
Re: hanging shutdown
« Reply #4 on: September 22, 2019, 04:15:34 am »
Code: [Select]
noapic acpi=force reboot=b

So where exactly would I put this line? Just at the top (first line) of the file?  :-\
If it ain't broke.........

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25718
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: hanging shutdown
« Reply #5 on: September 22, 2019, 05:33:22 pm »
NO, run
Code: [Select]
gksudo xed /etc/default/grub
find the line
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic acpi=force reboot=b"
SAVE the file, and exit the text editor.

Back in the terminal run:
Code: [Select]
sudo update-grub
then reboot (twice) to test.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Pepper9

  • Jr. Member
  • **
  • Posts: 27
  • Karma: 3
  • Peppermint OS: Rest for the weary.
    • View Profile
  • Peppermint version(s): peppermint 10 64bit
Re: hanging shutdown
« Reply #6 on: September 24, 2019, 12:50:50 am »
Worked like a charm. Thanks, as usual  8)
If it ain't broke.........

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25718
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: hanging shutdown
« Reply #7 on: September 24, 2019, 09:15:34 am »
Great news, kudos to DARKBOW923 for providing the kernel boot options solution :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec