Choose style:

Author Topic: Nvidia still doesnt create a x11.conf file (p9 respin)  (Read 409 times)

0 Members and 1 Guest are viewing this topic.

Offline chadwix

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
Re: Nvidia still doesnt create a x11.conf file (p9 respin)
« Reply #15 on: May 07, 2019, 03:02:00 am »
Hi
You have already been given all the answers by various people - you just need to put them all together.
install the nvidia drivers - 390 will be fine.  Do this from Additional Drivers or in a terminal type

Code: [Select]
sudo ubuntu-drivers autoinstall
Reboot and use

Code: [Select]
sudo nvidia-settings
to open nvidia control panel
find OpenGL Settings and untick "Sync to vBlank" and untick "Allow Flipping"
find X Server Display Configuration - click on advanced and then tick "Force Full Composition Pipeline"

then click save and type in the dialog box
Code: [Select]
/etc/X11/xorg.conf
click "Save" and when you are back to the main nvidia-settings screen click Quit.
This WILL eliminate all screen tearing.

Now to set the Font DPi anywhere between 96 and 144
so run
Code: [Select]
xed ~/.Xresources
and when a blank file opens, add this line

Code: [Select]
Xft.dpi: 96
 
Change 96 as described above - you will need to experiment to get the font size you wish.

Now to get the window borders looking better for HiDPI displays
Open the Peppermint Settings Panel and then the Peppermint Control Centre. 
On the Window Manager Tab choose a Theme called Default-hdpi or Default xhdpi.  Again you will need to choose which of the two you prefer.
That is it.

Regards Zeb...

Thanks for the info, using the 390 driver now and fonts were big after driver but now fine after your dpi96 line. 
The only problem is I have todo the ctrl-alt  f2 then f7 or i get a grey screen upon every reboot.

Is there anyway to remove tearing with the generic driver?

Code: [Select]
System:    Host: chad-desktop Kernel: 4.15.0-48-generic x86_64 bits: 64
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: desktop Mobo: Intel model: DZ68BC v: AAG30742-401 serial: N/A
           BIOS: Intel v: BCZ6810H.86A.0021.2011.0831.1555 date: 08/31/2011
CPU:       Quad core Intel Core i7-2600K (-MT-MCP-) cache: 8192 KB
           clock speeds: max: 3800 MHz 1: 1596 MHz 2: 1596 MHz 3: 1596 MHz
           4: 1596 MHz 5: 1595 MHz 6: 1596 MHz 7: 1596 MHz 8: 1596 MHz
Graphics:  Card: NVIDIA GP104 [GeForce GTX 1070]
           Display Server: x11 (X.Org 1.19.6 ) driver: nvidia
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.116
Audio:     Card-1 Intel 6 Series/C200 Series Family High Def. Audio Controller
           driver: snd_hda_intel
           Card-2 NVIDIA GP104 High Def. Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-48-generic
Network:   Card: Intel 82579V Gigabit Network Connection driver: e1000e
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 120.0GB (19.6% used)
           ID-1: /dev/sda model: KINGSTON_SH100S3 size: 120.0GB
Partition: ID-1: / size: 110G used: 22G (22%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A gpu: 38C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 227 Uptime: 4 min Memory: 639.1/16016.9MB
           Client: Shell (bash) inxi: 2.3.56


« Last Edit: May 07, 2019, 03:06:38 am by chadwix »

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2909
  • Karma: 537
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Nvidia still doesnt create a x11.conf file (p9 respin)
« Reply #16 on: May 07, 2019, 02:55:06 pm »
Hi



on the X Server Display Configuration - towards the bottom click advanced and then make sure you tick "Force Full Composition Pipeline" on

and then



On the OpenGL Settings screen - I untick both "Sync to VBlank" and "Allow Flipping"

Some people advise just to do the flipping.  Experiment and see what works for you

Regards Zeb...

Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - i7-6700K @ 4.00GHz - 32Gb RAM - NVIDIA GTX1070ti 8Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P910 @ P9 x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline chadwix

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
Re: Nvidia still doesnt create a x11.conf file (p9 respin)
« Reply #17 on: May 08, 2019, 02:24:39 am »
Hi



on the X Server Display Configuration - towards the bottom click advanced and then make sure you tick "Force Full Composition Pipeline" on

and then




On the OpenGL Settings screen - I untick both "Sync to VBlank" and "Allow Flipping"

Some people advise just to do the flipping.  Experiment and see what works for you

Regards Zeb...

All of that is fine, i no longer get screen tearing and using the nvidia driver.  I have to ctrl-alt f2 then f7 to get it working.  I get a grey desktop with the lower bar (no menu).

When i hit the print screen key it appears to be fine in the screenshot after getting it working.

If the basic driver didnt have tearing id be all set