Choose style:

Author Topic: Blank Whisker Menu  (Read 528 times)

0 Members and 1 Guest are viewing this topic.

Offline jcgghb

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Blank Whisker Menu
« on: March 22, 2019, 04:59:28 pm »
Hi All,

I just finished upgrading from PM 8 to PM 9. Everything is working great. Except I open the menu and the menu is blank. The menu does not show any of the installed applications.
Is there a resolution to this issue?

Thank you.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25502
  • Karma: 2809
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Blank Whisker Menu
« Reply #1 on: March 22, 2019, 05:11:15 pm »
What do you mean by "upgrading" ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jcgghb

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Blank Whisker Menu
« Reply #2 on: March 22, 2019, 05:19:21 pm »
Was using PM 8 then installed PM 9 without formatting or over writing my PM Home directories and sub directories.

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1825
  • Karma: 252
    • View Profile
Re: Blank Whisker Menu
« Reply #3 on: March 22, 2019, 05:44:11 pm »
 :-[
There're major changes between 8 and 9.
The best would be to back-up your stuff and do a clean install  ;)

Offline jcgghb

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Blank Whisker Menu
« Reply #4 on: March 22, 2019, 05:47:18 pm »
Thanks. But I don't think I will follow your advice. But good try. Your suggestion is my failsafe option.

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1825
  • Karma: 252
    • View Profile
Re: Blank Whisker Menu
« Reply #5 on: March 22, 2019, 05:55:10 pm »
Good luck then!

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1949
  • Karma: 336
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Blank Whisker Menu
« Reply #6 on: March 22, 2019, 06:01:23 pm »
without formatting or over writing my PM Home directories and sub directories.

That's not advisable because it breaks too many things, as you've discovered.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25502
  • Karma: 2809
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Blank Whisker Menu
« Reply #7 on: March 23, 2019, 08:27:47 am »
The release notes:
https://peppermintos.com/release-notes/
clearly state you should not keep a home folder from a previous version .. we may be able to fix the menu, but you'll likely run into other issues .. it may be best to create another fresh user account, then move all your stuff to that account.

Can you confirm the menu works if you log onto a Guest session ?

And we'll decide where to go from there.
« Last Edit: March 23, 2019, 08:31:58 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jcgghb

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Blank Whisker Menu
« Reply #8 on: March 23, 2019, 10:48:47 am »
Thank you for the informative reply. Its a work issue so I will get back to you on Monday. I thought the idea of re-installing was a radical way of solving this issue. But I may have no choice. Thanks again.

Offline alynur

  • Trusted User
  • Member
  • *****
  • Posts: 993
  • Karma: 54
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Blank Whisker Menu
« Reply #9 on: March 23, 2019, 01:08:30 pm »
Thank you for the informative reply. Its a work issue so I will get back to you on Monday. I thought the idea of re-installing was a radical way of solving this issue. But I may have no choice. Thanks again.

Hi jcgghb, this is exactly why I always recommend Creating a DATA partition and symlinking your home folders to it. You can upgrade distros or change distros or anything you like, your home folders are always there and it's no biggie to make new symlinks. I highly recommend it. I said that already, didn't I.   :)
What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25502
  • Karma: 2809
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Blank Whisker Menu
« Reply #10 on: March 23, 2019, 02:36:46 pm »
Thank you for the informative reply. Its a work issue so I will get back to you on Monday. I thought the idea of re-installing was a radical way of solving this issue. But I may have no choice. Thanks again.

There's no need to reinstall, you likely just need a 'fresh' home folder .. this can be easily achieved by creating a new user account (and IMPORTANTLY adding it to the sudo group), copying your user files (pics/docs/etc.) from the old account to the new one, testing the new account (including 'sudo'), then once you're happy deleting the old account.

That said, we MAY be able to simply fix the menu if you're sure that's the only problem .. but I'll need you to confirm what I asked in my last posting first.
« Last Edit: March 25, 2019, 01:46:10 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rayzer

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Blank Whisker Menu
« Reply #11 on: March 25, 2019, 11:52:36 am »
try reinstalling the 'xfce4-whiskermenu-plugin'  & 'menu' packages with synaptic and see if it reconfigures it.

Offline jcgghb

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Blank Whisker Menu
« Reply #12 on: March 26, 2019, 08:30:30 am »
Thank you all for your very worthy advice. I took the path of least resistance copied my Home Directory and then recopied it back after doing a simple format install. Thanks again.