Choose style:

Author Topic: Screen Locking  (Read 260 times)

0 Members and 1 Guest are viewing this topic.

Offline CWM030

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Screen Locking
« on: March 11, 2019, 08:04:17 pm »
HI,

I am running Peppermint on a old Compaq Presario laptop with 2 gigs of ram.

And I noticed that when the screen shuts off I am not prompted for a password?

How do I set P9 to ask for a password when the screen is awakened?

Thanks,
Chris

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Screen Locking
« Reply #1 on: March 12, 2019, 04:20:31 pm »
When the screen shuts off how ?

By shutting the lid, or after inactivity ?



Maybe try installing light-locker
Code: [Select]
sudo apt-get install light-locker light-locker-settings
then REBOOT

then test ?
« Last Edit: March 12, 2019, 04:31:44 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline CWM030

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Screen Locking
« Reply #2 on: March 13, 2019, 02:55:10 pm »
Hello,

After inactivity..

Thanks let me go try that.

Chris

Offline CWM030

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Screen Locking
« Reply #3 on: March 13, 2019, 03:19:59 pm »
When the screen shuts off how ?

By shutting the lid, or after inactivity ?



Maybe try installing light-locker
Code: [Select]
sudo apt-get install light-locker light-locker-settings
then REBOOT

then test ?

Hello,

Okay the screen locked, but the screen isn't turning off on this laptop. =[

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Screen Locking
« Reply #4 on: March 13, 2019, 04:06:29 pm »
Did it turn off before the change to light-locker ?

and how are you triggering the suspend ?

and have you toyed with the settings in the power-manager ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline CWM030

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Screen Locking
« Reply #5 on: March 13, 2019, 04:13:41 pm »
>>>Did it turn off before the change to light-locker ?<<<<

The only thing I set was the power manager was blank after 15, suspend after 16 and off at 17. ( Thats the only way the sliders would let me do it.



<<<<and how are you triggering the suspend ?<<<<

I am not suspending the computer.... The laptop always runs because I'm always doing stuff for my mom on it I just want the screen to turn off. when not in use.



>>and have you toyed with the settings in the power-manager ? >>

I noticed under the light-locker-settings it says something in red about XFCE manager controls something at the top of the screen.


Thanks,
Chris

Offline CWM030

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Screen Locking
« Reply #6 on: March 13, 2019, 04:18:31 pm »
Did it turn off before the change to light-locker ?

and how are you triggering the suspend ?

and have you toyed with the settings in the power-manager ?



Okay I just looked under light-locker-settings the error says:

" Your screensaver is controlled by the XFCE power manager"

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Screen Locking
« Reply #7 on: March 13, 2019, 04:20:27 pm »
Your original posting said

Quote
And I noticed that when the screen shuts off I am not prompted for a password?

so how were you triggering the screen to turn off ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline CWM030

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Screen Locking
« Reply #8 on: March 13, 2019, 04:44:21 pm »
Your original posting said

Quote
And I noticed that when the screen shuts off I am not prompted for a password?

so how were you triggering the screen to turn off ?

Via power manager to blank screen after 15 min.....

suspend screen at 16

turn off screen at 17 min.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Screen Locking
« Reply #9 on: March 13, 2019, 07:25:55 pm »
And that worked (except for locking) prior to switching to light-locker ?

but doesn't even switch off the screen now, with light-locker ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline CWM030

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Screen Locking
« Reply #10 on: March 13, 2019, 08:04:17 pm »
And that worked (except for locking) prior to switching to light-locker ?

but doesn't even switch off the screen now, with light-locker ?


Before I ran the command you gave me , the screen would turn off but if you moved the mouse you could see the desktop and P9 never asked for a password.,

AFTER running your command, now I get the password prompt screen but the screen won't turn off.


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Screen Locking
« Reply #11 on: March 14, 2019, 11:39:49 am »
Try
Code: [Select]
sudo apt-get remove --purge light-locker light-locker-settings
then
Code: [Select]
cd /usr/bin
then
Code: [Select]
sudo ln -s /usr/lib/i3lock-fancy/i3lock-fancy xscreensaver
then REBOOT

Now test if it works.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline CWM030

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Screen Locking
« Reply #12 on: March 14, 2019, 08:26:01 pm »
Try
Code: [Select]
sudo apt-get remove --purge light-locker light-locker-settings
then
Code: [Select]
cd /usr/bin
then
Code: [Select]
sudo ln -s /usr/lib/i3lock-fancy/i3lock-fancy xscreensaver
then REBOOT

Now test if it works.

When I move the mouse I am instantly taken to the desktop :( No password prompt shows up now that I have removed light locker.

Offline CWM030

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Screen Locking
« Reply #13 on: March 15, 2019, 10:03:16 pm »
Try
Code: [Select]
sudo apt-get remove --purge light-locker light-locker-settings
then
Code: [Select]
cd /usr/bin
then
Code: [Select]
sudo ln -s /usr/lib/i3lock-fancy/i3lock-fancy xscreensaver
then REBOOT

Now test if it works.




When I move the mouse I am instantly taken to the desktop :( No password prompt shows up now that I have removed light locker.