Choose style:

Author Topic: Text file default set to execute as program...[SOLVED]  (Read 319 times)

0 Members and 1 Guest are viewing this topic.

Offline spence

  • Trusted User
  • Veteran
  • *****
  • Posts: 1571
  • Karma: 160
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin
Re: Text file default set to execute as program
« Reply #15 on: March 13, 2019, 02:46:28 pm »

This question reminds me of my own problems with file permissions from this post https://forum.peppermintos.com/index.php/topic,5936.0.html...  Now that Win10 is gone I'mma revisit
Read through this post which does seem very similar. Doesn't seem there was a solution though that could be applied here other than just grin and bear it until I eventually find them all and manually uncheck the boxes.  :-\

There was no solution in my thread @ogopogo as I realized my dual-booting MS and Linux was not going to allow one. Also many of the files in question date back to Win7, WinXP & even Win98SE so file ownership and permissions were all over the map
spence
PeppermintOS 9 installed  on:
'16 Antec Aria rebuild


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1577
  • Karma: 219
  • Peppermint - Void - NetBSD
    • View Profile
  • Peppermint version(s): Peppermint 7 Respin (64bit)
Re: Text file default set to execute as program
« Reply #16 on: March 13, 2019, 05:51:00 pm »
Give me 10min...
Need to double check the command I wrote previouly... just need to get home and boot one of my machines  ;)

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1577
  • Karma: 219
  • Peppermint - Void - NetBSD
    • View Profile
  • Peppermint version(s): Peppermint 7 Respin (64bit)
Re: Text file default set to execute as program
« Reply #17 on: March 13, 2019, 06:09:16 pm »
What about...
Code: [Select]
sudo chmod u-x /home/gerry/Documents/*
?

Offline rayzer

  • nOOb
  • *
  • Posts: 23
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Text file default set to execute as program
« Reply #18 on: March 13, 2019, 06:31:39 pm »
delete...
« Last Edit: March 14, 2019, 04:08:43 am by rayzer »

Offline ogopogo

  • Jr. Member
  • **
  • Posts: 49
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Text file default set to execute as program
« Reply #19 on: March 13, 2019, 07:27:18 pm »
is DATA on an internal drive ?

if so, you could change directory to /mnt/DATA
Code: [Select]
cd /mnt/DATA
then recursively change the permission of all FILES to 644:
Code: [Select]
find . -type f -exec chmod 0644 {} \;
and all DIRECTORIES to 755:
Code: [Select]
find . -type d -exec chmod 0755 {} \;
BE AWARE, if DATA is on an external drive the above commands could take some considerable time (depending on the amount of files/folders).

and remember, the above commands wil only work on files/folders you own.

ALSO bear in mind that going to mark ALL files as non-executable .. even scripts and binaries (not just text files).

HOORAY!  This worked like a charm. Thank you very much PCNetSpec!   :)

BTW..... All the info on the DATA partition on my HD I owned and there were no scripts or binaries to worry about either.

Thank you everyone else for you participation too!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Text file default set to execute as program...[SOLVED]
« Reply #20 on: March 14, 2019, 11:37:02 am »
You're most welcome :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec