Choose style:

Author Topic: (SOLVED) Why is Steam not Avaliable ?  (Read 182 times)

0 Members and 1 Guest are viewing this topic.

Offline FERE

  • nOOb
  • *
  • Posts: 18
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): DISTRIB_RELEASE=9
(SOLVED) Why is Steam not Avaliable ?
« on: March 09, 2019, 02:05:18 am »
Why is Steam not Avaliable ?

« Last Edit: March 10, 2019, 10:26:44 am by FERE »

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 3749
  • Karma: 825
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Why is Steam not Avaliable ?
« Reply #1 on: March 09, 2019, 03:12:45 am »
It's available, I don't know why it's showing as not available in the software manager. It can be installed using this method. Open a terminal and run this command:

Code: [Select]
sudo apt-get update

Enter your root password when prompted. After that command completes, run this one:

Code: [Select]
sudo apt-get install steam

That's what I did to install Steam on my system, and it worked just fine.

Offline FERE

  • nOOb
  • *
  • Posts: 18
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): DISTRIB_RELEASE=9
Re: Why is Steam not Avaliable ?
« Reply #2 on: March 09, 2019, 09:21:50 am »
It's available, I don't know why it's showing as not available in the software manager. It can be installed using this method. Open a terminal and run this command:

Code: [Select]
sudo apt-get update

Enter your root password when prompted. After that command completes, run this one:

Code: [Select]
sudo apt-get install steam

That's what I did to install Steam on my system, and it worked just fine.

Thanks man

I ran both commands  and i got this ERROR please look
Code: [Select]
minnts@minnts-System-Product-Name ~ $ sudo apt-get update
[sudo] password for minnts:
Hit:1 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease
Hit:2 http://archive.canonical.com/ubuntu bionic InRelease                           
Get:3 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]         
Hit:4 http://ppa.launchpad.net/peppermintos/p9-release/ubuntu bionic InRelease       
Hit:5 http://de.archive.ubuntu.com/ubuntu bionic InRelease                           
Get:6 http://de.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]         
Get:7 http://de.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Get:8 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [20,8 kB]
Get:10 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [12,2 kB]
Get:11 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [50,1 kB]
Get:12 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2.464 B]
Fetched 338 kB in 1s (590 kB/s)                                   
Reading package lists... Done
minnts@minnts-System-Product-Name ~ $ sudo apt-get install steam
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 steam:i386 : Depends: libudev1:i386 but it is not going to be installed
              Depends: libgl1-mesa-glx:i386 but it is not going to be installed
              Recommends: nvidia-driver-libs-i386:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

whats going on ? :'(

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Why is Steam not Avaliable ?
« Reply #3 on: March 09, 2019, 09:45:21 am »
What happens if you run:
Code: [Select]
sudo apt-get install libudev1:i386 libgl1-mesa-glx:i386
?



Your other option might be to uninstall steam from the repos
Code: [Select]
sudo apt-get remove steam
then download the client directly from Valve
https://steamcdn-a.akamaihd.net/client/installer/steam.deb
then double-click it to install.
« Last Edit: March 09, 2019, 09:51:59 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline FERE

  • nOOb
  • *
  • Posts: 18
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): DISTRIB_RELEASE=9
Re: Why is Steam not Avaliable ?
« Reply #4 on: March 09, 2019, 01:24:38 pm »
Spoiler (click here to view / hide)
minnts@minnts-System-Product-Name ~ $ sudo apt-get install libudev1:i386 libgl1-mesa-glx:i386
[sudo] password for minnts:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  app-install-data cairo-dock-animated-icons-plug-in
  cairo-dock-drop-indicator-plug-in cairo-dock-icon-effect-plug-in
  cairo-dock-illusion-plug-in cairo-dock-motion-blur-plug-in cairo-dock-plug-in-data
  cairo-dock-showmouse-plug-in compton dkms dleyna-server folks-common
  fonts-freefont-ttf geoclue-2.0 gir1.2-appstream-1.0 gir1.2-flatpak-1.0
  gir1.2-geoclue-2.0 gir1.2-geocodeglib-1.0 gir1.2-gfbgraph-0.2 gir1.2-grilo-0.3
  gir1.2-gstreamer-1.0 gir1.2-json-1.0 gir1.2-mediaart-2.0 gir1.2-rest-0.7
  gir1.2-totemplparser-1.0 gir1.2-tracker-2.0 gist gnome-settings-daemon-schemas
  grilo-plugins-0.3 grilo-plugins-0.3-base grilo-plugins-0.3-extra hddtemp
  libaribb24-0 libaudio2 libb2-1 libbasicusageenvironment1 libbrotli1
  libclutter-1.0-common libconfig9 libdleyna-connector-dbus-1.0-1
  libdleyna-core-1.0-3 libdmapsharing-3.0-2 libdvbpsi10 libebackend-1.2-10
  libebml4v5 libebook-1.2-19 libecal-1.2-19 libedata-book-1.2-25 libedata-cal-1.2-28
  libenca0 libepoxy0 libetpan20 libevdev2 libexempi3 libexiv2-14 libfolks25
  libgarcon-1-0 libgeoclue-2-0 libgeocode-glib0 libgexiv2-2 libgfbgraph-0.2-0
  libglu1-mesa libgmime-3.0-0 libgnome-autoar-0-0 libgom-1.0-0 libgpod4
  libgrilo-0.3-0 libgroupsock8 libgsoap-2.8.60 libgupnp-av-1.0-2 libgupnp-dlna-2.0-3
  libgweather-common libhttrack2 libiptcdata0 liblightdm-gobject-1-0 liblivemedia62
  liblua5.3-0 libmatroska6v5 libmediaart-2.0-0 libmicrodns0 libmng2 libmozjs-52-0
  libmtdev1 libnfs11 libnvidia-cfg1-390 libnvidia-common-390 libnvidia-compute-390
  libnvidia-compute-390:i386 libnvidia-decode-390 libnvidia-decode-390:i386
  libnvidia-encode-390 libnvidia-encode-390:i386 libnvidia-fbc1-390
  libnvidia-fbc1-390:i386 libnvidia-gl-390 libnvidia-gl-390:i386 libnvidia-ifr1-390
  libnvidia-ifr1-390:i386 libopenal-data libopenal1 libopenmpt-modplug1
  libpeas-common libplacebo4 libprotobuf-lite10 libqt4-dbus libqt4-declarative
  libqt4-designer libqt4-help libqt4-network libqt4-script libqt4-scripttools
  libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns
  libqt5positioning5 libqt5qml5 libqt5sensors5 libqt5webchannel5
  libqtassistantclient4 libqtcore4 libqtdbus4 libqtgui4 libquvi-0.9-0.9.3
  libquvi-scripts-0.9 libresid-builder0c2a libsdl-image1.2 libsdl1.2debian
  libsgutils2-2 libsidplay2 libsox-fmt-alsa libsox-fmt-base libsox3 libssh2-1
  libtagc0 libtorrent-rasterbar9 libtotem-plparser-common
  libtotem-plparser-videosite libtotem-plparser18 libtracker-control-2.0-0
  libtracker-miner-2.0-0 libtracker-sparql-2.0-0 libupnp6 libusageenvironment3
  libvncserver1 libwacom-common libwayland-client0:i386 libwayland-server0:i386
  libwoff1 libxcb-icccm4 libxcb-keysyms1 libxcb-render-util0 libxfont2 libxklavier16
  libxvmc1 libzeitgeist-1.0-1 libzeitgeist-2.0-0 lua-bitop lua-expat lua-json
  lua-lpeg lua-socket lxsession-data mate-calc-common nemo-data net-tools
  nvidia-compute-utils-390 nvidia-dkms-390 nvidia-kernel-common-390
  nvidia-kernel-source-390 nvidia-prime nvidia-utils-390 osinfo-db p7zip p7zip-full
  pkg-config python-appindicator python-qt4 python-qt4-dbus python-sip
  python3-configobj python3-llfuse python3-mako python3-markupsafe python3-msgpack
  python3-netifaces python3-pbr python3-xapian qdbus qt-at-spi qtchooser
  qtcore4-l10n realpath rhythmbox-data ruby-json sox tracker virtualbox-dkms vlc-bin
  vlc-data vlc-l10n vlc-plugin-samba vlc-plugin-video-output
  vlc-plugin-video-splitter vlc-plugin-visualization webhttrack-common xbindkeys
  xed-common xubuntu-icon-theme yelp-xsl zenity-common
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  advert-block apt apt-utils apt-xapian-index aptdaemon blueman bluez borgbackup
  cairo-dock cairo-dock-alsamixer-plug-in cairo-dock-cairo-penguin-plug-in
  cairo-dock-clipper-plug-in cairo-dock-clock-plug-in cairo-dock-core
  cairo-dock-dbus-plug-in cairo-dock-desklet-rendering-plug-in
  cairo-dock-dialog-rendering-plug-in cairo-dock-dnd2share-plug-in
  cairo-dock-dustbin-plug-in cairo-dock-folders-plug-in cairo-dock-gmenu-plug-in
  cairo-dock-impulse-plug-in cairo-dock-keyboard-indicator-plug-in
  cairo-dock-logout-plug-in cairo-dock-mail-plug-in
  cairo-dock-messaging-menu-plug-in cairo-dock-musicplayer-plug-in
  cairo-dock-netspeed-plug-in cairo-dock-plug-ins cairo-dock-powermanager-plug-in
  cairo-dock-quick-browser-plug-in cairo-dock-recent-events-plug-in
  cairo-dock-remote-control-plug-in cairo-dock-rendering-plug-in
  cairo-dock-rssreader-plug-in cairo-dock-shortcuts-plug-in
  cairo-dock-showdesktop-plug-in cairo-dock-slider-plug-in cairo-dock-stack-plug-in
  cairo-dock-switcher-plug-in cairo-dock-system-monitor-plug-in
  cairo-dock-systray-plug-in cairo-dock-terminal-plug-in cairo-dock-tomboy-plug-in
  cairo-dock-toons-plug-in cairo-dock-weather-plug-in cairo-dock-wifi-plug-in
  cairo-dock-xgamma-plug-in command-not-found conky-manager cryptsetup
  cryptsetup-bin cups dbus-user-session dconf-editor dmeventd dmsetup dosfstools
  eject evince evolution-data-server exfat-fuse exo-utils ffmpeg file-roller firefox
  flashplugin-installer flatpak friendly-recovery fuse fwupd gcr gdebi gdebi-core
  gir1.2-appindicator3-0.1 gir1.2-champlain-0.12 gir1.2-clutter-1.0 gir1.2-cogl-1.0
  gir1.2-coglpango-1.0 gir1.2-gst-plugins-base-1.0 gir1.2-gtk-3.0
  gir1.2-gtkchamplain-0.12 gir1.2-gtkclutter-1.0 gir1.2-gudev-1.0
  gir1.2-gweather-3.0 gir1.2-keybinder-3.0 gir1.2-nemo-3.0 gir1.2-nm-1.0
  gir1.2-nma-1.0 gir1.2-peas-1.0 gir1.2-rb-3.0 gir1.2-vte-2.91 gir1.2-webkit2-4.0
  gir1.2-wnck-3.0 gir1.2-xapp-1.0 gjs gnome-disk-utility gnome-keyring gnome-maps
  gnome-music gnome-power-manager gnome-search-tool gnome-session-canberra
  gnome-settings-daemon gnome-software gnome-software-plugin-flatpak
  gnome-software-plugin-snap gnome-system-tools gnote gparted grub-common
  grub-gfxpayload-lists grub-pc grub-pc-bin grub2-common gstreamer1.0-clutter-3.0
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-good guake gucharmap gufw guvcview
  gvfs gvfs-backends gvfs-daemons gvfs-fuse hplip iio-sensor-proxy
  indicator-application indicator-application-gtk2 indicator-sound
  indicator-sound-gtk2 init initramfs-tools initramfs-tools-bin initramfs-tools-core
  inxi language-selector-common language-selector-gnome libappindicator3-1
  libapt-inst2.0 libapt-pkg5.0 libatasmart4 libavdevice57 libblockdev-fs2
  libblockdev-loop2 libblockdev-part2 libblockdev-swap2 libblockdev-utils2
  libblockdev2 libbluetooth3 libcanberra-gtk3-0 libcanberra-gtk3-module
  libchamplain-0.12-0 libchamplain-gtk-0.12-0 libclutter-1.0-0 libclutter-gst-3.0-0
  libclutter-gtk-1.0-0 libcogl-pango20 libcogl-path20 libcogl20 libcolord2
  libcolorhug2 libcryptsetup12 libdc1394-22 libdevmapper-event1.02.1
  libdevmapper1.02.1 libept1.5.0 libevdocument3-4 libevview3-3 libexo-1-0 libexo-2-0
  libfolks-eds25 libgail-3-0 libgcr-ui-3-1 libgjs0g libgl1-mesa-glx
  libgnome-desktop-3-17 libgnomekbd8 libgphoto2-6 libgphoto2-port12 libgpod-common
  libgspell-1-1 libgstreamer-gl1.0-0 libgtk-3-0 libgtk3-perl libgtkmm-3.0-1v5
  libgtksourceview-3.0-1 libgtkspell3-3-0 libgucharmap-2-90-7 libgudev-1.0-0
  libgusb2 libguvcview-2.0-2 libgweather-3-15 libhpmud0 libido3-0.1-0
  libindicator3-7 libinput-bin libinput10 libkeybinder-3.0-0 liblvm2app2.2
  liblvm2cmd2.02 libmbim-glib4 libmbim-proxy libmtp-runtime libmtp9
  libnautilus-extension1a libnemo-extension1 libnm0 libnma0 libnss-systemd
  libosinfo-1.0-0 libpam-systemd libparted-fs-resize0 libparted2 libpci3
  libpeas-1.0-0 libpisock9 libplymouth4 libqmi-glib5 libqmi-proxy libqt5gui5
  libqt5opengl5 libqt5printsupport5 libqt5quick5 libqt5svg5 libqt5webkit5
  libqt5widgets5 libqt5x11extras5 librhythmbox-core10 libsane-hpaio libsane1
  libsnmp30 libudev1 libusb-1.0-0 libvte-2.91-0 libwacom2 libwebkit2gtk-4.0-37
  libwnck-3-0 libxapp1 libxfce4panel-2.0-4 libxfce4ui-2-0 libyelp0 lightdm lvm2
  lxpolkit lxsession lxsession-default-apps lxsession-logout mate-calc
  media-player-info menulibre mintinstall mintinstall-flatpak-support mintstick
  mintupdate modemmanager mount mpv nautilus nemo nemo-dropbox nemo-fileroller
  nemo-gtkhash netplan.io network-manager network-manager-gnome nfs-common
  notification-daemon nplan ntfs-3g nvidia-driver-390 nvidia-settings obconf
  os-prober packagekit parted pavucontrol pciutils peppermint-control-center
  peppermint-default-session peppermint-default-settings peppermint-firefox-themer
  peppermint-panel-reset peppermint-scrot-helper peppermint-system
  peppermint-system-sounds peppermint-thunderbird-themer phantomjs pinentry-gnome3
  plymouth plymouth-label plymouth-theme-peppermint-9
  plymouth-theme-peppermint-9-text plymouth-theme-ubuntu-text policykit-1
  policykit-1-gnome printer-driver-gutenprint printer-driver-hpcups
  printer-driver-splix pulseaudio pulseaudio-equalizer pulseaudio-module-bluetooth
  python-apt python-parted python3-apt python3-aptdaemon
  python3-aptdaemon.gtk3widgets python3-commandnotfound python3-distupgrade
  python3-software-properties python3-update-manager qbittorrent
  qt5-gtk-platformtheme qt5-style-plugins rhythmbox
  rhythmbox-plugin-alternative-toolbar rhythmbox-plugins sakura
  screen-resolution-extra simple-scan slick-greeter snapd software-properties-common
  software-properties-gtk synaptic system-config-printer
  system-config-printer-common systemd systemd-sysv sysvinit-utils timeshift
  tracker-extract tracker-miner-fs transmission-gtk ubuntu-drivers-common
  ubuntu-release-upgrader-core udev udisks udisks2 unattended-upgrades
  update-manager-core update-notifier-common upower usb-modeswitch usbutils
  util-linux virtualbox virtualbox-qt vlc vlc-plugin-base vlc-plugin-notify
  vlc-plugin-qt vlc-plugin-skins2 webhttrack xapps-common xdg-desktop-portal
  xdg-desktop-portal-gtk xdg-user-dirs-gtk xed xfce4-appfinder xfce4-notifyd
  xfce4-panel xfce4-power-manager xfce4-power-manager-plugins
  xfce4-pulseaudio-plugin xfce4-screenshooter xfce4-settings
  xfce4-whiskermenu-plugin xfce4-xkb-plugin xfpanel-switch xserver-xorg-core
  xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-video-all
  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-nvidia-390
  xserver-xorg-video-qxl xserver-xorg-video-radeon xserver-xorg-video-vesa
  xserver-xorg-video-vmware xviewer yad yelp zenity
The following NEW packages will be installed:
  libgl1-mesa-glx:i386 libudev1:i386
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt libapt-pkg5.0 (due to apt) init systemd-sysv (due to init) mount
  util-linux (due to mount) sysvinit-utils libudev1 (due to util-linux)
0 upgraded, 2 newly installed, 389 to remove and 0 not upgraded.
Need to get 61,5 kB of archives.
After this operation, 877 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?] yes
Abort.
[close]

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Why is Steam not Avaliable ?
« Reply #5 on: March 09, 2019, 05:28:28 pm »
Okay I hope you aborted.

Have you tried the direct Valve download ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline FERE

  • nOOb
  • *
  • Posts: 18
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): DISTRIB_RELEASE=9
Re: Why is Steam not Avaliable ?
« Reply #6 on: March 10, 2019, 01:48:25 am »
Okay I hope you aborted.

Have you tried the direct Valve download ?

yes i took a look

all i can see is for windows and mac  did not see option for Linux

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 3749
  • Karma: 825
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Why is Steam not Avaliable ?
« Reply #7 on: March 10, 2019, 05:13:55 am »
It's the big blue button that says "Install Steam" on this page:

https://store.steampowered.com/about/

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Why is Steam not Avaliable ?
« Reply #8 on: March 10, 2019, 06:40:17 am »
Click the big blue button scifidude79 linked to .. that should download a file called steam_latest.deb

Once you have the steam_latest.deb file, double-click it to install.

Here's a direct link to the download if it helps, but as it's a CDN I can't guarantee the link will stay statically active permanently .. which is why the big blue button at scifidude79's link is the best way to download the .deb file
https://steamcdn-a.akamaihd.net/client/installer/steam.deb
« Last Edit: March 10, 2019, 06:42:02 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline FERE

  • nOOb
  • *
  • Posts: 18
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): DISTRIB_RELEASE=9
Re: Why is Steam not Avaliable ?
« Reply #9 on: March 10, 2019, 10:25:50 am »
It's the big blue button that says "Install Steam" on this page:

https://store.steampowered.com/about/

Thanks man It worked


 :) :) :) :) :) :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: (SOLVED) Why is Steam not Avaliable ?
« Reply #10 on: March 10, 2019, 01:08:10 pm »
Glad to hear it :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec