Choose style:

Author Topic: foreign language input with ibus[SOLVED]  (Read 110 times)

0 Members and 1 Guest are viewing this topic.

Offline hela

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
foreign language input with ibus[SOLVED]
« on: February 23, 2019, 07:20:26 am »
Hello

I would like to be able to type in more than one language - namely English and Korean and switch between the two easily. I also have a Raspberry Pi and on there what i did was install ibus with
Code: [Select]
sudo apt-get install ibus im-config ibus-hangul

+ the fonts and it worked. I tried the same on peppermint and while the same icons and settings appear, I just cannot type in Korean. I tried also installing the ibus m17n engine via synaptic package manager and again, the icon appears where it should but it doesn't work.

What do I need to configure? Also, I have a Lenovo Ideapad S12, running peppermint 9 32-bit version.

Thank you for your help
« Last Edit: February 23, 2019, 05:33:55 pm by hela »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: foreign language input with ibus
« Reply #1 on: February 23, 2019, 12:43:38 pm »
What's wrong with just adding the Korean language support, then using the keyboard layout selector that's on the bottom panel by default ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline alynur

  • Trusted User
  • Member
  • *****
  • Posts: 847
  • Karma: 42
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9 (64bit), P 9 R
Re: foreign language input with ibus
« Reply #2 on: February 23, 2019, 12:43:57 pm »
Hello hela, welcome to Peppermint, have you tried in Peppermint Settings Panel? Go to Settings→Peppermint Settings Panel→User→Keyboard Settings→Layout. There you can add the language settings you want. I personally need to find a layout that has the "/" reversed, I don't have that in my keyboard.
What was I thinking?

Offline hela

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: foreign language input with ibus
« Reply #3 on: February 23, 2019, 03:54:57 pm »
What's wrong with just adding the Korean language support, then using the keyboard layout selector that's on the bottom panel by default ?

I'm sorry I didn't know I have to install language support as well. Thank you for your answer. That + selecting Ibus as the Keyboard input method system worked.
« Last Edit: February 23, 2019, 05:34:21 pm by hela »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23555
  • Karma: 2616
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: foreign language input with ibus
« Reply #4 on: February 23, 2019, 04:15:54 pm »
Great news, glad you got it working :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec