Choose style:

Author Topic: Audio Headache [Solved]  (Read 1369 times)

0 Members and 1 Guest are viewing this topic.

Offline gerj

  • nOOb
  • *
  • Posts: 19
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Audio Headache [Solved]
« on: February 07, 2019, 12:24:16 pm »
I am TRYING to come to terms with Peppermint 9 after switching from Win 7.
I like the OS, look and feel HOWEVER ... my audio is AWFUL!  I get lotz of crackling and pops (Cs&Ps). 
The sound works, I can hear all audio its just the interfering Cs&Ps.  They are intermittent .
I have a generic computer with onboard graphics (AMD Radeon R7) and sound (HD Audio).
Have tried loading Realtek driver (instructions found online) but failed miserably.
Is there anyone out there willing to take a poor ol' man by the hand and walk him through the linux jungle to find the pastures of mellow music and GREAT sounds?
BTW, I'm an absolute novice when it comes to command line programing.

Thanks in advance
gerj
 
« Last Edit: February 22, 2019, 06:23:25 am by gerj »

Offline alynur

  • Trusted User
  • Member
  • *****
  • Posts: 984
  • Karma: 54
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Audio Headache
« Reply #1 on: February 07, 2019, 12:58:41 pm »
Hi gerj, welcome to Peppermint. First of all, we are going to need to know what we are dealing with. Give us your computer specs by copying and pasting this command in the terminal.
Code: [Select]
inxi -Fz
oops, had a brain fart, fixed it
Then copy the terminal output and paste it back here encapsulated by the code function. the box with the # sign above the  :-[ character. Maybe we can figure something out.
« Last Edit: February 07, 2019, 01:01:21 pm by alynur »
What was I thinking?

Offline gerj

  • nOOb
  • *
  • Posts: 19
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Audio Headache
« Reply #2 on: February 07, 2019, 01:06:59 pm »
Here it is ...
Code: [Select]
gerj@gerj ~ $ inxi -Fz
System:    Host: gerj Kernel: 4.15.0-45-generic x86_64 bits: 64 Desktop: N/A
           Distro: Peppermint Nine
Machine:   Device: desktop System: Gigabyte product: N/A serial: N/A
           Mobo: Gigabyte model: F2A68HM-HD2 v: x.x serial: N/A
           UEFI: American Megatrends v: FB date: 04/22/2015
CPU:       Quad core AMD A8-7650K Radeon R7 10 Compute Cores 4C+6G (-MCP-)
           cache: 8192 KB
           clock speeds: max: 3300 MHz 1: 1906 MHz 2: 1903 MHz 3: 1895 MHz
           4: 1895 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1024x768@60.00hz
           OpenGL: renderer: AMD KAVERI (DRM 2.50.0, 4.15.0-45-generic, LLVM 7.0.0)
           version: 4.5 Mesa 18.2.2
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Kaveri HDMI/DP Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-45-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 160.0GB (7.5% used)
           ID-1: /dev/sda model: WDC_WD1600BEVT size: 160.0GB
Partition: ID-1: / size: 146G used: 12G (9%) fs: ext4 dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 1.8C mobo: N/A gpu: 3.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 200 Uptime: 2:20 Memory: 923.8/14977.6MB
           Client: Shell (bash) inxi: 2.3.56
gerj@gerj ~ $
« Last Edit: February 07, 2019, 04:42:28 pm by zebedeeboss »

Offline Specter

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • C#, Cryptocurrency, Finance.
    • View Profile
  • Peppermint version(s): 9
Re: Audio Headache
« Reply #3 on: February 07, 2019, 01:07:46 pm »
Hello, there!

I usually fix mine by restarting pulseaudio in the terminal. The crackles and pops usually stop.

to stop the program
Code: [Select]
pulseaudio -k

and to start it again
Code: [Select]
pulseaudio --start

See if this fix it.
"forever is composed entirely of nows"

Offline gerj

  • nOOb
  • *
  • Posts: 19
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Audio Headache
« Reply #4 on: February 07, 2019, 01:15:02 pm »
Hello, there!

I usually fix mine by restarting pulseaudio in the terminal. The crackles and pops usually stop.

to stop the program
Code: [Select]
pulseaudio -k

and to start it again
Code: [Select]
pulseaudio --start

See if this fix it.


Thanks for the tip ... it helps but not completely.  Hopefully I'll get a permanent fix but if not at least this will make Peppermint life more bearable.  Thanks

Offline Specter

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • C#, Cryptocurrency, Finance.
    • View Profile
  • Peppermint version(s): 9
Re: Audio Headache
« Reply #5 on: February 07, 2019, 01:18:30 pm »
You are welcome. I'm waiting on a permanent fix too. I'm sorry I forgot to mention that. Restarting pulseaudio usually fixes the crackles everytime they occur.
"forever is composed entirely of nows"

Offline gerj

  • nOOb
  • *
  • Posts: 19
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Audio Headache
« Reply #6 on: February 14, 2019, 01:25:11 pm »
Hmmmm, guess no help from the OS Team!  Shame, I quite like Peppermint. :(

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5177
  • Karma: 939
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Audio Headache
« Reply #7 on: February 14, 2019, 02:17:29 pm »
I'm building an Intel/AMD rig with a Radeon R9 graphics card (Hawaii HDMI Audio). However, I'm using the Intel HD Audio Controller for sound.

Spoiler (click here to view / hide)
vindsl@Ulyoth ~ $ sudo inxi -Fxxxz
System:    Host: Ulyoth Kernel: 4.15.0-45-generic x86_64 bits: 64 gcc: 7.3.0 Console: tty 0 dm: lightdm
           Distro: Peppermint Nine
Machine:   Device: desktop Mobo: ASUSTeK model: P5Q PRO TURBO v: Rev 1.xx serial: <filter>
           BIOS: American Megatrends v: 0602 date: 08/04/2009
CPU:       Quad core Intel Core2 Quad Q9650 (-MCP-) arch: Penryn rev.10 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 23996
           clock speeds: max: 2974 MHz 1: 2726 MHz 2: 2574 MHz 3: 2845 MHz 4: 2974 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Hawaii XT / Grenada XT [Radeon R9 290X/390X]
           bus-ID: 01:00.0 chip-ID: 1002:67b0
           Display Server: X.Org 1.19.6 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1200@59.95hz
           OpenGL: renderer: AMD HAWAII (DRM 2.50.0, 4.15.0-45-generic, LLVM 7.0.0)
           version: 4.5 Mesa 18.2.2 (compat-v: 4.4) Direct Render: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 1002:aac8
           Card-2 Intel 82801JI (ICH10 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:3a3e
           Sound: Advanced Linux Sound Architecture v: k4.15.0-45-generic
Network:   Card: Intel 82541PI Gigabit Ethernet Controller
           driver: e1000 v: 7.3.21-k8-NAPI port: ec00 bus-ID: 05:01.0 chip-ID: 8086:107c
           IF: enp5s1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1250.3GB (11.4% used)
           ID-1: /dev/sda model: Samsung_SSD_860 size: 250.1GB serial: <filter> temp: 0C
           ID-2: /dev/sdb model: SAMSUNG_HD103SJ size: 1000.2GB serial: <filter> temp: 29C
Partition: ID-1: / size: 20G used: 5.8G (32%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 59G used: 1009M (2%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 0.54GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 32.0C mobo: 22.0C gpu: 37.0
           Fan Speeds (in rpm): cpu: 1125 psu: 0 sys-1: 0 sys-2: 0
Info:      Processes: 181 Uptime: 6 min Memory: 680.0/3944.5MB Init: systemd v: 237 runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (sudo running in bash) inxi: 2.3.56
vindsl@Ulyoth ~ $
[close]

I just turned up the volume and tested the sound quality on a BlackPink video (664M views), but didn't notice any crackling.



Guess we need to find someone that has an all-AMD rig for some debugging...

Offline gerj

  • nOOb
  • *
  • Posts: 19
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Audio Headache
« Reply #8 on: February 14, 2019, 06:12:56 pm »
Well, to be honest, as my computer has (integrated) onboard graphics and HD audio I tried updating the graphics driver to AMDGPU-PRO (from the AMD website) and it has helped considerably.  I still have some C&Ps but not near as much.  I won't be happy until I have crystal clear audio as I'm on my computer all the time and rely on it for music and videos.

Do you have a driver for the Intel HD audio controller?

gerj

PS - Like the video too.

« Last Edit: February 14, 2019, 06:17:01 pm by gerj »

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1937
  • Karma: 335
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Audio Headache
« Reply #9 on: February 14, 2019, 06:56:32 pm »
I won't be happy until I have crystal clear audio

If you're really serious about that, you might want to look into getting an asynchronous USB DAC and even powering it through a hub to isolate it from the PC's power supply.

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5177
  • Karma: 939
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Audio Headache
« Reply #10 on: February 14, 2019, 11:27:36 pm »
If you're really serious about that, you might want to look into getting an asynchronous USB DAC and even powering it through a hub to isolate it from the PC's power supply.

Agreed! I was thinking along the same lines.  ;)

If I was worried about sound quality, I'd even consider dropping 60 bucks and buying an Audigy RX sound card.

Picked at random:  https://goo.gl/64gTZt

These cards have been around forever, and mature Linux drivers are available.


Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25286
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Audio Headache
« Reply #11 on: February 15, 2019, 06:18:04 am »
The driver for intel hd audio is in the kernel .. you could try a more recent kernel, or maybe a low-latency kernel
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gerj

  • nOOb
  • *
  • Posts: 19
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Audio Headache
« Reply #12 on: February 15, 2019, 06:00:51 pm »
To be honest, I never heard of the USB DAC card would hate to spend money only to amplify the crackling and pops.  But a different sound card is a possibility.  You recon this one is compatible with Peppermint?
As I said, I'm coming to terms with linux (migrating from windows), so am a novice when it comes to the terminal commands.  have managed a few tasks with help from you tube and various websites.  Don't know how to go about changing kernels ... tis all greek to me.

I JUST WANT CLEAR SOUND!!!   >:(

And I thank you for all the advice.

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1937
  • Karma: 335
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Audio Headache
« Reply #13 on: February 15, 2019, 06:31:54 pm »
A DAC (Digital to Analogue Converter) is like an output-only sound card. You can get ones that plug into a USB socket.
https://www.amazon.com/s/ref=nb_sb_noss_2?url=search-alias%3Daps&field-keywords=usb+dac&rh=i%3Aaps%2Ck%3Ausb+dac

It's a step up from the cheapo 5 USB audio adaptors so you could test one of those first to see if it was any better before spending any serious dough. I'm thinking your integrated audio might be the cause of the problem.
https://www.amazon.com/s/ref=nb_sb_noss_2?url=search-alias%3Daps&field-keywords=usb+audio&rh=i%3Aaps%2Ck%3Ausb+audio

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1823
  • Karma: 250
    • View Profile
Re: Audio Headache
« Reply #14 on: February 16, 2019, 02:24:08 am »
Changing the kernel is rather straight forward. I do it nearly every week 'cause I like to test if/when things break  :)
The issue here is rather, which kernel(s) to try?  :-\  :-\