Choose style:

Author Topic: [SOLVED] NFS shares in fstab not mounting at boot  (Read 395 times)

0 Members and 1 Guest are viewing this topic.

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1932
  • Karma: 335
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
[SOLVED] NFS shares in fstab not mounting at boot
« on: January 17, 2019, 11:23:35 am »
This is a Peppermint 9 (original) install. I've got two NAS folders set to mount at boot but they often don't until I run sudo mount -a

The PC is connecting to the router over wireless. I don't have any problem with hanging either at boot or shutdown (and I haven't applied the fix for the shutdown hang).

The two folders both have different options in fstab; I can't remember where I got those options from.

Code: [Select]
192.168.1.21:/mnt/video /home/tom/Videos        nfs     auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
192.168.1.21:/mnt/4TB /home/tom/Music        nfs     auto,nofail,noatime

Any ideas how to make them automount 100% of the time?  :-\
« Last Edit: January 17, 2019, 12:28:59 pm by murraymint »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25266
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: NFS shares in fstab not mounting at boot
« Reply #1 on: January 17, 2019, 12:08:54 pm »
Okay for comparison, here's one of my NFS entries
Code: [Select]
192.168.1.99:/data/Share /mnt/readynas/share nfs noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min,rsize=32768,wsize=32768,intr,noatime 0 0
It may slow boot a little whilst it waits for networking to become active (specially wireless), but it seems to work for me.
« Last Edit: January 17, 2019, 12:10:47 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1932
  • Karma: 335
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: [SOLVED] NFS shares in fstab not mounting at boot
« Reply #2 on: January 17, 2019, 12:29:52 pm »
Thanks, I've done it that way and it fixed it :)  There might be a few seconds' delay but it's better than having to open a terminal just to mount them.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25266
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: [SOLVED] NFS shares in fstab not mounting at boot
« Reply #3 on: January 17, 2019, 02:20:00 pm »
No problem, happy it works for you too :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec