Author Topic: show desktop not working in p9 (SOLVED)  (Read 676 times)

Offline joao.p

  • Newly Subscribed
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9R
show desktop not working in p9 (SOLVED)
« on: January 15, 2019, 10:20:44 am »
Hi there,
please could someone confirm that Super+M is not working when hooked to show_desktop_key
(Peppermint Control Center - Keyboard Shortcuts - Window Manager Shortcuts).
It only works until reboot, when the old Ctrl+Alt+D takes control.
It works after reboot when hooked to an application instead.
Just trying to replicate the WinXP "Minimize all windows" shortcut.
It was all OK in P5.
« Last Edit: January 16, 2019, 10:14:41 am by PCNetSpec »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: show desktop not working in p9
« Reply #1 on: January 15, 2019, 10:45:22 am »
What's the output from
Code: [Select]
grep desktop ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline joao.p

  • Newly Subscribed
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9R
Re: show desktop not working in p9
« Reply #2 on: January 15, 2019, 08:24:22 pm »
What's the output from
Code: [Select]
grep desktop ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
Code: [Select]
<property name="&lt;Super&gt;m" type="string" value="show_desktop_key"/>

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: show desktop not working in p9
« Reply #3 on: January 16, 2019, 06:46:24 am »
Currently "show desktop" should be mapped to Ctrl+Alt+D .. but if you also want it mapped to Super+M keep reading...

Okay run:
Code: [Select]
gksudo xed /usr/bin/peppermint_show_desktopwhen a BLANK file opens, make it read
Code: [Select]
#!/bin/sh
if xprop -root  _NET_SHOWING_DESKTOP|egrep '= 1' ; then
      wmctrl -k off ;
    else
      wmctrl -k on ;
    fi
SAVE the file and exit the text editor.

Back in the terminal make that executable with
Code: [Select]
sudo chmod +x /usr/bin/peppermint_show_desktopnow open up your xbindkeys config file for editing
Code: [Select]
xed ~/.config/peppermint-control-center/xbindkeys.confand add this new section at the bottom
Code: [Select]
"peppermint_show_desktop"
    Mod4+m
SAVE the file .. now log off/on before testing.
« Last Edit: January 16, 2019, 06:54:03 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline joao.p

  • Newly Subscribed
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9R
Re: show desktop not working in p9 [SOLVED]
« Reply #4 on: January 16, 2019, 08:18:57 am »
Works OK now, thank you.
I know about Ctrl+Alt+D, but I've been using Windows+M since I moved from DOS to Win
in the last century.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: show desktop not working in p9
« Reply #5 on: January 16, 2019, 10:13:59 am »
NP :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec