Choose style:

Author Topic: Disable key on "Starting up..." splash screen [SOLVED]  (Read 459 times)

0 Members and 1 Guest are viewing this topic.

Offline brunok

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Disable key on "Starting up..." splash screen [SOLVED]
« on: January 13, 2019, 09:32:29 am »
Hi!

I have a old laptop and search on google for "lightweight distros 2019".

I found Peppermint OS! Good!
Installed!

i have troubles with "DELETE KEY" and need disable it.

Already disabled with "xmodmap -e "keycode 91 = "", but, in "Starting up..." splash screen, the screen blinks and cause issues on startup.  >:(

Found plymouth config, but, its show only "Restart" and "Stop".

Where I find the setting that launches the "Starting up ..." screen, so I add xmodmap too?
« Last Edit: January 14, 2019, 04:00:19 pm by brunok »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25684
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Disable key on "Starting up..." splash screen
« Reply #1 on: January 13, 2019, 04:26:14 pm »
As far as I'm aware you're not going to be able to tell the X server to modify the keymap before the X server is running.

I know you can modify keyboard layouts and mapping in the console (though this is quite independent of  X and ONLY applies to the console, so would need to run alongside xmpomap):
https://superuser.com/questions/290115/how-to-change-console-keymap-in-linux
I'm not sure how early in the boot process even this would kick in.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline brunok

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Disable key on "Starting up..." splash screen
« Reply #2 on: January 14, 2019, 03:57:16 pm »
SOLVED!

I disabled the "splash" parameter kernel in grub.


OS starting in text mode and /etc/init.d/udev load with my hack to disable my broken DEL key...


 :D :D :D

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25684
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Disable key on "Starting up..." splash screen [SOLVED]
« Reply #3 on: January 14, 2019, 04:16:26 pm »
Nice, glad you figured it out :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec