Author Topic: Megasync panel icon not showing status  (Read 2507 times)

Offline emegra

  • Administrator
  • Veteran
  • *****
  • Posts: 1946
  • Karma: 450
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10 64bit
Megasync panel icon not showing status
« on: January 13, 2019, 01:32:06 am »
Hi guys

This is not really a big issue but I'm just curious if anyone else who uses Megasync is having the same problem

When I right click on the Megasync icon on the panel I'm given 3 choices Show Status, Settings & Exit, Settings and Exit works fine but clicking on Show Status does absolutely nothing, however if I place the icon on the Desktop a left click will launch the show status box


Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5829
  • Karma: 1131
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Megasync panel icon not showing status
« Reply #1 on: January 13, 2019, 10:56:00 am »
No probs here, Graeme...




EDIT


Just had my first cup of coffee and reread your post.

Yes, I have the same problem. Clicking 'Show status' doesn't show jack.

Plus, if you mouse-over the icon, the status graphic is working, but it's ghosted  :-\



« Last Edit: January 13, 2019, 11:20:18 am by VinDSL »

Offline emegra

  • Administrator
  • Veteran
  • *****
  • Posts: 1946
  • Karma: 450
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10 64bit
Re: Megasync panel icon not showing status
« Reply #2 on: January 13, 2019, 12:07:20 pm »
Quote
Plus, if you mouse-over the icon, the status graphic is working, but it's ghosted

Same here  ???



Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Megasync panel icon not showing status
« Reply #3 on: January 13, 2019, 01:05:36 pm »
Any idea what the status is supposed to display ?

Could it be expectingr nautilus maybe ?

If so, maybe symlinking nautilus --> nemo would help .. just thinking out loud.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline emegra

  • Administrator
  • Veteran
  • *****
  • Posts: 1946
  • Karma: 450
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10 64bit
Re: Megasync panel icon not showing status
« Reply #4 on: January 13, 2019, 01:13:21 pm »
Quote
Any idea what the status is supposed to display ?

It shows used storage (ie I've used 4% of 50GB) it also show sync progress if files are currently syncing, it has a settings menu etc

I would show a screenshot but it wont allow me when it's open


Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Megasync panel icon not showing status
« Reply #5 on: January 13, 2019, 01:28:29 pm »
Can't you use the screenshot tool to take a screenshot with a delay .. then open the status, and wait for the screenshot ?

But I'm confused .. how can you show me if it's not working ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline emegra

  • Administrator
  • Veteran
  • *****
  • Posts: 1946
  • Karma: 450
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10 64bit
Re: Megasync panel icon not showing status
« Reply #6 on: January 13, 2019, 01:37:42 pm »
Quote
Can't you use the screenshot tool to take a screenshot with a delay .. then open the status, and wait for the screenshot ?

Yep that worked :)


Quote
But I'm confused .. how can you show me if it's not working ?

I can get it to work by placing the Megasync icon on the desktop and left clicking it doesn't work from the panel , I tried to explain that in my first post


Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5829
  • Karma: 1131
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Megasync panel icon not showing status
« Reply #7 on: January 13, 2019, 04:09:45 pm »
Discovered a piece to the puzzle...

I've been checking various machines, and the only rig I've found it working on is my 32bit LANParty gamer.

Same machine, with the same installed Megasync version works on 32bit Peppermint 7, but not 32bit Peppermint 9  :-\


Code: [Select]
╭─vindsl@Boogaloo-6 ~ 
╰─➤  apt-cache policy megasync                     
megasync:
  Installed: 3.7.1+3.1
  Candidate: 3.7.1+3.1
  Version table:
 *** 3.7.1+3.1 500
        500 https://mega.nz/linux/MEGAsync/xUbuntu_16.04 ./ Packages
        100 /var/lib/dpkg/status
╭─vindsl@Boogaloo-6 ~ 
╰─➤




Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Megasync panel icon not showing status
« Reply #8 on: January 13, 2019, 05:09:53 pm »
I'm pretty sure I have a mega account .. I'll see if I can remember my login details (haven't used it for ages).

@VinDSL

which version of xfce4-panel is PM7 runnin ?

Wonder if this has anything to do with the automounter (though I can't see how) .. did PM7 have that ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5829
  • Karma: 1131
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Megasync panel icon not showing status
« Reply #9 on: January 13, 2019, 08:01:24 pm »
Been getting rid of that #$%! Linux 4.20.x for a couple of hours, and washing, rinsing and restyling Conky  -  just shut it down. Hold on...  :)

Okay, it's 'xfce-panel 4.12.0'

Megasync is still working fine on the disco-proposed 4.19 LTS kernel. Just saying...


EDIT


BTW, I can't find any automounter in PM7...

« Last Edit: January 13, 2019, 08:34:14 pm by VinDSL »

Offline VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5829
  • Karma: 1131
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Megasync panel icon not showing status
« Reply #10 on: January 13, 2019, 10:50:23 pm »
OMG!  I just spent 3 hours shoehorning the 32bit Xenial ver into my 32bit Disco-powered PM9R2 install.

I basically had to build my own custom 32bit Megasync package, one piece at a time.

Had to get that off my chest, as the Chief would say... ;D

Anyway, guess what?!?! The feking status window works just fine, on my 2004 32bit doorstop Dell Dimension 3000



Offline VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5829
  • Karma: 1131
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Megasync panel icon not showing status
« Reply #11 on: January 13, 2019, 11:05:24 pm »
If I had to guess - having just gone through a total shiz storm - I imagine what happened is, one or more of the core depends got updated recently, and nobody noticed the bugs until now.

There are some heavy hitters in that Megasync client - encryption crap and so forth. It wouldn't take much to bring the whole house of cards down.



« Last Edit: January 13, 2019, 11:43:21 pm by VinDSL »

Offline emegra

  • Administrator
  • Veteran
  • *****
  • Posts: 1946
  • Karma: 450
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10 64bit
Re: Megasync panel icon not showing status
« Reply #12 on: January 14, 2019, 12:27:21 am »
It works fine in PM8



 Is it possible this is a themeing issue I say that because although the "Settings" dialogue box opens from the panel icon the themeing is horrible compared to PM8 above






Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Megasync panel icon not showing status
« Reply #13 on: January 14, 2019, 01:28:28 pm »
Does
Code: [Select]
ldd $(which megasync)report any of its lib dependencies are missing ?
(you may wanna maximise the terminal to make the output easier to read)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline emegra

  • Administrator
  • Veteran
  • *****
  • Posts: 1946
  • Karma: 450
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10 64bit
Re: Megasync panel icon not showing status
« Reply #14 on: January 14, 2019, 01:33:08 pm »
Quote
Does
Code: [Select]

ldd $(which megasync)

report any of its lib dependencies are missing ?
(you may wanna maximise the terminal to make the output easier to read)

If I'm understanding the output correctly I'd say no dependencies missing

Spoiler (click here to view / hide)
[close]

Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation