Choose style:

Author Topic: Printer prints but won't scan (SOLVED)  (Read 399 times)

0 Members and 1 Guest are viewing this topic.

Offline arky217

  • Member
  • ***
  • Posts: 151
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Printer prints but won't scan (SOLVED)
« on: January 12, 2019, 08:37:37 pm »
I dual boot Peppermint 9 and MX Linux 18.
I have a Samsung all-in-one network printer, model ProXpress SL-M4070FR.
I installed the Linux printer and scanner drivers from Samsung on both os's.
Then installed the printer exactly the same way on both os's.
On MX Linux, printing and scanning work fine.
On Peppermint, printing works fine, but Peppermint doesn't see the scanner.
Using both gscan2pdf and simple scan, they say no scanner installed.

My computer specs are: (when in the MX os)

Spoiler (click here to view / hide)
System:    Host: mxonhp Kernel: 4.19.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0
           Desktop: Xfce 4.12.3 Distro: MX-18_x64 Continuum March 14  2018
           base: Debian GNU/Linux 9 (stretch)
Machine:   Type: Desktop System: HP product: 550-110 v: 1.00 serial: <filter>
           Mobo: HP model: 2B2C v: 1.01 serial: <filter> BIOS: AMI v: A0.02 date: 07/03/2015
CPU:       Topology: Dual Core model: Intel Core i3-4170 bits: 64 type: MT MCP arch: Haswell
           rev: 3 L2 cache: 3072 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 29531
           Speed: 799 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 802 2: 844 3: 798 4: 798
Graphics:  Device-1: Intel 4th Generation Core Processor Family Integrated Graphics
           vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0
           Display: x11 server: X.Org 1.19.2 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa DRI Intel Haswell v: 4.5 Mesa 18.2.6 direct render: Yes
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
           vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:03.0
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Hewlett-Packard
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0
           Sound Server: ALSA v: k4.19.0-1-amd64
Network:   Device-1: Broadcom Limited BCM43142 802.11b/g/n vendor: Hewlett-Packard driver: wl
           v: kernel port: f040 bus ID: 02:00.0
           IF: wlan0 state: down mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
           vendor: Hewlett-Packard driver: r8169 v: kernel port: e000 bus ID: 03:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 1.02 TiB used: 23.75 GiB (2.3%)
           ID-1: /dev/sda vendor: SanDisk model: SDSSDA120G size: 111.79 GiB
           ID-2: /dev/sdb vendor: Seagate model: ST1000DM003-1ER162 size: 931.51 GiB
Partition: ID-1: / size: 47.81 GiB used: 23.75 GiB (49.7%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 11.93 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 34.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list
           1: deb http://la.mxrepo.com/antix/stretch stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
           1: deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list
           1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
           1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/mx.list
           1: deb http://mxrepo.com/mx/repo/ stretch main non-free
           Active apt repos in: /etc/apt/sources.list.d/opera-stable.list
           1: deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
           Active apt repos in: /etc/apt/sources.list.d/teamviewer.list
           1: deb http://linux.teamviewer.com/deb stable main
           No active apt repos in: /etc/apt/sources.list.d/various.list
Info:      Processes: 210 Uptime: 1h 28m Memory: 11.66 GiB used: 893.9 MiB (7.5%) Init: SysVinit
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.29
[close]


Any ideas why Peppermint doesn't see the scanner ?

(If it would help, I could show system specs while in Peppermint,
just happened to post this while in MX)
« Last Edit: February 05, 2019, 08:57:08 pm by arky217 »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24514
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Printer prints but won't scan
« Reply #1 on: January 13, 2019, 04:12:21 pm »
How is the printer/scanner connected ? .. ethernet/wireless/USB ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline arky217

  • Member
  • ***
  • Posts: 151
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Printer prints but won't scan
« Reply #2 on: January 14, 2019, 09:47:34 am »
How is the printer/scanner connected ? .. ethernet/wireless/USB ?

Ethernet connection.

Thank you for your reply.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24514
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Printer prints but won't scan
« Reply #3 on: January 14, 2019, 05:24:32 pm »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline arky217

  • Member
  • ***
  • Posts: 151
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Printer prints but won't scan
« Reply #4 on: February 05, 2019, 08:56:22 pm »
Finally found a solution to my scanner problem after much searching on the web.

On both Peppermint and Xubuntu, the scanner was not seen but on MX Linux
it worked.

The solution was to edit     /etc/sane.d/xerox_mfp.conf 
and add a line that pointed to the static network address
that I set the scanner to. (printer is connected via ethernet port)

The line I added was    tcp 192.168.2.111
which is the static address of my printer.

After adding that line, the scanner works fine
in both Peppermint and Xubuntu.

Why MX Linux doesn't need that line (and it's not there in the MX file),
I don't know. Maybe it has something to do with MX being based on Debian
and Peppermint and Xubuntu being based on Ubuntu.

At any rate, the scanner works now on P. & X. and I imagine would
work also on other Ubuntu based OS's.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24514
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Printer prints but won't scan (SOLVED)
« Reply #5 on: February 06, 2019, 06:07:47 am »
Great bit of deduction Sherlock :) .. thanks for taking the time to post the solution so others can benefit from your research.
« Last Edit: February 06, 2019, 06:09:35 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec