Choose style:

Author Topic: RDP from Win 10 toP9 (Solved for my needs)  (Read 1426 times)

0 Members and 1 Guest are viewing this topic.

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
RDP from Win 10 toP9 (Solved for my needs)
« on: January 10, 2019, 10:06:31 am »
I am trying to RDP from Windows 10 to a P9 box and only getting a black screen. I have xrdp installed on the P9 machine and am wanting to use the stock Remote desktop connection app on the Windows machine. What am I missing? Or is there an easier way? Teamviewer is my first choice for personal use, but don't have that option since this machine is also accessed by coworkers. When I open the connection I get the xrdp splash and am using the Xorg session choice. Other session options are; X11rdp, Xvnc, console, vnc-any, sesman-any, and neutrinordp-any.   :-\
Am I missing configs on the P9 machine?
Thanks
« Last Edit: March 19, 2019, 11:49:36 am by MNFrozenfish »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: RDP from Win 10 toP9
« Reply #1 on: January 10, 2019, 12:42:09 pm »
if you've already installed xrdp, it needs to be told which session and DE to start...

Try running
Code: [Select]
sudo sed -i.bak '/fi/a #xrdp multiple users configuration \n lxsession -s Peppermint -e LXDE \n' /etc/xrdp/startwm.sh
on the Peppermint box.
(may require a reboot .. dunno, I've never used it)

Now see if you can log in via RDP ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
Re: RDP from Win 10 toP9
« Reply #2 on: January 10, 2019, 12:59:42 pm »
No luck, still blank screen.
Ctrl+Alt+T opens terminal on P9 machine in remote window but the desktop does not display. Command to load/show desktop?
I was able to run sudo apt-get update with no errors.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: RDP from Win 10 toP9
« Reply #3 on: January 10, 2019, 01:09:06 pm »
Okay lets undo that change, run:
Code: [Select]
sudo xed /etc/xrdp/startwm.sh
and make it read
Code: [Select]
#!/bin/sh

if [ -r /etc/default/locale ]; then
  . /etc/default/locale
  export LANG LANGUAGE
fi

. /etc/X11/Xsession
SAVE the file and exit the text editor.

Back in the terminal run
Code: [Select]
xed ~/.xsession
and when a BLANK file opens, make it read
Code: [Select]
lxsession -s Peppermint -e LXDE
SAVE the file, and exit the text editor.

Now restart xrdp
Code: [Select]
sudo service xrdp restart
now try logging on from Windows
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
Re: RDP from Win 10 toP9
« Reply #4 on: January 10, 2019, 01:21:04 pm »
That file contains:
Spoiler (click here to view / hide)
#!/bin/sh
# xrdp X session start script (c) 2015, 2017 mirabilos
# published under The MirOS Licence

if test -r /etc/profile; then
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

#xrdp multiple users configuration
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

 lxsession -s Peppermint -e LXDE

   . /etc/profile
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

#xrdp multiple users configuration
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

 lxsession -s Peppermint -e LXDE

fi
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

#xrdp multiple users configuration
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

 lxsession -s Peppermint -e LXDE


if test -r /etc/default/locale; then
   . /etc/default/locale
   test -z "${LANG+x}" || export LANG
   test -z "${LANGUAGE+x}" || export LANGUAGE
   test -z "${LC_ADDRESS+x}" || export LC_ADDRESS
   test -z "${LC_ALL+x}" || export LC_ALL
   test -z "${LC_COLLATE+x}" || export LC_COLLATE
   test -z "${LC_CTYPE+x}" || export LC_CTYPE
   test -z "${LC_IDENTIFICATION+x}" || export LC_IDENTIFICATION
   test -z "${LC_MEASUREMENT+x}" || export LC_MEASUREMENT
   test -z "${LC_MESSAGES+x}" || export LC_MESSAGES
   test -z "${LC_MONETARY+x}" || export LC_MONETARY
   test -z "${LC_NAME+x}" || export LC_NAME
   test -z "${LC_NUMERIC+x}" || export LC_NUMERIC
   test -z "${LC_PAPER+x}" || export LC_PAPER
   test -z "${LC_TELEPHONE+x}" || export LC_TELEPHONE
   test -z "${LC_TIME+x}" || export LC_TIME
   test -z "${LOCPATH+x}" || export LOCPATH
fi
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

#xrdp multiple users configuration
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

 lxsession -s Peppermint -e LXDE


if test -r /etc/profile; then
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

#xrdp multiple users configuration
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

 lxsession -s Peppermint -e LXDE

   . /etc/profile
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

#xrdp multiple users configuration
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

 lxsession -s Peppermint -e LXDE

fi
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

#xrdp multiple users configuration
#xrdp multiple users configuration
 lxsession -s Peppermint -e LXDE

 lxsession -s Peppermint -e LXDE


test -x /etc/X11/Xsession && exec /etc/X11/Xsession
exec /bin/sh /etc/X11/Xsession
[close]
Should I be replacing all the text with the first step?

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: RDP from Win 10 toP9
« Reply #5 on: January 10, 2019, 01:27:03 pm »
replace it with JUST what I said.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
Re: RDP from Win 10 toP9
« Reply #6 on: January 10, 2019, 01:31:44 pm »
Same thing.  :(

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: RDP from Win 10 toP9
« Reply #7 on: January 10, 2019, 02:42:33 pm »
Maye it has something to do with the red text at step 2 here
http://c-nergy.be/blog/?p=10355

is the user account you're using to login already logged on locally ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
Re: RDP from Win 10 toP9
« Reply #8 on: January 10, 2019, 03:03:25 pm »
Yes, I can create another user and try logging in with those creds.
Will update when I get time to test.

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
Re: RDP from Win 10 toP9
« Reply #9 on: January 10, 2019, 03:11:51 pm »
Nope, still a black screen. terminal window opens as user logged in via xrdp but no desktop.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: RDP from Win 10 toP9
« Reply #10 on: January 10, 2019, 03:27:28 pm »
If you can open a terminal, what happens if you run
Code: [Select]
/usr/bin/lxsession -s Peppermint -e LXDE
in that terminal ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
Re: RDP from Win 10 toP9
« Reply #11 on: January 10, 2019, 03:41:23 pm »
todd@P9-Latitude-E6540 ~ $ /usr/bin/lxsession -s Peppermint -e LXDE
** Message: 14:37:00.512: main.vala:102: Session is Peppermint
** Message: 14:37:00.512: main.vala:103: DE is LXDE
** Message: 14:37:00.532: main.vala:134: log directory: /home/todd/.cache/lxsession/Peppermint
** Message: 14:37:00.532: main.vala:135: log path: /home/todd/.cache/lxsession/Peppermint/run.log
 
Same from RDP session terminal and local terminal. Neither one returns to a prompt.
Same from both users except log path has different user.
« Last Edit: January 10, 2019, 03:44:27 pm by MNFrozenfish »

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
Re: RDP from Win 10 toP9
« Reply #12 on: January 10, 2019, 03:57:29 pm »
xrdp also seems to keep open the RDP session when I disconnect.
Have you, or anyone else had any success with other apps like remmina or?

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: RDP from Win 10 toP9
« Reply #13 on: January 10, 2019, 05:09:49 pm »
It's been forever since I did anything like that .. on the odd occasion I need to connect to sommat remotely (with a desktop) now I just use teamviewer.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
Re: RDP from Win 10 toP9
« Reply #14 on: January 10, 2019, 05:18:21 pm »
Me too :D
Could it be a local firewall setting or permission issue? Both users have admin accounts.